aboutsummaryrefslogtreecommitdiff
path: root/audio/re
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-09-01 11:38:01 +0000
committerChris Rees <crees@FreeBSD.org>2012-09-01 11:38:01 +0000
commit9225b2fce97312250709706928be84137398baa6 (patch)
tree674016a5881506b277e985ce8334cf59c48f25f2 /audio/re
parent3b1d3c9f1e1277084de45c34a225f096772f9516 (diff)
downloadports-9225b2fce97312250709706928be84137398baa6.tar.gz
ports-9225b2fce97312250709706928be84137398baa6.zip
Libre is a portable and generic library for real-time communications
with async IO support and a complete SIP stack with support for SDP, RTP/RTCP, STUN/TURN/ICE, BFCP and DNS Client. Features: - SIP Stack (RFC 3261) - SDP - RTP and RTCP - DNS-Client - STUN/TURN/ICE - BFCP - Jitter-buffer - Async I/O (poll, epoll, select) - UDP/TCP/TLS transport WWW: http://www.creytiv.com/re.html
Notes
Notes: svn path=/head/; revision=303468
Diffstat (limited to 'audio/re')
-rw-r--r--audio/re/Makefile23
-rw-r--r--audio/re/distinfo2
-rw-r--r--audio/re/pkg-descr17
-rw-r--r--audio/re/pkg-plist45
4 files changed, 87 insertions, 0 deletions
diff --git a/audio/re/Makefile b/audio/re/Makefile
new file mode 100644
index 000000000000..7023116977eb
--- /dev/null
+++ b/audio/re/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= re
+PORTVERSION= 0.4.0
+CATEGORIES= audio devel
+MASTER_SITES= http://www.creytiv.com/pub/
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Library for real-time comms with async IO support
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+PORTDATA= re.mk
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/${PORTNAME} ${DATADIR}
+ (cd ${WRKSRC}/include && \
+ ${COPYTREE_SHARE} \*.h ${PREFIX}/include/${PORTNAME})
+ ${INSTALL_DATA} ${WRKSRC}/mk/${PORTNAME}.mk ${DATADIR}
+ ${INSTALL_LIB} ${WRKSRC}/lib${PORTNAME}.[sa]* ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/audio/re/distinfo b/audio/re/distinfo
new file mode 100644
index 000000000000..cf5ef259ec8b
--- /dev/null
+++ b/audio/re/distinfo
@@ -0,0 +1,2 @@
+SHA256 (re-0.4.0.tar.gz) = 1057da19d56dd44ca8d36202aeb5801f611bc9840840e19f55c4f17388de0683
+SIZE (re-0.4.0.tar.gz) = 252293
diff --git a/audio/re/pkg-descr b/audio/re/pkg-descr
new file mode 100644
index 000000000000..e194f0241ba3
--- /dev/null
+++ b/audio/re/pkg-descr
@@ -0,0 +1,17 @@
+Libre is a portable and generic library for real-time communications
+with async IO support and a complete SIP stack with support for SDP,
+RTP/RTCP, STUN/TURN/ICE, BFCP and DNS Client.
+
+Features:
+
+- SIP Stack (RFC 3261)
+- SDP
+- RTP and RTCP
+- DNS-Client
+- STUN/TURN/ICE
+- BFCP
+- Jitter-buffer
+- Async I/O (poll, epoll, select)
+- UDP/TCP/TLS transport
+
+WWW: http://www.creytiv.com/re.html
diff --git a/audio/re/pkg-plist b/audio/re/pkg-plist
new file mode 100644
index 000000000000..2e3fef03775f
--- /dev/null
+++ b/audio/re/pkg-plist
@@ -0,0 +1,45 @@
+include/re/re_net.h
+include/re/re_list.h
+include/re/re_hash.h
+include/re/re_stun.h
+include/re/re_tls.h
+include/re/re_lock.h
+include/re/re_base64.h
+include/re/re_bfcp.h
+include/re/re_sip.h
+include/re/re_dbg.h
+include/re/re_sys.h
+include/re/re_tmr.h
+include/re/re_types.h
+include/re/re_mbuf.h
+include/re/re_mem.h
+include/re/re_mqueue.h
+include/re/re_crc32.h
+include/re/re_main.h
+include/re/re_uri.h
+include/re/re_jbuf.h
+include/re/re_sipevent.h
+include/re/re_telev.h
+include/re/re_httpauth.h
+include/re/re_dns.h
+include/re/re_ice.h
+include/re/re_sdp.h
+include/re/re.h
+include/re/re_conf.h
+include/re/re_rtp.h
+include/re/re_md5.h
+include/re/re_fmt.h
+include/re/re_turn.h
+include/re/re_sipreg.h
+include/re/re_natbd.h
+include/re/re_bitv.h
+include/re/re_sa.h
+include/re/re_sha.h
+include/re/re_mod.h
+include/re/re_sipsess.h
+include/re/re_hmac.h
+include/re/re_tcp.h
+include/re/re_udp.h
+lib/libre.so
+lib/libre.a
+@dirrm include/re