aboutsummaryrefslogtreecommitdiff
path: root/audio/rebot3
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2011-05-16 09:06:33 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2011-05-16 09:06:33 +0000
commit9bdafe46bef3e287e4fed6a3e277764e88d73128 (patch)
treec819ebd5f0a92a6c55a3cfbd243974680703420b /audio/rebot3
parentcbab7f600fea5416405df01dc2a3a16335a4b4a5 (diff)
downloadports-9bdafe46bef3e287e4fed6a3e277764e88d73128.tar.gz
ports-9bdafe46bef3e287e4fed6a3e277764e88d73128.zip
- move multimedia/rebot3 to audio/rebot3
rebot3.pl renames MP3 files that you have grabbed from audio CDs with the track name, number, album, and/or artist. It does so by using either a remote CDDB server or a local CDDB created by cd (and other) players like xmcd, kscd or xmms. With rebot3.pl you can also add or remove ID3 (version 1) tags to/from the MP3 files. WWW: http://www.headmqa.com/rebot3/ Approved by: maintainer
Notes
Notes: svn path=/head/; revision=274167
Diffstat (limited to 'audio/rebot3')
-rw-r--r--audio/rebot3/Makefile40
-rw-r--r--audio/rebot3/distinfo2
-rw-r--r--audio/rebot3/pkg-descr7
3 files changed, 49 insertions, 0 deletions
diff --git a/audio/rebot3/Makefile b/audio/rebot3/Makefile
new file mode 100644
index 000000000000..54bbf888ed86
--- /dev/null
+++ b/audio/rebot3/Makefile
@@ -0,0 +1,40 @@
+# Ports collection Makefile for: rebot3
+# Date created: 7th May 2011
+# Whom: Chris Rees (utisoft@gmail.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= rebot3
+PORTVERSION= 1.0.2
+CATEGORIES= audio
+MASTER_SITES= http://www.headmqa.com/${PORTNAME}/ \
+ http://www.bayofrum.net/dist/${PORTNAME}/
+
+MAINTAINER= utisoft@gmail.com
+COMMENT= Renames mp3 files using freedb or local CDDB
+
+RUN_DEPENDS= ${SITE_PERL}/CDDB.pm:${PORTSDIR}/audio/p5-CDDB \
+ ${SITE_PERL}/MP3/ID3v1Tag.pm:${PORTSDIR}/audio/p5-MP3-ID3v1Tag
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+# Yes, we know it's perl, but we don't want to type '.pl' the whole time.
+ @${REINPLACE_CMD} -e 's#\(${PORTNAME}\).pl#\1#' \
+ -e '1s#/usr/bin/perl#${PERL}#' \
+ -e 's#defined (\(@.*\))#\1#' \
+ ${WRKSRC}/${PORTNAME}.pl ${WRKSRC}/${PORTNAME}.pl.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.pl.1 \
+ ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+
+.include <bsd.port.post.mk>
diff --git a/audio/rebot3/distinfo b/audio/rebot3/distinfo
new file mode 100644
index 000000000000..e4b918bea1c6
--- /dev/null
+++ b/audio/rebot3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rebot3-1.0.2.tar.gz) = 0284a9faa0810c93700d256d6903a743c0d40099b477556f247535ce4857cc95
+SIZE (rebot3-1.0.2.tar.gz) = 13610
diff --git a/audio/rebot3/pkg-descr b/audio/rebot3/pkg-descr
new file mode 100644
index 000000000000..71f04365eeb7
--- /dev/null
+++ b/audio/rebot3/pkg-descr
@@ -0,0 +1,7 @@
+rebot3.pl renames MP3 files that you have grabbed from audio CDs with
+the track name, number, album, and/or artist. It does so by using
+either a remote CDDB server or a local CDDB created by cd (and other)
+players like xmcd, kscd or xmms. With rebot3.pl you can also add or
+remove ID3 (version 1) tags to/from the MP3 files.
+
+WWW: http://www.headmqa.com/rebot3/