aboutsummaryrefslogtreecommitdiff
path: root/audio/resid
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-11-18 04:57:59 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-11-18 04:57:59 +0000
commit5aaba6ed4ad90cea64d1431f0db4da28fce02f14 (patch)
tree1f9be4b52cd3ec870ea21629c078d1671d06d26d /audio/resid
parent4ed080b2a8abc2bb01712b1cf518a16f69300d6c (diff)
downloadports-5aaba6ed4ad90cea64d1431f0db4da28fce02f14.tar.gz
ports-5aaba6ed4ad90cea64d1431f0db4da28fce02f14.zip
Add resid, a cycle-based SID emulator engine.
Notes
Notes: svn path=/head/; revision=70371
Diffstat (limited to 'audio/resid')
-rw-r--r--audio/resid/Makefile25
-rw-r--r--audio/resid/distinfo1
-rw-r--r--audio/resid/pkg-comment1
-rw-r--r--audio/resid/pkg-descr8
-rw-r--r--audio/resid/pkg-plist14
5 files changed, 49 insertions, 0 deletions
diff --git a/audio/resid/Makefile b/audio/resid/Makefile
new file mode 100644
index 000000000000..05e1adb3000b
--- /dev/null
+++ b/audio/resid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: resid
+# Date created: 6 October 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= resid
+PORTVERSION= 0.13
+CATEGORIES= audio emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sidplay2
+DISTNAME= ${PORTNAME}-${PORTVERSION}-p1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --enable-shared
+
+.include <bsd.port.mk>
diff --git a/audio/resid/distinfo b/audio/resid/distinfo
new file mode 100644
index 000000000000..e42cc512edff
--- /dev/null
+++ b/audio/resid/distinfo
@@ -0,0 +1 @@
+MD5 (resid-0.13-p1.tgz) = 15f54bdb411b0682468a6992170eb87d
diff --git a/audio/resid/pkg-comment b/audio/resid/pkg-comment
new file mode 100644
index 000000000000..613aa381bb54
--- /dev/null
+++ b/audio/resid/pkg-comment
@@ -0,0 +1 @@
+Cycle-based SID emulator engine
diff --git a/audio/resid/pkg-descr b/audio/resid/pkg-descr
new file mode 100644
index 000000000000..3faf2c312cf5
--- /dev/null
+++ b/audio/resid/pkg-descr
@@ -0,0 +1,8 @@
+Since June 1998, a cycle-based SID emulator engine is available and is
+distributed under the GNU General Public License (GPL). It's called reSID, is
+programmed in C++, and so far has been developed by Dag Lem.
+
+Requirement for processor power is huge (don't expect a complex SID emulator
+like this to run on a machine with less than 233-300 MHz).
+
+WWW: http://www.geocities.com/SiliconValley/Lakes/5147/resid/
diff --git a/audio/resid/pkg-plist b/audio/resid/pkg-plist
new file mode 100644
index 000000000000..e91cf19a1591
--- /dev/null
+++ b/audio/resid/pkg-plist
@@ -0,0 +1,14 @@
+include/resid/envelope.h
+include/resid/extfilt.h
+include/resid/filter.h
+include/resid/pot.h
+include/resid/sid.h
+include/resid/siddefs.h
+include/resid/spline.h
+include/resid/voice.h
+include/resid/wave.h
+lib/libresid.a
+lib/libresid.la
+lib/libresid.so
+lib/libresid.so.2
+@dirrm include/resid