aboutsummaryrefslogtreecommitdiff
path: root/audio/rezound
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-24 12:32:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-24 12:32:09 +0000
commit9a8a94739b560fd9ff90b10746bd071caf0f40ae (patch)
treeadc3f707fd343a9d7f39ce52c71767cef03c7015 /audio/rezound
parent735809748181eda11018f7fb7a7080b9f342647e (diff)
downloadports-9a8a94739b560fd9ff90b10746bd071caf0f40ae.tar.gz
ports-9a8a94739b560fd9ff90b10746bd071caf0f40ae.zip
- Add a patch to fix the build on 64-bit arches (patch in the PR looks like
it originated from Gentoo, which in turn says it's copyrighted by T2 SDE Project and submitted by Rene Rebe; committed version should be more clean and correct) [*] - Add a patch from Christian Schoenebeck to fix saving of raw files (Debian bug id 602277, Gentoo's 203471) - Fix a typo in #ifndef directive (also obtained from Gentoo) - Fix GNU gettext detection in configure script (was not 64-bit clean, thus package for e.g. amd64 would not pack because of broken pkg-plist) - Bump port revision after recent changes in dependencies and bugfixes PR: ports/157433 [*] Submitted by: Lowell Gilbert
Notes
Notes: svn path=/head/; revision=278234
Diffstat (limited to 'audio/rezound')
-rw-r--r--audio/rezound/Makefile14
-rw-r--r--audio/rezound/files/patch-64bit-fixes78
-rw-r--r--audio/rezound/files/patch-fix-raw-save78
3 files changed, 161 insertions, 9 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 38e058b58b41..2903cd9d1e85 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rezound
DISTVERSION= 0.12.3beta
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/ReZound/${DISTVERSION}
@@ -39,12 +39,6 @@ OPTIONS= LARGEFILE "Enable 64-bit I/O support (not yet!)" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
.if defined(WITH_LARGEFILE)
CONFIGURE_ARGS+= --enable-largefile
BROKEN= no expl(), logl(), nearbyintl(), etc
@@ -98,7 +92,6 @@ RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
@@ -109,8 +102,11 @@ post-patch: .SILENT
${REINPLACE_CMD} -E '/atoll|round|nearbyint/d' \
${WRKSRC}/config/platform/bsd.h
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...), ; \
- /^C(XX)?FLAGS=/d ; /CXXFLAGS="\$$CXXFLAGS -[gW]/d' \
+ /^C(XX)?FLAGS=/d ; /CXXFLAGS="\$$CXXFLAGS -[gW]/d ; \
+ /^return /s,\(int\)( n?gettext),(long)\1,' \
${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,WORDS_BIGENDIN,WORDS_BIGENDIAN,' \
+ ${WRKSRC}/src/backend/COSSSoundPlayer.cpp
${REINPLACE_CMD} -e 's,$$(prefix)/doc,$$(datadir)/doc,' \
${WRKSRC}/config/am_include.mk ${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in ${WRKSRC}/src/misc/Makefile.in \
diff --git a/audio/rezound/files/patch-64bit-fixes b/audio/rezound/files/patch-64bit-fixes
new file mode 100644
index 000000000000..25ff2f45bd81
--- /dev/null
+++ b/audio/rezound/files/patch-64bit-fixes
@@ -0,0 +1,78 @@
+--- src/frontend_fox/CMainWindow.cpp.orig 2007-01-14 05:48:07.000000000 +0600
++++ src/frontend_fox/CMainWindow.cpp 2011-07-10 00:43:26.743617695 +0700
+@@ -438,7 +438,7 @@
+
+ long CMainWindow::onSoundListChange(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- FXint index=(FXint)ptr;
++ FXint index=(uintptr_t)ptr;
+
+ if(index>=0 && index<soundList->getNumItems())
+ {
+@@ -1853,13 +1853,13 @@
+
+ if(pos==0 && FXSELID(sel)==ID_SHUTTLE_BACKWARD)
+ {
+- if((unsigned)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
++ if((uintptr_t)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
+ shuttleDial->setValue(pos-inc);
+ onShuttleChange(sender,sel,ptr);
+ }
+ else if(pos==0 && FXSELID(sel)==ID_SHUTTLE_FORWARD)
+ {
+- if((unsigned)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
++ if((uintptr_t)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
+ shuttleDial->setValue(pos+inc);
+ onShuttleChange(sender,sel,ptr);
+ }
+--- src/frontend_fox/CMp3Dialog.cpp.orig 2004-06-19 10:53:18.000000000 +0700
++++ src/frontend_fox/CMp3Dialog.cpp 2011-07-10 00:28:06.789412062 +0700
+@@ -170,7 +170,7 @@
+
+ long CMp3Dialog::onRadioButton(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- if((int)ptr==0) // only act when ptr==1 when it's getting checked
++ if(ptr==0) // only act when ptr==1 when it's getting checked
+ return 1;
+
+ // turn off all buttons
+--- src/frontend_fox/COggDialog.cpp.orig 2004-02-11 11:11:17.000000000 +0600
++++ src/frontend_fox/COggDialog.cpp 2011-07-10 00:27:51.332341401 +0700
+@@ -136,7 +136,7 @@
+
+ long COggDialog::onRadioButton(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- if((int)ptr==0) // only act when ptr==1 when it's getting checked
++ if(ptr==0) // only act when ptr==1 when it's getting checked
+ return 1;
+
+ // turn off all buttons
+--- src/frontend_fox/CPasteChannelsDialog.cpp.orig 2005-02-09 14:17:36.000000000 +0600
++++ src/frontend_fox/CPasteChannelsDialog.cpp 2011-07-10 00:26:51.192066310 +0700
+@@ -206,7 +206,7 @@
+ {
+ pasteChannels.clear();
+
+- actionParameters->setValue<unsigned>(_("MixMethod"),(unsigned)(mixTypeComboBox->getItemData(mixTypeComboBox->getCurrentItem())));
++ actionParameters->setValue<unsigned>(_("MixMethod"),(uintptr_t)(mixTypeComboBox->getItemData(mixTypeComboBox->getCurrentItem())));
+
+ if(repeatTypeComboBox->getCurrentItem()==0)
+ { // repeating it a given number of times
+--- src/misc/AThread.h.orig 2003-07-09 01:31:57.000000000 +0700
++++ src/misc/AThread.h 2011-07-10 00:14:55.142793847 +0700
+@@ -131,13 +131,13 @@
+ catch(exception &e)
+ {
+ thread->running=false;
+- fprintf(stderr,"exception was thrown within thread -- ID: 0x%x;\nmessage: %s\naborting\n",(unsigned)thread->threadID,e.what());fflush(stderr);
++ fprintf(stderr,"exception was thrown within thread -- ID: 0x%p;\nmessage: %s\naborting\n",thread->threadID,e.what());fflush(stderr);
+ abort();
+ }
+ catch(...)
+ {
+ thread->running=false;
+- fprintf(stderr,"unhandled exception was thrown within thread -- ID: 0x%x; aborting\n",(unsigned)thread->threadID);fflush(stderr);
++ fprintf(stderr,"unhandled exception was thrown within thread -- ID: 0x%p; aborting\n",thread->threadID);fflush(stderr);
+ abort();
+ }
+ return(NULL);
diff --git a/audio/rezound/files/patch-fix-raw-save b/audio/rezound/files/patch-fix-raw-save
new file mode 100644
index 000000000000..f2421b073f09
--- /dev/null
+++ b/audio/rezound/files/patch-fix-raw-save
@@ -0,0 +1,78 @@
+--- src/backend/CrawSoundTranslator.cpp.orig
++++ src/backend/CrawSoundTranslator.cpp
+@@ -132,6 +132,13 @@
+ // get user preferences for saving the raw data
+ static bool parametersGotten=false;
+ static AFrontendHooks::RawParameters parameters;
++
++ // init parameters which cannot be changed by the RAW parameters dialog
++ parameters.channelCount=sound->getChannelCount();
++ parameters.sampleRate=sound->getSampleRate();
++ parameters.dataLength=sound->getLength();
++ parameters.dataOffset=0;
++
+ useLastUserPrefs&=parametersGotten;
+ if(!useLastUserPrefs)
+ {
+--- src/frontend_fox/CRawDialog.cpp.orig
++++ src/frontend_fox/CRawDialog.cpp
+@@ -137,8 +137,11 @@
+
+ if(execute(PLACEMENT_SCREEN))
+ {
+- parameters.channelCount=atoi(channelsCountComboBox->getText().text());
+- parameters.sampleRate=atoi(sampleRateComboBox->getText().text());
++ // don't apply values of hidden GUI controls
++ if (showLoadRawParameters) {
++ parameters.channelCount=atoi(channelsCountComboBox->getText().text());
++ parameters.sampleRate=atoi(sampleRateComboBox->getText().text());
++ }
+
+ switch(sampleFormatComboBox->getCurrentItem())
+ {
+@@ -158,19 +161,22 @@
+
+ parameters.endian= byteOrderToggleButton->getState() ? AFrontendHooks::RawParameters::eBigEndian : AFrontendHooks::RawParameters::eLittleEndian;
+
+- if(atoi(dataOffsetTextBox->getText().text())<0)
+- {
+- Error(_("invalid negative data offset"));
+- return(false);
+- }
+- parameters.dataOffset=atoi(dataOffsetTextBox->getText().text());
+-
+- if(atoi(dataLengthTextBox->getText().text())<0)
+- {
+- Error(_("invalid negative data length"));
+- return(false);
++ // don't apply values of hidden GUI controls
++ if (showLoadRawParameters) {
++ if(atoi(dataOffsetTextBox->getText().text())<0)
++ {
++ Error(_("invalid negative data offset"));
++ return(false);
++ }
++ parameters.dataOffset=atoi(dataOffsetTextBox->getText().text());
++
++ if(atoi(dataLengthTextBox->getText().text())<0)
++ {
++ Error(_("invalid negative data length"));
++ return(false);
++ }
++ parameters.dataLength=atoi(dataLengthTextBox->getText().text());
+ }
+- parameters.dataLength=atoi(dataLengthTextBox->getText().text());
+
+ return(true);
+ }
+--- src/frontend_fox/CRawDialog.h.orig
++++ src/frontend_fox/CRawDialog.h
+@@ -37,7 +37,7 @@
+ CRawDialog(FXWindow *mainWindow);
+ virtual ~CRawDialog();
+
+- bool show(AFrontendHooks::RawParameters &parameters,bool showOffsetAndLengthParameters);
++ bool show(AFrontendHooks::RawParameters &parameters,bool showLoadRawParameters);
+
+ //long onRadioButton(FXObject *sender,FXSelector sel,void *ptr);
+