aboutsummaryrefslogtreecommitdiff
path: root/audio/ripit
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2009-02-05 14:57:16 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2009-02-05 14:57:16 +0000
commit30385b5c7f6649ac63876d8e6692080a65d60646 (patch)
tree6ea291c964844d8457bfa3bb4ab44972f3081112 /audio/ripit
parentbed8643504764f88877bfbc8260a17c968b778c0 (diff)
downloadports-30385b5c7f6649ac63876d8e6692080a65d60646.tar.gz
ports-30385b5c7f6649ac63876d8e6692080a65d60646.zip
- Add patch to fix lame --genre-list
- Bump PORTREVISION PR: ports/131308 Submitted by: Tobias Rehbein <tobias.rehbein at web.de> (maintainer)
Notes
Notes: svn path=/head/; revision=227671
Diffstat (limited to 'audio/ripit')
-rw-r--r--audio/ripit/Makefile1
-rw-r--r--audio/ripit/files/patch-ripit.pl42
2 files changed, 43 insertions, 0 deletions
diff --git a/audio/ripit/Makefile b/audio/ripit/Makefile
index 31a2ccce5fbf..424af7258e2f 100644
--- a/audio/ripit/Makefile
+++ b/audio/ripit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ripit
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.suwald.com/ripit/
diff --git a/audio/ripit/files/patch-ripit.pl b/audio/ripit/files/patch-ripit.pl
new file mode 100644
index 000000000000..7f38277cd191
--- /dev/null
+++ b/audio/ripit/files/patch-ripit.pl
@@ -0,0 +1,42 @@
+--- ./ripit.pl.orig 2009-02-02 19:23:52.000000000 +0000
++++ ./ripit.pl 2009-02-02 19:24:58.000000000 +0000
+@@ -3398,7 +3398,7 @@
+
+ # If Lame is not used, don't die if ID3v2-tag is not compliant.
+ if($lameflag == 0) {
+- unless(log_system("lame --genre-list | grep -i \" $genre\$\" > /dev/null ")) {
++ unless(log_system("lame --genre-list 2>&1 | grep -i \" $genre\$\" > /dev/null ")) {
+ print "Genre $genre is not ID3v2 compliant!\n"
+ if($verbose >= 1);
+ print "I continue anyway!\n\n" if($verbose >= 1);
+@@ -3417,7 +3417,7 @@
+
+ # Check if (similar) genre exists. Enter a new one with interaction,
+ # or take the default one.
+- while(!log_system("lame --genre-list | grep -i \"$genre\" > /dev/null ")) {
++ while(!log_system("lame --genre-list 2>&1 | grep -i \"$genre\" > /dev/null ")) {
+ print "Genre $genre is not ID3v2 compliant!\n" if($verbose >= 1);
+ if($interaction == 1) {
+ print "Use \"lame --genre-list\" to get a list!\n";
+@@ -3437,7 +3437,7 @@
+ return;
+ }
+ elsif($genre =~ /^\d+$/) {
+- $genre = `lame --genre-list | grep -i \' $genre \'`;
++ $genre = `lame --genre-list 2>&1 | grep -i \' $genre \'`;
+ chomp $genre;
+ }
+ else {
+@@ -3449,10 +3449,10 @@
+ # "pop-like" genres!
+ # There will be a linebreak, if multiple possibilities found.
+ my $ogenre = $genre;
+- $genre = `lame --genre-list | grep -i \'$genre\'`;
++ $genre = `lame --genre-list 2>&1 | grep -i \'$genre\'`;
+ chomp $genre;
+ # Second we want THE original genre, if it precisly exists.
+- my $testgenre = `lame --genre-list | grep -i \'\^... $ogenre\$\'`;
++ my $testgenre = `lame --genre-list 2>&1 | grep -i \'\^... $ogenre\$\'`;
+ chomp $testgenre;
+ $genre = $testgenre if($testgenre);
+ # If we still have several genres: