aboutsummaryrefslogtreecommitdiff
path: root/audio/rosegarden
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-11 21:19:19 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-11 21:19:19 +0000
commitada99036c46303de5c3a748f993b428de8f1446c (patch)
treef6daa74cd610c990da69f23543436f2de60e7817 /audio/rosegarden
parent58740d6b8692a792a71a42d2a10b5d42f4ef599a (diff)
downloadports-ada99036c46303de5c3a748f993b428de8f1446c.tar.gz
ports-ada99036c46303de5c3a748f993b428de8f1446c.zip
Notes
Diffstat (limited to 'audio/rosegarden')
-rw-r--r--audio/rosegarden/Makefile55
-rw-r--r--audio/rosegarden/distinfo4
-rw-r--r--audio/rosegarden/files/patch-configure14
3 files changed, 45 insertions, 28 deletions
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 2633fa96c970..1df036d9b650 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -1,40 +1,59 @@
-# New ports collection makefile for: rosegarden
-# Date created: 04 Aug 1996
-# Whom: shanee@augusta.de
-#
+# Created by: shanee@augusta.de
# $FreeBSD$
-#
PORTNAME= rosegarden
-PORTVERSION= 12.04
-PORTREVISION= 1
+PORTVERSION= 12.12
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}-LINUX/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
MAINTAINER= pawel@FreeBSD.org
-COMMENT= The Rosegarden editor and sequencer suite
+COMMENT= General purpose music editor and sequencer suite
LICENSE= GPLv2
BUILD_DEPENDS= dssi_osc_update:${PORTSDIR}/audio/dssi \
makedepend:${PORTSDIR}/devel/makedepend
-RUN_DEPENDS= dssi_osc_update:${PORTSDIR}/audio/dssi \
- lilypond:${PORTSDIR}/print/lilypond
-LIB_DEPENDS+= lrdf.2:${PORTSDIR}/textproc/liblrdf \
+LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
+ FLAC:${PORTSDIR}/audio/flac \
+ jack:${PORTSDIR}/audio/jack \
+ lo:${PORTSDIR}/audio/liblo \
+ ogg:${PORTSDIR}/audio/libogg \
+ samplerate:${PORTSDIR}/audio/libsamplerate \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ lirc_client:${PORTSDIR}/comms/lirc \
+ icuuc:${PORTSDIR}/devel/icu \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ yajl:${PORTSDIR}/devel/yajl \
+ curl:${PORTSDIR}/ftp/curl \
+ png15:${PORTSDIR}/graphics/png \
fftw3:${PORTSDIR}/math/fftw3 \
fftw3f:${PORTSDIR}/math/fftw3-float \
- asound.2:${PORTSDIR}/audio/alsa-lib \
- lirc_client:${PORTSDIR}/comms/lirc
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ lrdf:${PORTSDIR}/textproc/liblrdf \
+ raptor2:${PORTSDIR}/textproc/raptor2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+RUN_DEPENDS= dssi_osc_update:${PORTSDIR}/audio/dssi \
+ lilypond:${PORTSDIR}/print/lilypond
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= QTLIBDIR=${QT_LIBDIR}
+USE_PKGCONFIG= build
USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice sm x11 xau xdmcp xext xrender
USE_QT4= gui xml network corelib sql qt3support \
rcc_build moc_build uic_build linguist_build
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= QTLIBDIR=${QT_LIBDIR}
-GNU_CONFIGURE= yes
+USE_GNOME= libxml2 libxslt
MAKE_JOBS_SAFE= yes
INSTALLS_ICONS= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+
.include <bsd.port.mk>
diff --git a/audio/rosegarden/distinfo b/audio/rosegarden/distinfo
index d91580a1d9c0..24ee229ab370 100644
--- a/audio/rosegarden/distinfo
+++ b/audio/rosegarden/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rosegarden-12.04.tar.bz2) = bcf5705c34144269d4d18c68f3dd4633a628a5619c0728969971473a469eee8a
-SIZE (rosegarden-12.04.tar.bz2) = 5971442
+SHA256 (rosegarden-12.12.tar.bz2) = 9948c8d6f7eb87edcaae2010276ae06c0b5d951abe5efa9309e9e2655d17241a
+SIZE (rosegarden-12.12.tar.bz2) = 6046858
diff --git a/audio/rosegarden/files/patch-configure b/audio/rosegarden/files/patch-configure
index 320c59317281..5f21a725958c 100644
--- a/audio/rosegarden/files/patch-configure
+++ b/audio/rosegarden/files/patch-configure
@@ -1,13 +1,11 @@
---- configure.orig 2010-06-09 12:33:23.000000000 +0700
-+++ configure 2010-06-09 12:34:06.000000000 +0700
-@@ -4971,9 +4971,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_dl_dlopen" >&5
+--- configure.orig 2012-12-10 21:30:47.000000000 +0100
++++ configure 2012-12-10 21:31:26.000000000 +0100
+@@ -4998,8 +4998,6 @@
$as_echo "$ac_cv_lib_dl_dlopen" >&6; }
- if test "x$ac_cv_lib_dl_dlopen" = x""yes; then :
-- LIBS="$LIBS -ldl"
+ if test "x$ac_cv_lib_dl_dlopen" = xyes; then :
+ LIBS="$LIBS -ldl"
-else
-- as_fn_error "Failed to find required dl library" "$LINENO" 5
-+ LIBS="$LIBS"
+- as_fn_error $? "Failed to find required dl library" "$LINENO" 5
fi