aboutsummaryrefslogtreecommitdiff
path: root/audio/rplay
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-06-28 16:05:11 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-06-28 16:05:11 +0000
commite71e1fb70f1a5e776a2aaaf83b7e04b18f1a738e (patch)
treec3a2ba52e4dec534e017f8f90ada3f878f36b73c /audio/rplay
parentb83c006f7c037fc2fb8f82a614bbe6744ad084d6 (diff)
downloadports-e71e1fb70f1a5e776a2aaaf83b7e04b18f1a738e.tar.gz
ports-e71e1fb70f1a5e776a2aaaf83b7e04b18f1a738e.zip
- Update to version 3.3.2
- Add WWW: line into pkg/DESCR - Add INSTALLS_SHLIB/INFO_FILES hunks - HAS_CONFIGURE -> GNU_CONFIGURE PR: 19521 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=29943
Diffstat (limited to 'audio/rplay')
-rw-r--r--audio/rplay/Makefile40
-rw-r--r--audio/rplay/distinfo2
-rw-r--r--audio/rplay/files/patch-ab49
-rw-r--r--audio/rplay/files/patch-ac10
-rw-r--r--audio/rplay/files/patch-ad41
-rw-r--r--audio/rplay/files/patch-ae13
-rw-r--r--audio/rplay/files/patch-af13
-rw-r--r--audio/rplay/files/patch-ag13
-rw-r--r--audio/rplay/files/patch-ah50
-rw-r--r--audio/rplay/files/patch-ai33
-rw-r--r--audio/rplay/files/patch-aj38
-rw-r--r--audio/rplay/files/patch-ak14
-rw-r--r--audio/rplay/files/patch-al12
-rw-r--r--audio/rplay/files/patch-am19
-rw-r--r--audio/rplay/pkg-descr2
-rw-r--r--audio/rplay/pkg-plist16
16 files changed, 305 insertions, 60 deletions
diff --git a/audio/rplay/Makefile b/audio/rplay/Makefile
index eb26a8ade3dc..88ee5e94d2cd 100644
--- a/audio/rplay/Makefile
+++ b/audio/rplay/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rplay
-PORTVERSION= 3.2.0b6
+PORTVERSION= 3.3.2
CATEGORIES= audio
MASTER_SITES= http://rplay.doit.org/dist/
@@ -14,20 +14,32 @@ MAINTAINER= rmallory@csusb.edu
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
-HAS_CONFIGURE= yes
-USE_GMAKE= yes
-MAN1= rplay.1 xrplay.1 rplayd.1 rptp.1
-MAN5= rplay.conf.5 rplay.hosts.5 rplay.servers.5
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= rplay.1 rptp.1
+MAN5= rplay.conf.5 rplay.helpers.5 rplay.hosts.5 rplay.servers.5
+MAN8= rplayd.8
+
+INFO_FILES= RPLAY.info RPTP.info librplay.info rplayd.info
+
+post-extract:
+ @${CP} ${WRKSRC}/doc/rplay.texi ${WRKSRC}/doc/rplayd.texi
post-install:
- @if [ ! -f ${PREFIX}/etc/rc.d/rplayd.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/rplayd.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/rplayd.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/rplayd ] && ( ${PREFIX}/sbin/rplayd & ) && ${ECHO} -n ' rplayd'" >> ${PREFIX}/etc/rc.d/rplayd.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/rplayd.sh; \
- fi
- @if [ ! -f ${PREFIX}/etc/rplay.hosts ]; then \
- ${ECHO} localhost > ${PREFIX}/etc/rplay.hosts; \
- fi
+.for info in ${INFO_FILES}
+ @install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
+.endfor
+.if !exists(${PREFIX}/etc/rc.d/rplayd.sh)
+ @${ECHO} "===> Installing ${PREFIX}/etc/rc.d/rplayd.sh startup file"
+ @${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/rplayd.sh
+ @${ECHO} "[ -x ${PREFIX}/sbin/rplayd ] && ( ${PREFIX}/sbin/rplayd & ) && ${ECHO} -n ' rplayd'" >> ${PREFIX}/etc/rc.d/rplayd.sh
+ @${CHMOD} 751 ${PREFIX}/etc/rc.d/rplayd.sh
+.endif
+.if !exists(${PREFIX}/etc/rplay.hosts)
+ @${ECHO} localhost > ${PREFIX}/etc/rplay.hosts
+.endif
.include <bsd.port.mk>
diff --git a/audio/rplay/distinfo b/audio/rplay/distinfo
index ffa04ed9101c..2735cb3e25e3 100644
--- a/audio/rplay/distinfo
+++ b/audio/rplay/distinfo
@@ -1 +1 @@
-MD5 (rplay-3.2.0b6.tar.gz) = d8346e6f132193d076341de0d9fa35ca
+MD5 (rplay-3.3.2.tar.gz) = e39888f6bea32e1c8cf4a8880b416e56
diff --git a/audio/rplay/files/patch-ab b/audio/rplay/files/patch-ab
index 8770cd19979f..40662a82670b 100644
--- a/audio/rplay/files/patch-ab
+++ b/audio/rplay/files/patch-ab
@@ -1,39 +1,10 @@
-*** rplayd/Makefile.in.orig Fri Feb 2 03:13:57 1996
---- rplayd/Makefile.in Fri Jun 13 19:31:38 1997
-***************
-*** 1,4 ****
---- 1,5 ----
- include @RPLAY_TOP@/Makefile.config
-+ bindir= $(exec_prefix)/sbin
-
- srcdir = @srcdir@
- VPATH = @srcdir@
-***************
-*** 9,21 ****
- MKINSTALLDIRS= @srcdir@/../mkinstalldirs
-
- CPPFLAGS= $(CC_OPTIONS) -I. -I../include -I@srcdir@ -I@srcdir@/../include -I@srcdir@/../lib \
-! -I@srcdir@/../adpcm -I@srcdir@/../gsm @DEFS@
-
- .c.o:
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-
- LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp \
-! -L../adpcm -ladpcm -L../gsm -lgsm @LDFLAGS@ @LIBS@ -lm
-
- TARGET= rplayd
-
---- 10,22 ----
- MKINSTALLDIRS= @srcdir@/../mkinstalldirs
-
- CPPFLAGS= $(CC_OPTIONS) -I. -I../include -I@srcdir@ -I@srcdir@/../include -I@srcdir@/../lib \
-! -I@srcdir@/../adpcm -I/usr/local/include @DEFS@
-
- .c.o:
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
-
- LDFLAGS= $(LD_OPTIONS) -L../librplay -lrplay -L../lib -lrp \
-! -L../adpcm -ladpcm -L/usr/local/lib -lgsm @LDFLAGS@ @LIBS@ -lm
-
- TARGET= rplayd
-
+--- rplayd/Makefile.in.orig Wed Jun 9 15:27:43 1999
++++ rplayd/Makefile.in Wed Jun 21 23:04:00 2000
+@@ -54,7 +54,6 @@
+ install: all
+ $(MKINSTALLDIRS) $(sbindir)
+ $(INSTALL_PROGRAM) $(TARGET) $(sbindir)/$(TARGET)
+- @test -x $(bindir)/$(TARGET) && echo "" && echo " Note: Consider removing $(bindir)/$(TARGET)" && echo ""
+
+ uninstall:
+ $(RM) $(bindir)/$(TARGET)
diff --git a/audio/rplay/files/patch-ac b/audio/rplay/files/patch-ac
new file mode 100644
index 000000000000..7b5d09de9015
--- /dev/null
+++ b/audio/rplay/files/patch-ac
@@ -0,0 +1,10 @@
+--- Makefile.config.in.orig Thu Aug 13 15:12:59 1998
++++ Makefile.config.in Wed Jun 21 22:26:35 2000
+@@ -43,6 +43,7 @@
+ #CC_OPTIONS= -O -cckr # SGI
+ #CC_OPTIONS= -O # generic
+ #CC_OPTIONS= -g # debug
++CC_OPTIONS= @CPPFLAGS@
+
+ ##
+ ## Extra linker options.
diff --git a/audio/rplay/files/patch-ad b/audio/rplay/files/patch-ad
new file mode 100644
index 000000000000..38c78247e0dd
--- /dev/null
+++ b/audio/rplay/files/patch-ad
@@ -0,0 +1,41 @@
+--- doc/Makefile.in.orig Wed Jul 15 07:35:23 1998
++++ doc/Makefile.in Thu Jun 22 00:41:13 2000
+@@ -23,15 +23,15 @@
+ .texi.html:
+ $(TEXI2HTML) $(TEXI2HTML_FLAGS) $<
+
+-all:
++all: info
+
+-info: RPLAY.info RPTP.info librplay.info rplay.info
++info: RPLAY.info RPTP.info librplay.info rplayd.info
+
+-dvi: RPLAY.dvi RPTP.dvi librplay.dvi rplay.dvi
++dvi: RPLAY.dvi RPTP.dvi librplay.dvi rplayd.dvi
+
+-ps: RPLAY.ps RPTP.ps librplay.ps rplay.ps
++ps: RPLAY.ps RPTP.ps librplay.ps rplayd.ps
+
+-html: RPLAY.html RPTP.html librplay.html rplay.html
++html: RPLAY.html RPTP.html librplay.html rplayd.html
+
+ man:
+ ./genman rplay.1.in
+@@ -50,7 +50,7 @@
+ -$(INSTALL_DATA) RPLAY.info $(infodir)/RPLAY.info
+ -$(INSTALL_DATA) RPTP.info $(infodir)/RPTP.info
+ -$(INSTALL_DATA) librplay.info $(infodir)/librplay.info
+- -$(INSTALL_DATA) rplay.info $(infodir)/rplay.info
++ -$(INSTALL_DATA) rplayd.info $(infodir)/rplayd.info
+
+ uninstall:
+ -$(RM) $(mandir)/man1/rplay.1
+@@ -63,7 +63,7 @@
+ -$(RM) $(infodir)/RPLAY.info
+ -$(RM) $(infodir)/RPTP.info
+ -$(RM) $(infodir)/librplay.info
+- -$(RM) $(infodir)/rplay.info
++ -$(RM) $(infodir)/rplayd.info
+
+ clean:
+ $(RM) *~ *.bak *.orig
diff --git a/audio/rplay/files/patch-ae b/audio/rplay/files/patch-ae
new file mode 100644
index 000000000000..df40a019a006
--- /dev/null
+++ b/audio/rplay/files/patch-ae
@@ -0,0 +1,13 @@
+--- doc/RPLAY.texi.orig Wed Jul 15 07:35:23 1998
++++ doc/RPLAY.texi Wed Jun 21 22:38:54 2000
+@@ -2,6 +2,10 @@
+ @c %**start of header
+ @setfilename RPLAY.info
+ @settitle The RPLAY Protocol
++@dircategory Network Audio Systems
++@direntry
++* RPLAY Protocol: (RPLAY) The RPLAY Protocol
++@end direntry
+ @iftex
+ @finalout
+ @end iftex
diff --git a/audio/rplay/files/patch-af b/audio/rplay/files/patch-af
new file mode 100644
index 000000000000..7bb0f3d0da47
--- /dev/null
+++ b/audio/rplay/files/patch-af
@@ -0,0 +1,13 @@
+--- doc/RPTP.texi.orig Wed Jul 15 07:35:23 1998
++++ doc/RPTP.texi Wed Jun 21 22:38:56 2000
+@@ -2,6 +2,10 @@
+ @c %**start of header
+ @setfilename RPTP.info
+ @settitle The RPTP Protocol
++@dircategory Network Audio Systems
++@direntry
++* RPTP: (RPTP) RPTP Protocol
++@end direntry
+ @defindex ev
+ @iftex
+ @finalout
diff --git a/audio/rplay/files/patch-ag b/audio/rplay/files/patch-ag
new file mode 100644
index 000000000000..865bd4e9f282
--- /dev/null
+++ b/audio/rplay/files/patch-ag
@@ -0,0 +1,13 @@
+--- doc/librplay.texi.orig Wed Jul 15 07:35:23 1998
++++ doc/librplay.texi Wed Jun 21 22:38:58 2000
+@@ -2,6 +2,10 @@
+ @c %**start of header
+ @setfilename librplay.info
+ @settitle The rplay Programmer's Manual
++@dircategory Network Audio Systems
++@direntry
++* librplay: (librplay) The rplay Programmer's Manual
++@end direntry
+ @iftex
+ @finalout
+ @end iftex
diff --git a/audio/rplay/files/patch-ah b/audio/rplay/files/patch-ah
new file mode 100644
index 000000000000..5612cc1aa202
--- /dev/null
+++ b/audio/rplay/files/patch-ah
@@ -0,0 +1,50 @@
+--- doc/rplayd.texi.orig Wed Jul 15 07:35:23 1998
++++ doc/rplayd.texi Thu Jun 22 01:20:50 2000
+@@ -1,7 +1,11 @@
+ \input texinfo @c -*-texinfo-*-
+ @c %**start of header
+-@setfilename rplay.info
++@setfilename rplayd.info
+ @settitle rplay
++@dircategory Network Audio Systems
++@direntry
++* rplayd: (rplayd) RPlay
++@end direntry
+ @iftex
+ @finalout
+ @end iftex
+@@ -71,7 +75,6 @@
+ * rplayd:: The rplay audio server.
+ * rplay:: A sample RPLAY client.
+ * rptp:: A sample RPTP client.
+-* xrplay:: A X Windows rplay audio control panel.
+ @end menu
+
+ @node Overview, rplayd, Top, Top
+@@ -162,25 +165,12 @@
+ attempt to determine whether or not the server has the sound before
+ using the network.
+
+-@node rptp, xrplay, rplay, Top
++@node rptp, , rplay, Top
+ @chapter rptp
+ rptp is a simple RPTP client that communicates with rplayd using the
+ RPTP protocol. Several commands can be issued to control rplayd and
+ report its status. See the output of the rptp help command for a list
+ of available commands.
+-
+-@node xrplay, , rptp, Top
+-@chapter xrplay
+-rplay control panel which includes CD player-like buttons, volume
+-control, a simple vu meter, and a sound progess bar. Sounds can be
+-played, paused, continued, and stopped using the appropriate buttons.
+-
+-xrplay is also useful as a sound file player and can be used with web
+-browsers and other applications that use external programs to play
+-sounds.
+-
+-xrplay communicates with the local (or remote) rplayd using the RPTP
+-protocol.
+
+ @bye
+
diff --git a/audio/rplay/files/patch-ai b/audio/rplay/files/patch-ai
new file mode 100644
index 000000000000..654c104718b4
--- /dev/null
+++ b/audio/rplay/files/patch-ai
@@ -0,0 +1,33 @@
+--- doc/rplayd.8.orig Wed Jul 15 07:35:23 1998
++++ doc/rplayd.8 Wed Jun 21 22:39:07 2000
+@@ -125,7 +125,7 @@
+ Linux uses cdrom[0-3] -> /dev/cdrom[0-3].
+ .TP
+ .I "\-C FILE, \-\-conf=FILE"
+-Use FILE for rplay.conf (/etc/rplay/rplay.conf).
++Use FILE for rplay.conf.
+ .TP
+ .I "\-T N, \-\-connection\-timeout=N"
+ Close idle RPTP connections after N seconds, disabled with 0 (300).
+@@ -146,10 +146,10 @@
+ Display helpful information.
+ .TP
+ .I "\-\-helpers=FILE"
+-Use FILE for rplay.helpers (/etc/rplay/rplay.helpers).
++Use FILE for rplay.helpers.
+ .TP
+ .I "\-H FILE, \-\-hosts=FILE"
+-Use FILE for rplay.hosts (/etc/rplay/rplay.hosts).
++Use FILE for rplay.hosts.
+ .TP
+ .I "\-\-inetd"
+ Enable inetd mode. (disabled)
+@@ -191,7 +191,7 @@
+ (--other-rptp-port may also be available)
+ .TP
+ .I "\-S FILE, \-\-servers=FILE"
+-Use FILE for rplay.servers (/etc/rplay/rplay.servers).
++Use FILE for rplay.servers.
+ .TP
+ .I "\-t N, \-\-timeout=N"
+ Exit after N idle seconds, disabled with 0 (0).
diff --git a/audio/rplay/files/patch-aj b/audio/rplay/files/patch-aj
new file mode 100644
index 000000000000..dd85d7c40f1f
--- /dev/null
+++ b/audio/rplay/files/patch-aj
@@ -0,0 +1,38 @@
+--- librplay/Makefile.in.orig Tue Mar 23 11:38:38 1999
++++ librplay/Makefile.in Thu Jun 22 00:07:42 2000
+@@ -19,11 +19,12 @@
+ $(CC) -c -fPIC $(CPPFLAGS) $(CFLAGS) -o $@ $<
+
+ TARGET= $(LIBRPLAY_NAME)
++SOVER= 1
+ SRCS= rplay.c rptp.c async.c
+ OBJS= rplay.o rptp.o async.o
+ SHAREDOBJS= rplay.lo rptp.lo async.lo
+
+-all: $(TARGET) librplay.so
++all: $(TARGET) librplay.so.$(SOVER)
+
+ #
+ # Use the following for SunOS 4.1.x, Solaris 2.x, Linux, NetBSD
+@@ -32,8 +33,9 @@
+ $(AR) rcv $@ $?
+ $(RANLIB) $@
+
+-librplay.so: $(SHAREDOBJS)
+- $(CC) -o $@ $(SHAREDOBJS) $(LDFLAGS)
++librplay.so.$(SOVER): $(SHAREDOBJS)
++ $(CC) -o $@ -Wl,-soname,$@ $(SHAREDOBJS) $(LDFLAGS)
++ ln -sf $@ librplay.so
+
+ #
+ # For HP-UX comment above and uncomment below.
+@@ -50,7 +52,8 @@
+ install: all
+ $(MKINSTALLDIRS) $(libdir)
+ $(INSTALL_DATA) $(TARGET) $(libdir)
+- $(INSTALL_DATA) librplay.so $(libdir)
++ $(INSTALL_DATA) librplay.so.$(SOVER) $(libdir)
++ ln -sf librplay.so.$(SOVER) $(libdir)/librplay.so
+
+ uninstall:
+ $(RM) $(libdir)/$(TARGET)
diff --git a/audio/rplay/files/patch-ak b/audio/rplay/files/patch-ak
new file mode 100644
index 000000000000..b0a7b830458c
--- /dev/null
+++ b/audio/rplay/files/patch-ak
@@ -0,0 +1,14 @@
+--- rplayd/sound.h.orig Wed Jun 9 15:27:44 1999
++++ rplayd/sound.h Wed Jun 21 22:29:37 2000
+@@ -170,9 +170,9 @@
+ int gsm_bit_frame_bytes; /* Number of bytes in gsm_bit_frame */
+ int gsm_fixed_buffer_size;
+ #endif /* HAVE_GSM */
+-#ifdef HAVE_CDROM
++#if defined(HAVE_CDROM) || defined(HAVE_HELPERS)
+ int pid;
+-#endif /* HAVE_CDROM */
++#endif /* HAVE_CDROM || HAVE_HELPERS */
+ }
+ SINDEX;
+
diff --git a/audio/rplay/files/patch-al b/audio/rplay/files/patch-al
new file mode 100644
index 000000000000..40e400f0215c
--- /dev/null
+++ b/audio/rplay/files/patch-al
@@ -0,0 +1,12 @@
+--- rplayd/spool.c.orig Thu Mar 11 06:14:38 1999
++++ rplayd/spool.c Wed Jun 21 23:20:13 2000
+@@ -1127,8 +1127,8 @@
+ spool_flow_pause(sp);
+ }
+ }
+-#endif /* HAVE_CDROM */
+ }
++#endif /* HAVE_CDROM */
+ }
+ else
+ {
diff --git a/audio/rplay/files/patch-am b/audio/rplay/files/patch-am
new file mode 100644
index 000000000000..b45b9504124e
--- /dev/null
+++ b/audio/rplay/files/patch-am
@@ -0,0 +1,19 @@
+--- rx/Makefile.in.orig Wed Jun 21 22:57:55 2000
++++ rx/Makefile.in Wed Jun 21 22:59:43 2000
+@@ -64,11 +64,11 @@
+ all: librx.a
+
+ install: all
+- test -d $(libdir) || mkdir $(libdir)
+- test -d $(includedir) || mkdir $(includedir)
+- $(INSTALL) librx.a $(libdir)/librx.a
+- $(RANLIB) $(libdir)/librx.a
+- $(INSTALL) $(srcdir)/inst-rxposix.h $(includedir)/rxposix.h
++# test -d $(libdir) || mkdir $(libdir)
++# test -d $(includedir) || mkdir $(includedir)
++# $(INSTALL) librx.a $(libdir)/librx.a
++# $(RANLIB) $(libdir)/librx.a
++# $(INSTALL) $(srcdir)/inst-rxposix.h $(includedir)/rxposix.h
+
+
+ uninstall:
diff --git a/audio/rplay/pkg-descr b/audio/rplay/pkg-descr
index fde9c605c303..5a2472eda72f 100644
--- a/audio/rplay/pkg-descr
+++ b/audio/rplay/pkg-descr
@@ -4,3 +4,5 @@ supports SunOS 4.1.X, Solaris 2.X, Linux, SGI IRIX 4 & 5, HP9000/705,
HP9000/710 and now FreeBSD. The rplay clients and client library should
work on any system that supports Berkeley sockets. The X Window
System is not required.
+
+WWW: http://rplay.doit.org/
diff --git a/audio/rplay/pkg-plist b/audio/rplay/pkg-plist
index e416658e83c2..814e2b244e60 100644
--- a/audio/rplay/pkg-plist
+++ b/audio/rplay/pkg-plist
@@ -2,16 +2,20 @@ etc/rc.d/rplayd.sh
etc/rplay.hosts
bin/rplay
bin/rptp
-@comment requires XForms
-@comment bin/xrplay
sbin/rplayd
include/rplay.h
lib/librplay.a
-@unexec install-info --delete %D/info/librplay.info %D/info/dir
-@unexec install-info --delete %D/info/rplay.info %D/info/dir
+lib/librplay.so
+lib/librplay.so.1
@unexec install-info --delete %D/info/RPLAY.info %D/info/dir
@unexec install-info --delete %D/info/RPTP.info %D/info/dir
-info/librplay.info
-info/rplay.info
+@unexec install-info --delete %D/info/librplay.info %D/info/dir
+@unexec install-info --delete %D/info/rplayd.info %D/info/dir
info/RPLAY.info
info/RPTP.info
+info/librplay.info
+info/rplayd.info
+@exec install-info %D/info/RPLAY.info %D/info/dir
+@exec install-info %D/info/RPTP.info %D/info/dir
+@exec install-info %D/info/librplay.info %D/info/dir
+@exec install-info %D/info/rplayd.info %D/info/dir