aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-mp3tag/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-11-29 11:08:19 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-11-29 11:08:19 +0000
commit3f2e109414d19db4f2e43f41ed397307deead42f (patch)
tree8ab68e5c40b9dc72a1c30435e688e711a341b301 /audio/ruby-mp3tag/Makefile
parenta197d9dfad2935d0736b68df0a33fadcfd1125eb (diff)
downloadports-3f2e109414d19db4f2e43f41ed397307deead42f.tar.gz
ports-3f2e109414d19db4f2e43f41ed397307deead42f.zip
Notes
Diffstat (limited to 'audio/ruby-mp3tag/Makefile')
-rw-r--r--audio/ruby-mp3tag/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/audio/ruby-mp3tag/Makefile b/audio/ruby-mp3tag/Makefile
index 63e0d94ba7a7..504a2b1f39e1 100644
--- a/audio/ruby-mp3tag/Makefile
+++ b/audio/ruby-mp3tag/Makefile
@@ -12,24 +12,32 @@ MASTER_SITES= http://users.cybercity.dk/~dsl8950/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= A Ruby module to manipulate ID3v1.1 tags in MP3 files
USE_RUBY= yes
+USE_RUBY_RDOC= yes
+
+RUBY_RD_FILES= mp3tag.rb
NO_BUILD= yes
-DOCS= README mp3tag.html
+DOCS= README \
+ ${RUBY_RD_HTML_FILES}
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e "s,^(require[[:space:]]+')\./mp3tag(.*),\1mp3tag\2," \
+ ${WRKSRC}/mp3tag_test.rb
do-install:
+ ${MKDIR} ${RUBY_SITELIBDIR}/
${INSTALL_DATA} ${WRKSRC}/mp3tag.rb ${RUBY_SITELIBDIR}/
.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/mp3tag_test.rb ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${RUBY_MODDOCDIR}/
.endif
.include <bsd.port.mk>