aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-smf
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-03-30 16:59:28 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-03-30 16:59:28 +0000
commitfa6e768d650c2f2e8b02c9954df9b0bb983cd807 (patch)
tree2d8d18515d410ad5e4b369fcc89bacd640f00884 /audio/ruby-smf
parentf26a988cf33dc44c3d10ce84c08391dafebc94d2 (diff)
downloadports-fa6e768d650c2f2e8b02c9954df9b0bb983cd807.tar.gz
ports-fa6e768d650c2f2e8b02c9954df9b0bb983cd807.zip
Add ruby-smf 0.11.5, a Ruby module to handle Standard MIDI Files.
Notes
Notes: svn path=/head/; revision=56964
Diffstat (limited to 'audio/ruby-smf')
-rw-r--r--audio/ruby-smf/Makefile40
-rw-r--r--audio/ruby-smf/distinfo1
-rw-r--r--audio/ruby-smf/pkg-comment1
-rw-r--r--audio/ruby-smf/pkg-descr6
-rw-r--r--audio/ruby-smf/pkg-plist48
5 files changed, 96 insertions, 0 deletions
diff --git a/audio/ruby-smf/Makefile b/audio/ruby-smf/Makefile
new file mode 100644
index 000000000000..2f5c18e966eb
--- /dev/null
+++ b/audio/ruby-smf/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-smf
+# Date created: 31 March 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smf
+PORTVERSION= 0.11.5
+CATEGORIES= audio ruby
+MASTER_SITES= http://www.funaba.org/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS_EN= MANUAL.en MANUAL.en.html MANUAL.en.rd README.en
+DOCS_JA= MANUAL MANUAL.html MANUAL.rd README
+EXAMPLES_EN= sample/*
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/ruby-smf/distinfo b/audio/ruby-smf/distinfo
new file mode 100644
index 000000000000..ea7a5e78ee0e
--- /dev/null
+++ b/audio/ruby-smf/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/smf-0.11.5.tar.gz) = 3987674a77b9b7094c83ca3efbb81e78
diff --git a/audio/ruby-smf/pkg-comment b/audio/ruby-smf/pkg-comment
new file mode 100644
index 000000000000..94fc3e8327f7
--- /dev/null
+++ b/audio/ruby-smf/pkg-comment
@@ -0,0 +1 @@
+Ruby module to handle Standard MIDI Files
diff --git a/audio/ruby-smf/pkg-descr b/audio/ruby-smf/pkg-descr
new file mode 100644
index 000000000000..87261bb3f555
--- /dev/null
+++ b/audio/ruby-smf/pkg-descr
@@ -0,0 +1,6 @@
+This is a "Standard MIDI File" module, which handles encoding and
+decoding SMF. This includes a simple MML as an example of
+application.
+
+Author: Tadayoshi Funaba <tadf@funaba.org>
+WWW: http://www.funaba.org/en/ruby.html#smf
diff --git a/audio/ruby-smf/pkg-plist b/audio/ruby-smf/pkg-plist
new file mode 100644
index 000000000000..fc0ee188a4d1
--- /dev/null
+++ b/audio/ruby-smf/pkg-plist
@@ -0,0 +1,48 @@
+%%RUBY_SITELIBDIR%%/smf.rb
+%%RUBY_SITELIBDIR%%/smf/divert.rb
+@dirrm %%RUBY_SITELIBDIR%%/smf
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/433.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/433.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/aaff2.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/aaff2.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv1079-1.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv1079-1.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv1079-5.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv1079-5.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv772a.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv772a.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv775.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv775.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv787.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/bwv787.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/ddt2.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/ddt2.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie1.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie1.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie2.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie2.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie3.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/gymnopedie3.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/ltvddpd2.mid
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/ltvddpd2.mml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/merge.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/mml.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/mml.ry
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/play.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/rand1.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/rand2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/smf2smf.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/smf2text.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/smf2wav.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/smf/split.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/smf
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/MANUAL.en
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/MANUAL.en.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/MANUAL.en.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/README.en
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/ja/MANUAL
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/ja/MANUAL.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/ja/MANUAL.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/smf/ja/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/smf/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/smf