aboutsummaryrefslogtreecommitdiff
path: root/audio/rubygem-ruby-shout
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-05-27 16:22:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-05-27 16:22:17 +0000
commitc16279737f35fc4839fe0a87e98e4825503f133f (patch)
tree172f65a2e7d94dcb832b3a4dba79174713d59550 /audio/rubygem-ruby-shout
parent7f343c16ccb82dc57e3bc9fc070cb9f298918f97 (diff)
downloadports-c16279737f35fc4839fe0a87e98e4825503f133f.tar.gz
ports-c16279737f35fc4839fe0a87e98e4825503f133f.zip
- Move audio/rubygem-shout to audio/rubygem-ruby-shout
- Fix build with ruby22 - Add LICENSE - Update WWW
Notes
Notes: svn path=/head/; revision=387633
Diffstat (limited to 'audio/rubygem-ruby-shout')
-rw-r--r--audio/rubygem-ruby-shout/Makefile22
-rw-r--r--audio/rubygem-ruby-shout/distinfo2
-rw-r--r--audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c11
-rw-r--r--audio/rubygem-ruby-shout/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/audio/rubygem-ruby-shout/Makefile b/audio/rubygem-ruby-shout/Makefile
new file mode 100644
index 000000000000..08c2a5d706cf
--- /dev/null
+++ b/audio/rubygem-ruby-shout/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ruby-shout
+PORTVERSION= 2.2.1
+PORTREVISION= 1
+CATEGORIES= audio rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby binding to the libshout library
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libshout.so:${PORTSDIR}/audio/libshout
+
+CONFIGURE_ARGS= --with-opt-include="${LOCALBASE}/include"
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/audio/rubygem-ruby-shout/distinfo b/audio/rubygem-ruby-shout/distinfo
new file mode 100644
index 000000000000..f512f20b831c
--- /dev/null
+++ b/audio/rubygem-ruby-shout/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-shout-2.2.1.gem) = 459da771249a2c05d82a548fed05b97ee8a230b6018b17779150204d91fb93e3
+SIZE (rubygem/ruby-shout-2.2.1.gem) = 12288
diff --git a/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c b/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c
new file mode 100644
index 000000000000..a07ff0a02b16
--- /dev/null
+++ b/audio/rubygem-ruby-shout/files/patch-ext-shout_ext.c
@@ -0,0 +1,11 @@
+--- ext/shout_ext.c.orig 2015-05-27 15:58:04 UTC
++++ ext/shout_ext.c
+@@ -250,7 +250,7 @@ static VALUE _sh_send(VALUE self, VALUE
+ shout_connection *s;
+ GET_SC(self, s);
+
+- Check_SafeStr(to_send);
++ SafeStringValue(to_send);
+ err = shout_send(s->conn, (unsigned char *) (RSTRING_PTR(to_send)),
+ RSTRING_LEN(to_send));
+ if(err != SHOUTERR_SUCCESS) {
diff --git a/audio/rubygem-ruby-shout/pkg-descr b/audio/rubygem-ruby-shout/pkg-descr
new file mode 100644
index 000000000000..30c9bb03d9af
--- /dev/null
+++ b/audio/rubygem-ruby-shout/pkg-descr
@@ -0,0 +1,4 @@
+Ruby-shout is a binding to the libshout library, which sends streaming
+MP3/Vorbis to an icecast server with libshout.
+
+WWW: https://github.com/niko/ruby-shout