aboutsummaryrefslogtreecommitdiff
path: root/audio/sayonara
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2017-09-14 21:02:51 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2017-09-14 21:02:51 +0000
commitc91270bd8d6b60bd7c36fb2ad128e2a8165e0686 (patch)
tree570aeb8e9fcad4efb19711621999d3df8296b6b9 /audio/sayonara
parent9620259fffa8cf46a8185e360528426f07898696 (diff)
downloadports-c91270bd8d6b60bd7c36fb2ad128e2a8165e0686.tar.gz
ports-c91270bd8d6b60bd7c36fb2ad128e2a8165e0686.zip
Update CMake to 3.9, merge devel/cmake-modules into devel/cmake
Thanks to antoine@ for the exp-run. Approved by: rakuco (mentor) Reviewed by: tcberner (mentor) Reviewed by: mat PR: 222000 (exp-run) Differential Revision: https://reviews.freebsd.org/D12299
Notes
Notes: svn path=/head/; revision=449853
Diffstat (limited to 'audio/sayonara')
-rw-r--r--audio/sayonara/files/patch-CMakeLists.txt28
-rw-r--r--audio/sayonara/files/patch-src_3rdParty_SomaFM_ui_GUI__SomaFM.h11
-rw-r--r--audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudArtistSearch.h11
-rw-r--r--audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudLibrary.h11
-rw-r--r--audio/sayonara/files/patch-uifiles.patch181
5 files changed, 242 insertions, 0 deletions
diff --git a/audio/sayonara/files/patch-CMakeLists.txt b/audio/sayonara/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..19201cb7227d
--- /dev/null
+++ b/audio/sayonara/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+CMake 3.9 compatibility. Upstreamed in a different form for
+sayonara 0.9.4, which is fully patched for CMake 3.9 and FreeBSD
+
+--- CMakeLists.txt.orig 2016-10-30 11:53:25 UTC
++++ CMakeLists.txt
+@@ -1,6 +1,11 @@
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.7)
+ PROJECT("Sayonara Player")
+
++IF(POLICY CMP0071)
++ CMAKE_POLICY(SET CMP0071 OLD)
++ SET(CMAKE_POLICY_DEFAULT_CMP0071 OLD) # Don't reset in subdirs
++ENDIF()
++
+ set (CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}")
+ INCLUDE(cotire)
+ SET(VAR_SAYONARA_VERSION "0.9.2")
+@@ -15,6 +20,10 @@ ADD_DEFINITIONS( -DSAYONARA_INSTALL_SHAR
+ MESSAGE("Build Sayonara ${VAR_SAYONARA_VERSION}")
+ MESSAGE("Will install to ${CMAKE_INSTALL_PREFIX}")
+
++# CMake 3.9 searches full UI-file paths
++SET(CMAKE_AUTOUIC_SEARCH_PATHS ${CMAKE_CURRENT_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src/GUI/Preferences/Fonts)
++INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/src ${CMAKE_CURRENT_BINARY_DIR}/src/GUI/Playlist/ ${CMAKE_BINARY_DIR}/src/GUI/Preferences .)
++
+ ADD_SUBDIRECTORY(src)
+ ADD_SUBDIRECTORY(resources)
+
diff --git a/audio/sayonara/files/patch-src_3rdParty_SomaFM_ui_GUI__SomaFM.h b/audio/sayonara/files/patch-src_3rdParty_SomaFM_ui_GUI__SomaFM.h
new file mode 100644
index 000000000000..c077b2e25a76
--- /dev/null
+++ b/audio/sayonara/files/patch-src_3rdParty_SomaFM_ui_GUI__SomaFM.h
@@ -0,0 +1,11 @@
+--- src/3rdParty/SomaFM/ui/GUI_SomaFM.h.orig 2017-09-01 21:11:21 UTC
++++ src/3rdParty/SomaFM/ui/GUI_SomaFM.h
+@@ -29,7 +29,7 @@
+ #include "SomaFMLibrary.h"
+ #include "SomaFMStation.h"
+
+-#include "3rdParty/SomaFM/ui_GUI_SomaFM.h"
++#include "3rdParty/SomaFM/ui/ui_GUI_SomaFM.h"
+ #include "Components/Covers/CoverLocation.h"
+ #include "GUI/Helper/SayonaraWidget/SayonaraWidget.h"
+
diff --git a/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudArtistSearch.h b/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudArtistSearch.h
new file mode 100644
index 000000000000..a7018ed137c5
--- /dev/null
+++ b/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudArtistSearch.h
@@ -0,0 +1,11 @@
+--- src/3rdParty/Soundcloud/ui/GUI_SoundcloudArtistSearch.h.orig 2017-09-01 21:08:31 UTC
++++ src/3rdParty/Soundcloud/ui/GUI_SoundcloudArtistSearch.h
+@@ -25,7 +25,7 @@
+
+ #include <QDialog>
+ #include "GUI/Helper/SayonaraWidget/SayonaraDialog.h"
+-#include "3rdParty/Soundcloud/ui_GUI_SoundcloudArtistSearch.h"
++#include "3rdParty/Soundcloud/ui/ui_GUI_SoundcloudArtistSearch.h"
+ #include "3rdParty/Soundcloud/src/SoundcloudLibrary.h"
+ #include "3rdParty/Soundcloud/src/SoundcloudDataFetcher.h"
+
diff --git a/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudLibrary.h b/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudLibrary.h
new file mode 100644
index 000000000000..7ca8f81b1999
--- /dev/null
+++ b/audio/sayonara/files/patch-src_3rdParty_Soundcloud_ui_GUI__SoundcloudLibrary.h
@@ -0,0 +1,11 @@
+--- src/3rdParty/Soundcloud/ui/GUI_SoundcloudLibrary.h.orig 2017-09-01 21:10:28 UTC
++++ src/3rdParty/Soundcloud/ui/GUI_SoundcloudLibrary.h
+@@ -23,7 +23,7 @@
+ #ifndef GUI_SOUNDCLOUDLIBRARY_H
+ #define GUI_SOUNDCLOUDLIBRARY_H
+
+-#include "3rdParty/Soundcloud/ui_GUI_SoundcloudLibrary.h"
++#include "3rdParty/Soundcloud/ui/ui_GUI_SoundcloudLibrary.h"
+
+ #include "GUI/Library/GUI_AbstractLibrary.h"
+
diff --git a/audio/sayonara/files/patch-uifiles.patch b/audio/sayonara/files/patch-uifiles.patch
new file mode 100644
index 000000000000..bb0ff8786048
--- /dev/null
+++ b/audio/sayonara/files/patch-uifiles.patch
@@ -0,0 +1,181 @@
+Many files #include generated UI-files with the path where they are
+generated by CMake 3.8; this breaks autouic in CMake 3.9, which looks
+at the actual source path and generates the files in a different
+location. All upstreamed in different forms for the forthcoming 0.9.4.
+
+--- src/GUI/Library/ImportFolderDialog/GUI_ImportFolder.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Library/ImportFolderDialog/GUI_ImportFolder.h
+@@ -21,7 +21,7 @@
+ #ifndef GUIIMPORTFOLDER_H_
+ #define GUIIMPORTFOLDER_H_
+
+-#include "GUI/Library/ui_GUI_ImportFolder.h"
++#include "ui_GUI_ImportFolder.h"
+ #include "GUI/Helper/SayonaraWidget/SayonaraDialog.h"
+ #include "Components/Library/Importer/LibraryImporter.h"
+
+--- src/GUI/Library/InfoBox/GUI_LibraryInfoBox.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Library/InfoBox/GUI_LibraryInfoBox.h
+@@ -25,7 +25,7 @@
+ #ifndef GUILIBRARYINFOBOX_H_
+ #define GUILIBRARYINFOBOX_H_
+
+-#include "GUI/Library/ui_GUI_LibraryInfoBox.h"
++#include "ui_GUI_LibraryInfoBox.h"
+ #include "GUI/Helper/SayonaraWidget/SayonaraDialog.h"
+
+
+--- src/GUI/Playlist/BottomBar/GUI_PlaylistBottomBar.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Playlist/BottomBar/GUI_PlaylistBottomBar.h
+@@ -24,7 +24,7 @@
+ #define PLAYLISTBOTTOMBAR_H
+
+ #include "GUI/Helper/SayonaraWidget/SayonaraWidget.h"
+-#include "GUI/Playlist/ui_GUI_PlaylistBottomBar.h"
++#include "ui_GUI_PlaylistBottomBar.h"
+
+ #include "Helper/Shutdown/Shutdown.h"
+ #include "Helper/Playlist/PlaylistMode.h"
+--- src/GUI/Preferences/Broadcast/GUI_BroadcastSetup.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Broadcast/GUI_BroadcastSetup.h
+@@ -23,7 +23,7 @@
+ #ifndef GUI_BROADCASTSETUP_H
+ #define GUI_BROADCASTSETUP_H
+
+-#include "GUI/Preferences/ui_GUI_BroadcastSetup.h"
++#include "ui_GUI_BroadcastSetup.h"
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+
+ class GUI_BroadcastSetup :
+--- src/GUI/Preferences/Fonts/GUI_FontConfig.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Fonts/GUI_FontConfig.h
+@@ -24,7 +24,7 @@
+ #define GUI_FONTCONFIG_H
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+-#include "GUI/Preferences/ui_GUI_FontConfig.h"
++#include "ui_GUI_FontConfig.h"
+
+ #include <QFontDatabase>
+ #include <QFont>
+--- src/GUI/Preferences/Language/GUI_LanguageChooser.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Language/GUI_LanguageChooser.h
+@@ -26,7 +26,7 @@
+ #include <QMap>
+ #include <QShowEvent>
+
+-#include "GUI/Preferences/ui_GUI_LanguageChooser.h"
++#include "ui_GUI_LanguageChooser.h"
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+
+
+--- src/GUI/Preferences/LastFM/GUI_LastFM.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/LastFM/GUI_LastFM.h
+@@ -29,7 +29,7 @@
+ #ifndef GUI_LASTFM_H_
+ #define GUI_LASTFM_H_
+
+-#include "GUI/Preferences/ui_GUI_LastFM.h"
++#include "ui_GUI_LastFM.h"
+
+ #include "Components/StreamPlugins/LastFM/LastFM.h"
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+--- src/GUI/Preferences/LibraryPreferences/GUI_LibraryPreferences.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/LibraryPreferences/GUI_LibraryPreferences.h
+@@ -22,7 +22,7 @@
+ #define GUI_LIBRARYPREFERENCES_H
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+-#include "GUI/Preferences/ui_GUI_LibraryPreferences.h"
++#include "ui_GUI_LibraryPreferences.h"
+
+
+ class GUI_LibraryPreferences :
+--- src/GUI/Preferences/Notifications/GUI_Notifications.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Notifications/GUI_Notifications.h
+@@ -25,7 +25,7 @@
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+ #include "Interfaces/Notification/NotificationHandler.h"
+-#include "GUI/Preferences/ui_GUI_Notifications.h"
++#include "ui_GUI_Notifications.h"
+
+
+ class GUI_Notifications :
+--- src/GUI/Preferences/PlayerPreferences/GUI_PlayerPreferences.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/PlayerPreferences/GUI_PlayerPreferences.h
+@@ -24,7 +24,7 @@
+ #define GUI_PLAYERPREFERENCES_H
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+-#include "GUI/Preferences/ui_GUI_PlayerPreferences.h"
++#include "ui_GUI_PlayerPreferences.h"
+
+
+ class GUI_PlayerPreferences :
+--- src/GUI/Preferences/PlaylistPreferences/GUI_PlaylistPreferences.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/PlaylistPreferences/GUI_PlaylistPreferences.h
+@@ -28,7 +28,7 @@
+
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+-#include "GUI/Preferences/ui_GUI_PlaylistPreferences.h"
++#include "ui_GUI_PlaylistPreferences.h"
+
+
+ class GUI_PlaylistPreferences :
+--- src/GUI/Preferences/PreferenceDialog/GUI_PreferenceDialog.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/PreferenceDialog/GUI_PreferenceDialog.h
+@@ -25,7 +25,7 @@
+
+ #include <QDialog>
+ #include <QList>
+-#include "GUI/Preferences/ui_GUI_PreferenceDialog.h"
++#include "ui_GUI_PreferenceDialog.h"
+ #include "GUI/Helper/SayonaraWidget/SayonaraWidget.h"
+ #include "Interfaces/PreferenceDialog/PreferenceDialogInterface.h"
+
+--- src/GUI/Preferences/RemoteControl/GUI_RemoteControl.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/RemoteControl/GUI_RemoteControl.h
+@@ -25,7 +25,7 @@
+ #ifndef GUISOCKETSETUP_H_
+ #define GUISOCKETSETUP_H_
+
+-#include "GUI/Preferences/ui_GUI_RemoteControl.h"
++#include "ui_GUI_RemoteControl.h"
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+
+--- src/GUI/Preferences/Shortcuts/GUI_ShortcutEntry.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Shortcuts/GUI_ShortcutEntry.h
+@@ -24,7 +24,7 @@
+
+ #include "GUI/Helper/SayonaraWidget/SayonaraWidget.h"
+ #include "GUI/Helper/Shortcuts/ShortcutHandler.h"
+-#include "GUI/Preferences/ui_GUI_ShortcutEntry.h"
++#include "ui_GUI_ShortcutEntry.h"
+
+
+ /**
+--- src/GUI/Preferences/Shortcuts/GUI_Shortcuts.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/Shortcuts/GUI_Shortcuts.h
+@@ -24,7 +24,7 @@
+ #define GUI_SHORTCUTS_H
+
+
+-#include "GUI/Preferences/ui_GUI_Shortcuts.h"
++#include "ui_GUI_Shortcuts.h"
+ #include "GUI/Helper/Shortcuts/ShortcutHandler.h"
+
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+--- src/GUI/Preferences/StreamRecorder/GUI_StreamRecorder.h.orig 2016-10-30 11:53:25 UTC
++++ src/GUI/Preferences/StreamRecorder/GUI_StreamRecorder.h
+@@ -25,7 +25,7 @@
+ #ifndef GUI_STREAMRECORDER_H_
+ #define GUI_STREAMRECORDER_H_
+
+-#include "GUI/Preferences/ui_GUI_StreamRecorder.h"
++#include "ui_GUI_StreamRecorder.h"
+ #include "Interfaces/PreferenceDialog/PreferenceWidgetInterface.h"
+
+ class GUI_StreamRecorder :