aboutsummaryrefslogtreecommitdiff
path: root/audio/sayonara
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2018-01-03 22:46:29 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2018-01-03 22:46:29 +0000
commitc995afeb09df82c0ea617fbf027bf4ca929ac195 (patch)
tree16b2e58545f02d991c0e23d1492402cefe7f104f /audio/sayonara
parent6f63e9485672f04d8e1780706242d9256ccafb92 (diff)
downloadports-c995afeb09df82c0ea617fbf027bf4ca929ac195.tar.gz
ports-c995afeb09df82c0ea617fbf027bf4ca929ac195.zip
Update audio/sayonara to latest upstream release 1.0.0
The overall changelog is at http://sayonara-player.com/changelog.php, nothing major. All patches from FreeBSD have been integrated upstream or made obsolete. Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D13747
Notes
Notes: svn path=/head/; revision=458004
Diffstat (limited to 'audio/sayonara')
-rw-r--r--audio/sayonara/Makefile5
-rw-r--r--audio/sayonara/distinfo6
-rw-r--r--audio/sayonara/files/patch-CMakeLists.txt15
-rw-r--r--audio/sayonara/files/patch-src_Helper_Logger_Logger.h14
-rw-r--r--audio/sayonara/files/patch-src_Main.cpp24
5 files changed, 5 insertions, 59 deletions
diff --git a/audio/sayonara/Makefile b/audio/sayonara/Makefile
index 42eee5e82cd6..d7e3d7a842ad 100644
--- a/audio/sayonara/Makefile
+++ b/audio/sayonara/Makefile
@@ -3,9 +3,8 @@
PORTNAME= sayonara
DISTVERSIONPREFIX= player-
-DISTVERSION= 0.9.3
-DISTVERSIONSUFFIX= -git2-20170509
-PORTREVISION= 1
+DISTVERSION= 1.0.0
+DISTVERSIONSUFFIX= -git1-20171231
CATEGORIES= audio
MASTER_SITES= http://www.sayonara-player.com/sw/
diff --git a/audio/sayonara/distinfo b/audio/sayonara/distinfo
index 239daddb8b9f..ea6f9c906b55 100644
--- a/audio/sayonara/distinfo
+++ b/audio/sayonara/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1507272191
-SHA256 (sayonara-player-0.9.3-git2-20170509.tar.gz) = 0412c6cf7e3d9283aa37caba08b009a9df6aeddb036cfca35af7dab40f5c14f5
-SIZE (sayonara-player-0.9.3-git2-20170509.tar.gz) = 1732355
+TIMESTAMP = 1514987445
+SHA256 (sayonara-player-1.0.0-git1-20171231.tar.gz) = 658eecfb0d42352c5ba616aa237e00474a2e8cf4cdd07547fe8d4cee77789a43
+SIZE (sayonara-player-1.0.0-git1-20171231.tar.gz) = 1754852
diff --git a/audio/sayonara/files/patch-CMakeLists.txt b/audio/sayonara/files/patch-CMakeLists.txt
deleted file mode 100644
index 79a2118286b4..000000000000
--- a/audio/sayonara/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-Adjust for changed UI search and generation paths in CMake 3.9.
-
---- CMakeLists.txt.orig 2017-05-09 18:52:59 UTC
-+++ CMakeLists.txt
-@@ -24,6 +24,10 @@ CONFIGURE_FILE(Macros.h.in "${CMAKE_CURR
- MESSAGE("Build Sayonara ${VAR_SAYONARA_VERSION}")
- MESSAGE("Will install to ${CMAKE_INSTALL_PREFIX}")
-
-+# CMake 3.9 searches full UI-file paths
-+SET(CMAKE_AUTOUIC_SEARCH_PATHS ${CMAKE_CURRENT_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/src/GUI/Preferences/Fonts)
-+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR}/src ${CMAKE_CURRENT_BINARY_DIR}/src/GUI/Playlist/ ${CMAKE_BINARY_DIR}/src/GUI/Preferences .)
-+
- ADD_SUBDIRECTORY(src)
- ADD_SUBDIRECTORY(resources)
-
diff --git a/audio/sayonara/files/patch-src_Helper_Logger_Logger.h b/audio/sayonara/files/patch-src_Helper_Logger_Logger.h
deleted file mode 100644
index fdf911df536f..000000000000
--- a/audio/sayonara/files/patch-src_Helper_Logger_Logger.h
+++ /dev/null
@@ -1,14 +0,0 @@
-Avoid adding #include <iostream> in lots of .cpp files, at the cost
-of compilation time because iostream is no longer forward-declared.
-
---- src/Helper/Logger/Logger.h.orig 2017-10-06 07:14:44 UTC
-+++ src/Helper/Logger/Logger.h
-@@ -21,7 +21,7 @@
- #ifndef LOGGER_H
- #define LOGGER_H
-
--#include <iosfwd>
-+#include <iostream>
- #include <typeinfo>
- #include <type_traits>
- #include <QList>
diff --git a/audio/sayonara/files/patch-src_Main.cpp b/audio/sayonara/files/patch-src_Main.cpp
deleted file mode 100644
index 2d382f95cfd6..000000000000
--- a/audio/sayonara/files/patch-src_Main.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
-The #else part is ill-formed, and the multi-instance support can
-work on FreeBSD as well as Linux.
-
---- src/Main.cpp.orig 2017-10-06 07:17:05 UTC
-+++ src/Main.cpp
-@@ -192,7 +192,7 @@ int main(int argc, char *argv[])
- return 0;
- }
-
--#ifdef Q_OS_LINUX
-+#if defined( Q_OS_LINUX ) || defined( Q_OS_FREEBSD )
-
- int pid=0;
- if( !cmd_data.multiple_instances ){
-@@ -203,9 +203,6 @@ int main(int argc, char *argv[])
- notify_old_instance(cmd_data.files_to_play, pid);
- return 0;
- }
--
--#else
-- Q_UNUSED(single_instance)
- #endif
-
-