aboutsummaryrefslogtreecommitdiff
path: root/audio/sbagen
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-17 22:11:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-17 22:11:12 +0000
commit9fc878e88f2e7402f5592aef2377954facd88fc1 (patch)
tree5d7792628589ebef8127e767b9f491f88b33ec00 /audio/sbagen
parent0753dc5f14a2380fd7921dc28f36c2d531b46990 (diff)
downloadports-9fc878e88f2e7402f5592aef2377954facd88fc1.tar.gz
ports-9fc878e88f2e7402f5592aef2377954facd88fc1.zip
Stage support
Notes
Notes: svn path=/head/; revision=340128
Diffstat (limited to 'audio/sbagen')
-rw-r--r--audio/sbagen/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/audio/sbagen/Makefile b/audio/sbagen/Makefile
index 3279a550165c..567ff3cb8d91 100644
--- a/audio/sbagen/Makefile
+++ b/audio/sbagen/Makefile
@@ -16,23 +16,16 @@ PORTDOCS= ChangeLog.txt README.txt SBAGEN.txt TODO.txt focus.txt \
focus2.txt holosync.txt theory.txt theory2.txt wave.txt
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -DT_LINUX -pthread -lm \
sbagen.c -o sbagen)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sbagen ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/sbagen ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>