aboutsummaryrefslogtreecommitdiff
path: root/audio/schismtracker
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-12 16:30:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-12 16:30:34 +0000
commit3d3b909ba4882558f122dc91365edeccd11d9b0f (patch)
tree6bf58dac08e3de3d8bc2e30c9c0425b1ec84888b /audio/schismtracker
parent4af528f41855f0a7e0107dea08f4d6cea2367e9e (diff)
downloadports-3d3b909ba4882558f122dc91365edeccd11d9b0f.tar.gz
ports-3d3b909ba4882558f122dc91365edeccd11d9b0f.zip
- Rename audio/schism for better naming
- Add .desktop files for tracker and editor - Provide icons
Notes
Notes: svn path=/head/; revision=438383
Diffstat (limited to 'audio/schismtracker')
-rw-r--r--audio/schismtracker/Makefile41
-rw-r--r--audio/schismtracker/distinfo3
-rw-r--r--audio/schismtracker/pkg-descr5
-rw-r--r--audio/schismtracker/pkg-plist6
4 files changed, 55 insertions, 0 deletions
diff --git a/audio/schismtracker/Makefile b/audio/schismtracker/Makefile
new file mode 100644
index 000000000000..17a652adde85
--- /dev/null
+++ b/audio/schismtracker/Makefile
@@ -0,0 +1,41 @@
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
+# $FreeBSD$
+
+PORTNAME= schismtracker
+PORTVERSION= 20160913
+PORTREVISION= 2
+CATEGORIES= audio
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Module tracker editor/player resembling impulse tracker
+
+LICENSE= GPLv2
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USES= autoreconf python compiler:c++11-lib desktop-file-utils
+USE_SDL= sdl
+USE_XORG= x11 xext xv
+GNU_CONFIGURE= yes
+
+USE_GITHUB= yes
+
+# if you touch these make sure configure finds X11/XKBlib.h presence
+LDFLAGS+= `sdl-config --libs`
+LIBS+= -lm -lX11
+CPPFLAGS+= -I${LOCALBASE}/include
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e "s|^\(AC_INIT.*\)\[last_git_commit\]|\1${PORTVERSION}|" \
+ -e '/^m4_define.*last_git_commit.*git/d' \
+ ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -e '/^schismtracker_LDADD/d' ${WRKSRC}/Makefile.am
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/sys/fd.org/*.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/icons/schism-icon-128.png \
+ ${WRKSRC}/icons/schism-itf-icon-128.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/audio/schismtracker/distinfo b/audio/schismtracker/distinfo
new file mode 100644
index 000000000000..1b6df161549b
--- /dev/null
+++ b/audio/schismtracker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475655562
+SHA256 (schismtracker-schismtracker-20160913_GH0.tar.gz) = 3c2fcea458ba7b41bcc63ee786c7eef0bfe8775639a3db8fab863e12f10888e9
+SIZE (schismtracker-schismtracker-20160913_GH0.tar.gz) = 1030790
diff --git a/audio/schismtracker/pkg-descr b/audio/schismtracker/pkg-descr
new file mode 100644
index 000000000000..a363b0e49858
--- /dev/null
+++ b/audio/schismtracker/pkg-descr
@@ -0,0 +1,5 @@
+Schism Tracker is a music editor that aims to match the look and feel of
+Impulse Tracker as closely as possible. The player code is based on Modplug,
+so it supports a wide variety of module formats.
+
+WWW: http://rigelseven.com/schism/
diff --git a/audio/schismtracker/pkg-plist b/audio/schismtracker/pkg-plist
new file mode 100644
index 000000000000..9f31d88f773c
--- /dev/null
+++ b/audio/schismtracker/pkg-plist
@@ -0,0 +1,6 @@
+bin/schismtracker
+man/man1/schismtracker.1.gz
+share/applications/itf.desktop
+share/applications/schism.desktop
+share/pixmaps/schism-icon-128.png
+share/pixmaps/schism-itf-icon-128.png