aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl2_mixer
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-06-21 19:56:27 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-06-21 19:56:27 +0000
commitc5a4db7c111615dacf0bd184c7b78e927dce311b (patch)
tree16b6a36999fedc7fbad7af76e86d017a12040f78 /audio/sdl2_mixer
parent2b6d9fd950bcce21b937ac81c7faa89131ebdfe9 (diff)
downloadports-c5a4db7c111615dacf0bd184c7b78e927dce311b.tar.gz
ports-c5a4db7c111615dacf0bd184c7b78e927dce311b.zip
Welcome SDL2 to the FreeBSD ports system!
A set of new SDL2 related ports has been added, which are essentially the same as their corresponding port for SDL1.2: audio/sdl2_mixer graphics/sdl2_image graphics/sdl2_ttf net/sdl2_net A set of new USE_SDL knobs is available to enable SDL2 and its related ports to be added as dependency to ports. Use either of USE_SDL= sdl2 image2 mixer2 net2 ttf2 to pull in the specific sdl2_* or sdl20 port.
Notes
Notes: svn path=/head/; revision=321500
Diffstat (limited to 'audio/sdl2_mixer')
-rw-r--r--audio/sdl2_mixer/Makefile60
-rw-r--r--audio/sdl2_mixer/distinfo2
-rw-r--r--audio/sdl2_mixer/pkg-descr6
-rw-r--r--audio/sdl2_mixer/pkg-plist7
4 files changed, 75 insertions, 0 deletions
diff --git a/audio/sdl2_mixer/Makefile b/audio/sdl2_mixer/Makefile
new file mode 100644
index 000000000000..f184fecc080c
--- /dev/null
+++ b/audio/sdl2_mixer/Makefile
@@ -0,0 +1,60 @@
+# $FreeBSD$
+
+PORTNAME= sdl2_mixer
+PORTVERSION= 2.0.p1
+CATEGORIES= audio
+MASTER_SITES= http://www.libsdl.org/tmp/SDL_mixer/release/
+DISTNAME= SDL2_mixer-2.0.0
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= A sample multi-channel audio mixer library
+
+LICENSE= ZLIB
+
+USES= pathfix pkgconfig:build
+USE_GMAKE= yes
+USE_SDL= sdl2
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= FLUIDSYNTH MODPLUG FLAC VORBIS
+OPTIONS_DEFAULT= FLUIDSYNTH MODPLUG FLAC VORBIS
+
+FLUIDSYNTH_DESC= Enable SoundFont2 Midi support via fluidsynth
+MODPLUG_DESC= Enable MOD music via libModPlug
+FLAC_DESC= Enable FLAC encoding support via flac
+VORBIS_DESC= Enable Ogg Vorbis music
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMODPLUG}
+LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
+CONFIGURE_ARGS+= --enable-music-mod --enable-music-mod-modplug
+.else
+CONFIGURE_ARGS+= --disable-music-mod --disable-music-mod-modplug
+.endif
+
+.if ${PORT_OPTIONS:MFLAC}
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+= --enable-music-flac
+.else
+CONFIGURE_ARGS+= --disable-music-flac
+.endif
+
+.if ${PORT_OPTIONS:MFLUIDSYNTH}
+LIB_DEPENDS+= fluidsynth:${PORTSDIR}/audio/fluidsynth
+CONFIGURE_ARGS+= --enable-music-midi --enable-music-midi-fluidsynth
+.else
+CONFIGURE_ARGS+= --disable-music-midi --disable-music-midi-fluidsynth
+.endif
+
+.if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+= --enable-music-ogg
+.else
+CONFIGURE_ARGS+= --disable-music-ogg
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/sdl2_mixer/distinfo b/audio/sdl2_mixer/distinfo
new file mode 100644
index 000000000000..8d8fb422c147
--- /dev/null
+++ b/audio/sdl2_mixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SDL2_mixer-2.0.0.tar.gz) = a3d72b0a02d27defc58665ffeef09247d874ea3e652a0326ef9b9f339581f836
+SIZE (SDL2_mixer-2.0.0.tar.gz) = 10109109
diff --git a/audio/sdl2_mixer/pkg-descr b/audio/sdl2_mixer/pkg-descr
new file mode 100644
index 000000000000..4ba39805f1c8
--- /dev/null
+++ b/audio/sdl2_mixer/pkg-descr
@@ -0,0 +1,6 @@
+SDL_mixer is a sample multi-channel audio mixer library. It supports any number
+of simultaneously playing channels of 16 bit stereo audio, plus a single
+channel of music, mixed by the popular MikMod MOD, Timidity MIDI and SMPEG MP3
+libraries.
+
+WWW: http://www.libsdl.org/projects/SDL_mixer/index.html
diff --git a/audio/sdl2_mixer/pkg-plist b/audio/sdl2_mixer/pkg-plist
new file mode 100644
index 000000000000..a7552a9553af
--- /dev/null
+++ b/audio/sdl2_mixer/pkg-plist
@@ -0,0 +1,7 @@
+include/SDL2/SDL_mixer.h
+lib/libSDL2_mixer-2.0.so
+lib/libSDL2_mixer-2.0.so.0
+lib/libSDL2_mixer.a
+lib/libSDL2_mixer.la
+lib/libSDL2_mixer.so
+libdata/pkgconfig/SDL2_mixer.pc