aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_mixer/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-09-21 12:02:02 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-09-21 12:02:02 +0000
commit5555c00c1ee4f35089cb024c7a2d408337a36da1 (patch)
treea039bbabdd109f0d48c0857bbe1404efcf8990b1 /audio/sdl_mixer/Makefile
parent758f1f016f12b250a048f5b6320208065f5d6c38 (diff)
downloadports-5555c00c1ee4f35089cb024c7a2d408337a36da1.tar.gz
ports-5555c00c1ee4f35089cb024c7a2d408337a36da1.zip
Notes
Diffstat (limited to 'audio/sdl_mixer/Makefile')
-rw-r--r--audio/sdl_mixer/Makefile46
1 files changed, 18 insertions, 28 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 3df68689813c..eaf95a76398f 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
@@ -22,44 +22,34 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-OPTIONS_DEFINE= MIKMOD SMPEG FLAC VORBIS TIMIDITYPLUS
-OPTIONS_DEFAULT= MIKMOD SMPEG FLAC VORBIS
+OPTIONS_DEFINE= SMPEG FLAC VORBIS TIMIDITYPLUS
+OPTIONS_DEFAULT= SMPEG FLAC VORBIS
+OPTIONS_RADIO= MOD
+OPTIONS_RADIO_MOD= MIKMOD MODPLUG
MIKMOD_DESC= Enable MOD music via libMikMod
+MODPLUG_DESC= Enable MOD music via libModPlug
SMPEG_DESC= Enable MP3 music via SMPEG
FLAC_DESC= Enable FLAC encoding support via flac
VORBIS_DESC= Enable Ogg Vorbis music
TIMIDITYPLUS_DESC= Use Timidity++ instead of Timidity (soundfont)
-.include <bsd.port.pre.mk>
+MIKMOD_LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod
+MIKMOD_CONFIGURE_ENABLE= music-mod
-.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
-CONFIGURE_ARGS+= --enable-music-mod
-.else
-CONFIGURE_ARGS+= --disable-music-mod
-.endif
+MODPLUG_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug
+MODPLUG_CONFIGURE_ENABLE= music-mod-modplug
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
-CONFIGURE_ARGS+= --enable-music-flac
-.else
-CONFIGURE_ARGS+= --disable-music-flac
-.endif
+FLAC_LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac
+FLAC_CONFIGURE_ENABLE= music-flac
-.if ${PORT_OPTIONS:MSMPEG}
-LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
-CONFIGURE_ARGS+= --enable-music-mp3
-.else
-CONFIGURE_ARGS+= --disable-music-mp3
-.endif
+SMPEG_LIB_DEPENDS= smpeg:${PORTSDIR}/multimedia/smpeg
+SMPEG_CONFIGURE_ENABLE= music-mp3
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+= --enable-music-ogg
-.else
-CONFIGURE_ARGS+= --disable-music-ogg
-.endif
+VORBIS_LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_ENABLE= music-ogg
+
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MTIMIDITYPLUS}
RUN_DEPENDS+= ${LOCALBASE}/share/timidity/timidity.cfg-eawpats:${PORTSDIR}/audio/eawpats