aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_mixer
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-08 08:20:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-08 08:20:10 +0000
commita0108e03523ba47be4ce04fb3a46f992015fab6f (patch)
treed75502a455d6356b61cd98cb14d146fdecd9d9f5 /audio/sdl_mixer
parent3d31c33e2e630555fb4e07e512ed71e7259c2c4c (diff)
downloadports-a0108e03523ba47be4ce04fb3a46f992015fab6f.tar.gz
ports-a0108e03523ba47be4ce04fb3a46f992015fab6f.zip
Notes
Diffstat (limited to 'audio/sdl_mixer')
-rw-r--r--audio/sdl_mixer/Makefile1
-rw-r--r--audio/sdl_mixer/files/patch-SDL_mixer.h14
-rw-r--r--audio/sdl_mixer/files/patch-mixer.c24
3 files changed, 39 insertions, 0 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 854c9384bf17..e9f0025815f6 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
diff --git a/audio/sdl_mixer/files/patch-SDL_mixer.h b/audio/sdl_mixer/files/patch-SDL_mixer.h
new file mode 100644
index 000000000000..67d21b9f24d7
--- /dev/null
+++ b/audio/sdl_mixer/files/patch-SDL_mixer.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- SDL_mixer.h 2001/05/08 07:44:56 1.1
++++ SDL_mixer.h 2001/05/08 07:48:13
+@@ -222,6 +222,8 @@
+ /* Close the mixer, halting all playing audio */
+ extern DECLSPEC void Mix_CloseAudio(void);
+
++extern DECLSPEC int Mix_GetMixerInfo(SDL_AudioSpec *, char *, int);
++
+ /* We'll use SDL for reporting errors */
+ #define Mix_SetError SDL_SetError
+ #define Mix_GetError SDL_GetError
diff --git a/audio/sdl_mixer/files/patch-mixer.c b/audio/sdl_mixer/files/patch-mixer.c
new file mode 100644
index 000000000000..819646081cdd
--- /dev/null
+++ b/audio/sdl_mixer/files/patch-mixer.c
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- mixer.c 2001/05/08 07:44:26 1.1
++++ mixer.c 2001/05/08 07:47:09
+@@ -865,3 +865,18 @@
+ }
+ return(chan);
+ }
++
++int Mix_GetMixerInfo(SDL_AudioSpec *m, char *namebuf, int maxlen)
++{
++ if (!audio_opened)
++ return -1;
++ if (m)
++ *m = mixer; /* struct copy */
++ if (namebuf && maxlen > 0)
++ {
++ namebuf[0] = 0;
++ if (SDL_AudioDriverName(namebuf, maxlen) == NULL)
++ namebuf[0] = 0;
++ }
++ return 0;
++}