aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_mixer
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-09 05:18:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-09 05:18:50 +0000
commitef0438863c3a7fab6b0fbb49cd56724a9064de12 (patch)
tree21f61c80b482e03fde67b9407f49d022857956c6 /audio/sdl_mixer
parent215f1dd63ca0cf4e88564e1829e63a78222364f1 (diff)
downloadports-ef0438863c3a7fab6b0fbb49cd56724a9064de12.tar.gz
ports-ef0438863c3a7fab6b0fbb49cd56724a9064de12.zip
audio/sdl{,2}_mixer: add TREMOR option
TREMOR is enabled by default on platforms without hardware floating point. PR: 202689 Approved by: maintainer timeout (6 months)
Notes
Notes: svn path=/head/; revision=410689
Diffstat (limited to 'audio/sdl_mixer')
-rw-r--r--audio/sdl_mixer/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 6b6464beb94b..13bec51b22d3 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.12
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
@@ -20,10 +20,17 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-OPTIONS_DEFINE= SMPEG FLAC VORBIS TIMIDITYPLUS
-OPTIONS_DEFAULT= SMPEG FLAC VORBIS MIKMOD
-OPTIONS_RADIO= MOD
+OPTIONS_DEFINE= SMPEG FLAC TIMIDITYPLUS
+OPTIONS_DEFAULT= SMPEG FLAC MIKMOD
+OPTIONS_RADIO= MOD OGG
OPTIONS_RADIO_MOD= MIKMOD MODPLUG
+OPTIONS_RADIO_OGG= VORBIS TREMOR
+
+.if defined(MACHINE_CPU) && ${MACHINE_CPU:Msoftfp}
+OPTIONS_DEFAULT+= TREMOR
+.else
+OPTIONS_DEFAULT+= VORBIS
+.endif
MIKMOD_DESC= Enable MOD music via libMikMod
MODPLUG_DESC= Enable MOD music via libModPlug
@@ -53,6 +60,9 @@ TIMIDITYPLUS_VARS= CONFIG_FILE=${LOCALBASE}/share/timidity/timidity.cfg-eawpats
TIMIDITYPLUS_RUN_DEPENDS_OFF= ${LOCALBASE}/lib/timidity/timidity.cfg:${PORTSDIR}/audio/timidity
TIMIDITYPLUS_VARS_OFF= CONFIG_FILE=${LOCALBASE}/lib/timidity/timidity.cfg
+TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_CONFIGURE_ENABLE= music-ogg music-ogg-tremor
+
post-patch:
@${REINPLACE_CMD} -e 's|\($$(prefix)/libdata/pkgconfig\)|$$(DESTDIR)\1|' \
${WRKSRC}/Makefile.in