aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_sound
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:35:36 +0000
commit5978476c353873821167189c3e7e7d3ce7b9909a (patch)
tree5c7b83e7642fc29f698d59a6bc145001dbd04783 /audio/sdl_sound
parent95ab3035bfc8b040822f80592efa7b9f2b7a51b6 (diff)
downloadports-5978476c353873821167189c3e7e7d3ce7b9909a.tar.gz
ports-5978476c353873821167189c3e7e7d3ce7b9909a.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in audio With hat: portmgr
Notes
Notes: svn path=/head/; revision=336166
Diffstat (limited to 'audio/sdl_sound')
-rw-r--r--audio/sdl_sound/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index b539d58e35aa..73500c2fb12c 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -28,38 +28,38 @@ SMPEG_DESC= MP3 audio format
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
.else
CONFIGURE_ARGS+=--disable-flac
.endif
.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
+LIB_DEPENDS+= libmikmod.so:${PORTSDIR}/audio/libmikmod
.else
CONFIGURE_ARGS+=--disable-mikmod
.endif
.if ${PORT_OPTIONS:MMODPLUG}
-LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
+LIB_DEPENDS+= libmodplug.so:${PORTSDIR}/audio/libmodplug
.else
CONFIGURE_ARGS+=--disable-modplug
.endif
.if ${PORT_OPTIONS:MPHYSFS}
-LIB_DEPENDS+= physfs:${PORTSDIR}/devel/physfs
+LIB_DEPENDS+= libphysfs.so:${PORTSDIR}/devel/physfs
.else
CONFIGURE_ARGS+=--disable-physfs
.endif
.if ${PORT_OPTIONS:MSMPEG}
-LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
+LIB_DEPENDS+= libsmpeg.so:${PORTSDIR}/multimedia/smpeg
CONFIGURE_ARGS+=--disable-mpglib
.else
CONFIGURE_ARGS+=--disable-smpeg
.endif
.if ${PORT_OPTIONS:MSPEEX}
-LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
.else
CONFIGURE_ARGS+=--disable-speex
.endif
@@ -72,7 +72,7 @@ CONFIGURE_ARGS+=--disable-midi
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+=--disable-ogg
.endif