aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_sound
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2010-06-02 19:03:01 +0000
committerMarcus von Appen <mva@FreeBSD.org>2010-06-02 19:03:01 +0000
commitbf7d2998c68c3bf34712113222b54cfc6a4ee0a9 (patch)
tree72317331ba8e884e968a8be5a5de4061b8027ab4 /audio/sdl_sound
parent846585d4284b907abc677f1289fb01ba509a62c9 (diff)
downloadports-bf7d2998c68c3bf34712113222b54cfc6a4ee0a9.tar.gz
ports-bf7d2998c68c3bf34712113222b54cfc6a4ee0a9.zip
Fix missing libmodplug dependency and add an OPTIONS knob for it.
PR: ports/147305 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=255576
Diffstat (limited to 'audio/sdl_sound')
-rw-r--r--audio/sdl_sound/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index 8d052ccc0734..3b4b59755c7a 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sdl_sound
PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://offload1.icculus.org:9090/SDL_sound/downloads/ \
http://offload2.icculus.org:9090/SDL_sound/downloads/
@@ -21,13 +21,14 @@ USE_LDCONFIG= yes
USE_SDL= sdl
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= FLAC "Enable flac support" on \
- MIKMOD "Enable mikmod support" on \
- PHYSFS "Enable physfs support" on \
- SMPEG "Enable smpeg support" on \
- SPEEX "Enable speex support" on \
- MIDI "Enable MIDI support" on \
- VORBIS "Enable Ogg Vorbis support" on
+OPTIONS= FLAC "Enable FLAC decoding support" on \
+ MIKMOD "Enable MOD decoding support using mikmod" on \
+ MIDI "Enable software MIDI music" on \
+ MODPLUG "Enable MOD decoding support using modplug" on \
+ PHYSFS "Enable PhysicsFS support" on \
+ SMPEG "Enable MP3 decoding support" on \
+ SPEEX "Enable SPX decoding support" on \
+ VORBIS "Enable Ogg Vorbis decoding support" on
.include <bsd.port.pre.mk>
@@ -43,6 +44,12 @@ LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
CONFIGURE_ARGS+=--disable-mikmod
.endif
+.if !defined(WITHOUT_MODPLUG)
+LIB_DEPENDS+= modplug.1:${PORTSDIR}/audio/libmodplug
+.else
+CONFIGURE_ARGS+=--disable-modplug
+.endif
+
.if !defined(WITHOUT_PHYSFS)
LIB_DEPENDS+= physfs.1:${PORTSDIR}/devel/physfs
.else