aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_sound
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-10-07 13:07:29 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-10-07 13:07:29 +0000
commitef3504f900526a2ba1235091d48e41f2ea8bd565 (patch)
treebe8e8cbee8b8599cd168bd484cd1416e4c9b6109 /audio/sdl_sound
parentcbd0afe866888dd99d0172982ddfff0da7fef284 (diff)
downloadports-ef3504f900526a2ba1235091d48e41f2ea8bd565.tar.gz
ports-ef3504f900526a2ba1235091d48e41f2ea8bd565.zip
- Convert to OptionsNG
Submitted by: A.J. Kehoe IV (Nanoman) (via mail)
Notes
Notes: svn path=/head/; revision=305470
Diffstat (limited to 'audio/sdl_sound')
-rw-r--r--audio/sdl_sound/Makefile46
1 files changed, 22 insertions, 24 deletions
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index be5985c0f0b8..69a11f5a0492 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -22,69 +22,67 @@ USE_SDL= sdl
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= FLAC "Enable FLAC decoding support" on \
- MIKMOD "Enable MOD decoding support using mikmod" on \
- MIDI "Enable software MIDI music" on \
- MODPLUG "Enable MOD decoding support using modplug" on \
- PHYSFS "Enable PhysicsFS support" on \
- SMPEG "Enable MP3 decoding support" on \
- SPEEX "Enable SPX decoding support" on \
- VORBIS "Enable Ogg Vorbis decoding support" on
+OPTIONS_DEFINE= FLAC MIKMOD MIDI MODPLUG PHYSFS SMPEG SPEEX VORBIS
+OPTIONS_DEFAULT= FLAC MIKMOD MIDI MODPLUG PHYSFS SMPEG SPEEX VORBIS
+
+MIDI_DESC= Software MIDI music
+PHYSFS_DESC= PhysicsFS support
+SMPEG_DESC= MP3 audio format
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_FLAC)
-LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+.if ${PORT_OPTIONS:MFLAC}
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
.else
CONFIGURE_ARGS+=--disable-flac
.endif
-.if !defined(WITHOUT_MIKMOD)
-LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+.if ${PORT_OPTIONS:MMIKMOD}
+LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
.else
CONFIGURE_ARGS+=--disable-mikmod
.endif
-.if !defined(WITHOUT_MODPLUG)
-LIB_DEPENDS+= modplug.1:${PORTSDIR}/audio/libmodplug
+.if ${PORT_OPTIONS:MMODPLUG}
+LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
.else
CONFIGURE_ARGS+=--disable-modplug
.endif
-.if !defined(WITHOUT_PHYSFS)
-LIB_DEPENDS+= physfs.1:${PORTSDIR}/devel/physfs
+.if ${PORT_OPTIONS:MPHYSFS}
+LIB_DEPENDS+= physfs:${PORTSDIR}/devel/physfs
.else
CONFIGURE_ARGS+=--disable-physfs
.endif
-.if !defined(WITHOUT_SMPEG)
-LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+.if ${PORT_OPTIONS:MSMPEG}
+LIB_DEPENDS+= smpeg:${PORTSDIR}/multimedia/smpeg
CONFIGURE_ARGS+=--disable-mpglib
.else
CONFIGURE_ARGS+=--disable-smpeg
.endif
-.if !defined(WITHOUT_SPEEX)
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+.if ${PORT_OPTIONS:MSPEEX}
+LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex
.else
CONFIGURE_ARGS+=--disable-speex
.endif
-.if !defined(WITHOUT_MIDI)
+.if ${PORT_OPTIONS:MMIDI}
RUN_DEPENDS+= ${LOCALBASE}/lib/timidity/goemon.cfg:${PORTSDIR}/audio/timidity
BUILD_DEPENDS+= ${LOCALBASE}/lib/timidity/goemon.cfg:${PORTSDIR}/audio/timidity
.else
CONFIGURE_ARGS+=--disable-midi
.endif
-.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+=--disable-ogg
.endif
-.if defined(WITHOUT_SMPEG)
pre-everything::
+.if !${PORT_OPTIONS:MSMPEG}
@${ECHO_CMD}
@${ECHO_CMD} "WARNING: the built-in MP3 support is currently broken, consider enabling the SMPEG option to use that library instead." | ${FMT}
@${ECHO_CMD}