aboutsummaryrefslogtreecommitdiff
path: root/audio/sidplay2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 12:42:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 12:42:16 +0000
commitbab0038480dea92811c8f291f1ab1ee39a06a16e (patch)
tree3a40df42ee182be7e84031eaff06b8084a8a0496 /audio/sidplay2
parent296be2414bfbe304d9c96fa656d7a041f591390d (diff)
downloadports-bab0038480dea92811c8f291f1ab1ee39a06a16e.tar.gz
ports-bab0038480dea92811c8f291f1ab1ee39a06a16e.zip
audio/sidplay2: oops, fix typo in r433015
Notes
Notes: svn path=/head/; revision=433025
Diffstat (limited to 'audio/sidplay2')
-rw-r--r--audio/sidplay2/Makefile2
-rw-r--r--audio/sidplay2/files/patch-src_args.cpp3
2 files changed, 3 insertions, 2 deletions
diff --git a/audio/sidplay2/Makefile b/audio/sidplay2/Makefile
index a3151aefd60e..d8e6c46e7311 100644
--- a/audio/sidplay2/Makefile
+++ b/audio/sidplay2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sidplay2
PORTVERSION= 2.0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/sidplay-${PORTVERSION}
DISTNAME= sidplay-${PORTVERSION}
diff --git a/audio/sidplay2/files/patch-src_args.cpp b/audio/sidplay2/files/patch-src_args.cpp
index 99213f69711a..4793c1d19592 100644
--- a/audio/sidplay2/files/patch-src_args.cpp
+++ b/audio/sidplay2/files/patch-src_args.cpp
@@ -14,8 +14,9 @@
{ // Read in MM:SS format
int val;
- *sep = '\0';
+- val = atoi (str);
+ char *tmp = strndup(str, sep - str);
- val = atoi (str);
++ val = atoi (tmp);
+ free(tmp);
if (val < 0 || val > 99)
return false;