aboutsummaryrefslogtreecommitdiff
path: root/audio/siren
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-05-20 17:04:32 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-05-20 17:04:32 +0000
commit0117910ee5ad851ecc5dd43a1d7129f21014eb6b (patch)
treefd72b86ad37ee19dbdcb6673d9ca8f1b70172373 /audio/siren
parent74fa808d34ee655874151e5c38668b44f18bf58e (diff)
downloadports-0117910ee5ad851ecc5dd43a1d7129f21014eb6b.tar.gz
ports-0117910ee5ad851ecc5dd43a1d7129f21014eb6b.zip
* Update to 0.7
* Convert SOUND from OPTIONS_MULTI to OPTIONS_SINGLE. The arguments show that it is meant to be exclusive. * Add options for FFMPEG and MPG123 as they are picked up if installed. Further patch in toggleability for FFMPEG. Reviewed by: rakuco Approved by: rakuco (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10836
Notes
Notes: svn path=/head/; revision=441321
Diffstat (limited to 'audio/siren')
-rw-r--r--audio/siren/Makefile15
-rw-r--r--audio/siren/distinfo5
-rw-r--r--audio/siren/files/patch-configure14
-rw-r--r--audio/siren/pkg-plist2
4 files changed, 29 insertions, 7 deletions
diff --git a/audio/siren/Makefile b/audio/siren/Makefile
index 38ae499d04f0..1ea37e3d393e 100644
--- a/audio/siren/Makefile
+++ b/audio/siren/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= siren
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= audio
MASTER_SITES= http://www.kariliq.nl/${PORTNAME}/dist/
@@ -18,17 +17,23 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libvorbis.so:audio/libvorbis \
libwavpack.so:audio/wavpack \
libopusfile.so:audio/opusfile
-
USES= ncurses pkgconfig
HAS_CONFIGURE= yes
USE_CSTD= c99
-OPTIONS_MULTI= SOUND
-OPTIONS_MULTI_SOUND= OSS PULSEAUDIO
+OPTIONS_DEFINE= FFMPEG MPG123
+OPTIONS_SINGLE= SOUND
+OPTIONS_SINGLE_SOUND= OSS PULSEAUDIO
OPTIONS_DEFAULT= OSS
OSS_CONFIGURE_ON= oss=yes pulse=no
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ON= oss=no pulse=yes
+FFMPEG_CONFIGURE_ON= ffmpeg=yes
+FFMPEG_CONFIGURE_OFF= ffmpeg=no
+FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
+MPG123_CONFIGURE_ON= mpg123=yes
+MPG123_CONFIGURE_OFF= mpg123=no
+MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
OPTIONS_SUB= yes
CONFIGURE_ARGS= sndfile=no \
diff --git a/audio/siren/distinfo b/audio/siren/distinfo
index d4216fcbafe9..93ef870e5be2 100644
--- a/audio/siren/distinfo
+++ b/audio/siren/distinfo
@@ -1,2 +1,3 @@
-SHA256 (siren-0.6.tar.gz) = 5ac944e5d2737942afa1270bf66d72d631b896d37b4c084bdd3a766a5e735a14
-SIZE (siren-0.6.tar.gz) = 96833
+TIMESTAMP = 1495297978
+SHA256 (siren-0.7.tar.gz) = 9be67c83c9ef127127ce4645a5919bd3f963e47d3c12492bc8fbc7c1d20b3d3c
+SIZE (siren-0.7.tar.gz) = 99891
diff --git a/audio/siren/files/patch-configure b/audio/siren/files/patch-configure
new file mode 100644
index 000000000000..366264ab6654
--- /dev/null
+++ b/audio/siren/files/patch-configure
@@ -0,0 +1,14 @@
+Make ffmpeg toggleable.
+
+--- configure.orig 2017-05-20 16:53:55 UTC
++++ configure
+@@ -314,6 +314,9 @@ for arg; do
+ sun=*)
+ get_option_value enable_sun "$arg"
+ ;;
++ ffmpeg=*)
++ get_option_value enable_ffmpeg "$arg"
++ ;;
+ help|-h|--help)
+ error "see the INSTALL file for more information"
+ ;;
diff --git a/audio/siren/pkg-plist b/audio/siren/pkg-plist
index cd2bbb631fe7..7420cc9b62c5 100644
--- a/audio/siren/pkg-plist
+++ b/audio/siren/pkg-plist
@@ -4,6 +4,8 @@ lib/siren/ip/mad.so
lib/siren/ip/opus.so
lib/siren/ip/vorbis.so
lib/siren/ip/wavpack.so
+%%FFMPEG%%lib/siren/ip/ffmpeg.so
+%%MPG123%%lib/siren/ip/mpg123.so
%%OSS%%lib/siren/op/oss.so
%%PULSEAUDIO%%lib/siren/op/pulse.so
man/man1/siren.1.gz