aboutsummaryrefslogtreecommitdiff
path: root/audio/siren
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-06-12 11:25:04 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-06-12 11:25:04 +0000
commitafb7ad7809b6f1f4065af17309f48ab063202d3c (patch)
tree5149828bf4fab706f038622bd069629e7a260aed /audio/siren
parent7fd03cdea2dd75293eef9c53c475eca78d636b57 (diff)
downloadports-afb7ad7809b6f1f4065af17309f48ab063202d3c.tar.gz
ports-afb7ad7809b6f1f4065af17309f48ab063202d3c.zip
Allow building of more than one output plugin. Output plugins can be
selected at run time with e.g. ':set output-plugin pulse'. - Add SNDIO option - Add LICENSE_FILE (yes, the filename is really LICENCE ;)) Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D11120
Notes
Notes: svn path=/head/; revision=443440
Diffstat (limited to 'audio/siren')
-rw-r--r--audio/siren/Makefile17
-rw-r--r--audio/siren/pkg-plist1
2 files changed, 13 insertions, 5 deletions
diff --git a/audio/siren/Makefile b/audio/siren/Makefile
index 43e9a2a14b7b..b2cba9e5627d 100644
--- a/audio/siren/Makefile
+++ b/audio/siren/Makefile
@@ -3,6 +3,7 @@
PORTNAME= siren
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.kariliq.nl/${PORTNAME}/dist/
@@ -10,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Text-based audio player
LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENCE
LIB_DEPENDS= libFLAC.so:audio/flac \
libid3tag.so:audio/libid3tag \
@@ -27,12 +29,18 @@ HAS_CONFIGURE= yes
USE_CSTD= c99
OPTIONS_DEFINE= FFMPEG MPG123
-OPTIONS_SINGLE= SOUND
-OPTIONS_SINGLE_SOUND= OSS PULSEAUDIO
+OPTIONS_MULTI= SOUND
+OPTIONS_MULTI_SOUND= OSS PULSEAUDIO SNDIO
OPTIONS_DEFAULT= OSS
-OSS_CONFIGURE_ON= oss=yes pulse=no
+OSS_CONFIGURE_ON= oss=yes
+OSS_CONFIGURE_OFF= oss=no
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-PULSEAUDIO_CONFIGURE_ON= oss=no pulse=yes
+PULSEAUDIO_CONFIGURE_ON= pulse=yes
+PULSEAUDIO_CONFIGURE_OFF= pulse=no
+SNDIO_CONFIGURE_ON= sndio=yes
+SNDIO_CONFIGURE_OFF= sndio=no
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_USES= localbase:ldflags
FFMPEG_CONFIGURE_ON= ffmpeg=yes
FFMPEG_CONFIGURE_OFF= ffmpeg=no
FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
@@ -44,7 +52,6 @@ OPTIONS_SUB= yes
CONFIGURE_ARGS= sndfile=no \
alsa=no \
ao=no \
- sndio=no \
sun=no \
portaudio=no \
aac=no
diff --git a/audio/siren/pkg-plist b/audio/siren/pkg-plist
index 7420cc9b62c5..7e81ca32b4a1 100644
--- a/audio/siren/pkg-plist
+++ b/audio/siren/pkg-plist
@@ -8,4 +8,5 @@ lib/siren/ip/wavpack.so
%%MPG123%%lib/siren/ip/mpg123.so
%%OSS%%lib/siren/op/oss.so
%%PULSEAUDIO%%lib/siren/op/pulse.so
+%%SNDIO%%lib/siren/op/sndio.so
man/man1/siren.1.gz