aboutsummaryrefslogtreecommitdiff
path: root/audio/snack/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-11-24 02:53:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-11-24 02:53:20 +0000
commite2e5c40ad0b44e75d738cb7a8761b6d970dbc629 (patch)
treeeca5df93e7333810924640e22691f2652ab13042 /audio/snack/Makefile
parentdf8ced14fd7ea1170047a419559ef958546c8828 (diff)
Notes
Diffstat (limited to 'audio/snack/Makefile')
-rw-r--r--audio/snack/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index 109d38819120..8e34bd23924b 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= snack
-PORTVERSION= 2.2.7
+PORTVERSION= 2.2.8
CATEGORIES= audio tcl84 tk84
MASTER_SITES= http://www.speech.kth.se/~kare/
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -19,6 +19,8 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+OPTIONS= VORBIS "Support for OGG/Vorbis Audio" off
+
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -26,12 +28,14 @@ CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
-PLIST_SUB= SNACK_VER=${PORTVERSION:R}
-
CFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 \
-I${LOCALBASE}/include
-OPTIONS= VORBIS "Support for OGG/Vorbis Audio" off
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_SUB= SNACK_VER=${PORTVERSION:R}
.include <bsd.port.pre.mk>