aboutsummaryrefslogtreecommitdiff
path: root/audio/snack
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-23 11:15:00 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-23 11:15:00 +0000
commit22a31d086c3f0bf08f4a8d3ed677228de8fd2c5b (patch)
treea7c6e4a2e678b09394bdc6d8f1ad0aa5f34f9cc7 /audio/snack
parent7db26d9385f0d5233d78f71fc9c98ffefadfe02e (diff)
downloadports-22a31d086c3f0bf08f4a8d3ed677228de8fd2c5b.tar.gz
ports-22a31d086c3f0bf08f4a8d3ed677228de8fd2c5b.zip
- Convert to USES=tk
- STAGE-clean
Notes
Notes: svn path=/head/; revision=340823
Diffstat (limited to 'audio/snack')
-rw-r--r--audio/snack/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index 5ec9a29a4722..10edfd1c1f60 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -13,42 +13,30 @@ COMMENT= A sound toolkit for scripting languages
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-USE_TK= 84+
-NO_STAGE= yes
-
OPTIONS_DEFINE= VORBIS DOCS
+OPTIONS_SUB= yes
+USES= tk
+USE_LDCONFIG= ${PREFIX}/lib/snack${PORTVERSION:R}
GNU_CONFIGURE= yes
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
-
-PLIST_SUB= SNACK_VER=${PORTVERSION:R}
-
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR}
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
-CFLAGS+= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} \
- -I${LOCALBASE}/include
+PLIST_SUB= SNACK_VER=${PORTVERSION:R}
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+= --with-ogg-include=${LOCALBASE}/include \
- --with-ogg-lib=${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-ogg-include=${LOCALBASE}/include \
+ --with-ogg-lib=${LOCALBASE}/lib
ALL_TARGET= all libsnackogg.so
-PLIST_SUB+= VORBIS=""
-.else
-PLIST_SUB+= VORBIS="@comment "
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/../doc/* ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>