aboutsummaryrefslogtreecommitdiff
path: root/audio/sndio/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-03 06:15:41 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-08-03 06:15:41 +0000
commit026baf8a419918d86c3559316e886ff77c8eb0a1 (patch)
treef9d9753690b2c86cea7e3547302f66dde94a755f /audio/sndio/Makefile
parent7f5840ad268a51ec2fd52677cad792f7a99debc9 (diff)
downloadports-026baf8a419918d86c3559316e886ff77c8eb0a1.tar.gz
ports-026baf8a419918d86c3559316e886ff77c8eb0a1.zip
Notes
Diffstat (limited to 'audio/sndio/Makefile')
-rw-r--r--audio/sndio/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/audio/sndio/Makefile b/audio/sndio/Makefile
new file mode 100644
index 000000000000..f11b150dc23c
--- /dev/null
+++ b/audio/sndio/Makefile
@@ -0,0 +1,41 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= sndio
+PORTVERSION= 1.1.0
+CATEGORIES= audio
+MASTER_SITES= http://www.sndio.org/
+
+MAINTAINER= t@tobik.me
+COMMENT= Small audio and MIDI framework from the OpenBSD project
+
+LICENSE= ISCL
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man
+
+USE_LDCONFIG= yes
+USE_RC_SUBR= sndiod
+
+.include <bsd.port.pre.mk>
+
+# FreeBSD 9.x does not have SOCK_CLOEXEC
+.if ${OSVERSION} < 1000000
+CFLAGS+= -DSOCK_CLOEXEC=0
+.endif
+
+USERS= _sndio
+GROUPS= _sndio
+
+# Parallel build leads to problems, but sndio is very quick to compile
+# as is so not worth fixing
+MAKE_JOBS_UNSAFE= yes
+
+post-install:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/lib/libsndio.so.6.1 \
+ ${STAGEDIR}${PREFIX}/bin/sndiod \
+ ${STAGEDIR}${PREFIX}/bin/aucat \
+ ${STAGEDIR}${PREFIX}/bin/midicat
+
+.include <bsd.port.post.mk>