aboutsummaryrefslogtreecommitdiff
path: root/audio/sound-juicer
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /audio/sound-juicer
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'audio/sound-juicer')
-rw-r--r--audio/sound-juicer/Makefile14
-rw-r--r--audio/sound-juicer/distinfo6
-rw-r--r--audio/sound-juicer/files/patch-src::Makefile.in19
-rw-r--r--audio/sound-juicer/pkg-plist23
4 files changed, 37 insertions, 25 deletions
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 0f6ca61cced3..e212a38eab09 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -3,32 +3,34 @@
# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/sound-juicer/Makefile,v 1.29 2005/09/19 13:18:32 marcus Exp $
+# $MCom: ports/audio/sound-juicer/Makefile,v 1.49 2006/04/14 15:06:00 ahze Exp $
#
PORTNAME= sound-juicer
-PORTVERSION= 2.12.3
+PORTVERSION= 2.14.3
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Clean, mean and lean CD ripper for GNOME2
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
- gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+ gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2 \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_REINPLACE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner \
gnomedocutils
USE_GSTREAMER= cdparanoia vorbis flac gconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ignore-missing-cd
+INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -36,5 +38,7 @@ GCONF_SCHEMAS= sound-juicer.schemas
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS = .*\)tests\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|--parents|-p|g' \
+ ${WRKSRC}/data/Makefile.in
.include <bsd.port.mk>
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index 9e28d45b9b25..d43b5ed55c60 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/sound-juicer-2.12.3.tar.bz2) = 395395c26b035d466f145dc908021a7f
-SHA256 (gnome2/sound-juicer-2.12.3.tar.bz2) = beae4a847e4c63bb8015a023751219dc2c7c0d23f931d19f2c8b957981c8db60
-SIZE (gnome2/sound-juicer-2.12.3.tar.bz2) = 802832
+MD5 (gnome2/sound-juicer-2.14.3.tar.bz2) = c525c4ef4e8cae163f7f1b6a28460e49
+SHA256 (gnome2/sound-juicer-2.14.3.tar.bz2) = f6b1e4af5b20bb3d986b40fa9d342e2cb422e43cff56a8f8541fd9f76ec64683
+SIZE (gnome2/sound-juicer-2.14.3.tar.bz2) = 875055
diff --git a/audio/sound-juicer/files/patch-src::Makefile.in b/audio/sound-juicer/files/patch-src::Makefile.in
index 187926fc41e3..189365e86d3f 100644
--- a/audio/sound-juicer/files/patch-src::Makefile.in
+++ b/audio/sound-juicer/files/patch-src::Makefile.in
@@ -1,20 +1,11 @@
---- src/Makefile.in.orig Tue Aug 23 20:23:29 2005
-+++ src/Makefile.in Tue Aug 23 20:23:57 2005
-@@ -63,7 +63,7 @@
- sj-about.$(OBJEXT) sj-extracting.$(OBJEXT) \
- bacon-volume.$(OBJEXT) $(am__objects_1) $(am__objects_2)
+--- src/Makefile.in.orig Mon Apr 3 23:40:45 2006
++++ src/Makefile.in Mon Apr 3 23:40:45 2006
+@@ -77,7 +77,7 @@ am_sound_juicer_OBJECTS = dummy.$(OBJEXT
+ gconf-bridge.$(OBJEXT) bacon-volume.$(OBJEXT) $(am__objects_2) \
+ $(am__objects_3) $(am__objects_4)
sound_juicer_OBJECTS = $(am_sound_juicer_OBJECTS)
-sound_juicer_LDADD = $(LDADD)
+sound_juicer_LDADD = $(LDADD) -lcam
DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
-@@ -257,7 +257,7 @@
- target_alias = @target_alias@
-
- # General compiler flags
--AM_CFLAGS = -Wall -export-dynamic -W -Wno-unused-parameter
-+AM_CFLAGS = -Wall -export-dynamic -W
-
- # General CPP flags. When I can demand automake 1.8, this can become
- # sound_juicer_CPPFLAGS.
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index 1b1ef9c77131..75ed982ba8e2 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -10,6 +10,11 @@ share/gnome/help/sound-juicer/es/figures/prefs.png
share/gnome/help/sound-juicer/es/figures/startup.png
share/gnome/help/sound-juicer/es/legal.xml
share/gnome/help/sound-juicer/es/sound-juicer.xml
+share/gnome/help/sound-juicer/nl/fdl-appendix.xml
+share/gnome/help/sound-juicer/nl/figures/prefs.png
+share/gnome/help/sound-juicer/nl/figures/startup.png
+share/gnome/help/sound-juicer/nl/legal.xml
+share/gnome/help/sound-juicer/nl/sound-juicer.xml
share/gnome/help/sound-juicer/uk/fdl-appendix.xml
share/gnome/help/sound-juicer/uk/figures/prefs.png
share/gnome/help/sound-juicer/uk/figures/startup.png
@@ -17,17 +22,21 @@ share/gnome/help/sound-juicer/uk/legal.xml
share/gnome/help/sound-juicer/uk/sound-juicer.xml
share/gnome/omf/sound-juicer/sound-juicer-C.omf
share/gnome/omf/sound-juicer/sound-juicer-es.omf
+share/gnome/omf/sound-juicer/sound-juicer-nl.omf
share/gnome/omf/sound-juicer/sound-juicer-uk.omf
-share/gnome/pixmaps/sound-juicer.png
-share/gnome/sound-juicer/orange-slice.png
share/gnome/sound-juicer/sj-play.png
share/gnome/sound-juicer/sj-record.png
share/gnome/sound-juicer/sound-juicer.glade
+share/icons/hicolor/16x16/apps/sound-juicer.png
+share/icons/hicolor/22x22/apps/sound-juicer.png
+share/icons/hicolor/24x24/apps/sound-juicer.png
+share/icons/hicolor/scalable/apps/sound-juicer.svg
share/locale/ar/LC_MESSAGES/sound-juicer.mo
share/locale/az/LC_MESSAGES/sound-juicer.mo
share/locale/be/LC_MESSAGES/sound-juicer.mo
share/locale/bg/LC_MESSAGES/sound-juicer.mo
share/locale/bn/LC_MESSAGES/sound-juicer.mo
+share/locale/br/LC_MESSAGES/sound-juicer.mo
share/locale/ca/LC_MESSAGES/sound-juicer.mo
share/locale/cs/LC_MESSAGES/sound-juicer.mo
share/locale/cy/LC_MESSAGES/sound-juicer.mo
@@ -44,13 +53,13 @@ share/locale/fi/LC_MESSAGES/sound-juicer.mo
share/locale/fr/LC_MESSAGES/sound-juicer.mo
share/locale/gl/LC_MESSAGES/sound-juicer.mo
share/locale/gu/LC_MESSAGES/sound-juicer.mo
-share/locale/he/LC_MESSAGES/sound-juicer.mo
share/locale/hi/LC_MESSAGES/sound-juicer.mo
share/locale/hr/LC_MESSAGES/sound-juicer.mo
share/locale/hu/LC_MESSAGES/sound-juicer.mo
share/locale/id/LC_MESSAGES/sound-juicer.mo
share/locale/it/LC_MESSAGES/sound-juicer.mo
share/locale/ja/LC_MESSAGES/sound-juicer.mo
+share/locale/ka/LC_MESSAGES/sound-juicer.mo
share/locale/ko/LC_MESSAGES/sound-juicer.mo
share/locale/lt/LC_MESSAGES/sound-juicer.mo
share/locale/mk/LC_MESSAGES/sound-juicer.mo
@@ -77,13 +86,21 @@ share/locale/th/LC_MESSAGES/sound-juicer.mo
share/locale/tr/LC_MESSAGES/sound-juicer.mo
share/locale/ug/LC_MESSAGES/sound-juicer.mo
share/locale/uk/LC_MESSAGES/sound-juicer.mo
+share/locale/vi/LC_MESSAGES/sound-juicer.mo
share/locale/xh/LC_MESSAGES/sound-juicer.mo
share/locale/zh_CN/LC_MESSAGES/sound-juicer.mo
+share/locale/zh_HK/LC_MESSAGES/sound-juicer.mo
share/locale/zh_TW/LC_MESSAGES/sound-juicer.mo
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
@dirrm share/gnome/sound-juicer
@dirrm share/gnome/omf/sound-juicer
@dirrm share/gnome/help/sound-juicer/uk/figures
@dirrm share/gnome/help/sound-juicer/uk
+@dirrm share/gnome/help/sound-juicer/nl/figures
+@dirrm share/gnome/help/sound-juicer/nl
@dirrm share/gnome/help/sound-juicer/es/figures
@dirrm share/gnome/help/sound-juicer/es
@dirrm share/gnome/help/sound-juicer/C/figures