aboutsummaryrefslogtreecommitdiff
path: root/audio/soundtouch
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-07-05 13:18:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-07-05 13:18:08 +0000
commitedf266c9b89f42766d45ed8a7de01b04b18de70d (patch)
tree216820e6bb6884e7af7cab57b5d1bbfb900109cc /audio/soundtouch
parent129c32572a097341d3845d6a375be4b91ce1e0a6 (diff)
downloadports-edf266c9b89f42766d45ed8a7de01b04b18de70d.tar.gz
ports-edf266c9b89f42766d45ed8a7de01b04b18de70d.zip
- Update to version 1.6.0 now that our autotools allow to bootstrap the build
- Reduce amount of local patching, cleanup Makefile, drop maintainership
Notes
Notes: svn path=/head/; revision=300519
Diffstat (limited to 'audio/soundtouch')
-rw-r--r--audio/soundtouch/Makefile36
-rw-r--r--audio/soundtouch/distinfo4
-rw-r--r--audio/soundtouch/files/patch-cpu_detect_x86_gcc.cpp95
-rw-r--r--audio/soundtouch/pkg-plist2
4 files changed, 21 insertions, 116 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index 33c7bb9782d0..521bc3abd6ee 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -6,33 +6,33 @@
#
PORTNAME= soundtouch
-DISTVERSION= 1.4.0
+DISTVERSION= 1.6.0
CATEGORIES= audio
MASTER_SITES= http://www.surina.net/soundtouch/
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source audio processing library
LICENSE= LGPL21
-WRKSRC= ${WRKDIR}/${PORTNAME}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared=yes
+USE_AUTOTOOLS= autoconf automake libtool
USE_LDCONFIG= yes
+CONFIGURE_ARGS= --enable-shared=yes
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
+ pkgdoc_DATA="${PORTDOCS}" pkgdocdir="${DOCSDIR}"
+.if !defined(NOPORTDOCS)
PORTDOCS= README.html
-
-post-patch: .SILENT
-# Adjust some paths for FreeBSD, respect CFLAGS, and get rid of GPL
- ${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E \
- 's|\(libdir\)/pkgconfig|(prefix)/libdata/pkgconfig|g; \
- s| -O3( -[mf][[:graph:]]*)*||; \
- s|\(prefix\)/doc|(datadir)/doc|; s|COPYING\.TXT||'
-# Fix SSE detection
- ${REINPLACE_CMD} -e 's|__x86_64__|&) \&\& defined(__SSE__|' \
- ${WRKSRC}/include/STTypes.h
-.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e 's|[[:blank:]]install-pkgdocDATA$$||' \
- ${WRKSRC}/Makefile.in
.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -E 's|-O3 ?||' \
+ ${WRKSRC}/source/SoundStretch/Makefile.am \
+ ${WRKSRC}/source/SoundTouch/Makefile.am
+
+run-autotools: # see ${WRKSRC}/soundtouch/bootstrap for reference
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} \
+ AUTOMAKE="${AUTOMAKE} --add-missing --foreign --copy" \
+ ${AUTORECONF} -fisv)
.include <bsd.port.mk>
diff --git a/audio/soundtouch/distinfo b/audio/soundtouch/distinfo
index 872c7b32769b..fd00126a215c 100644
--- a/audio/soundtouch/distinfo
+++ b/audio/soundtouch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (soundtouch-1.4.0.tar.gz) = d7f40b1acf24789b3d24316e368859df2784135c29d244181020f94d803a11fb
-SIZE (soundtouch-1.4.0.tar.gz) = 413183
+SHA256 (soundtouch-1.6.0.tar.gz) = 8776edaf7299ffe1e8c97285f020365a63c0e01aa4f6f7c5fd1d011c0ded278f
+SIZE (soundtouch-1.6.0.tar.gz) = 94852
diff --git a/audio/soundtouch/files/patch-cpu_detect_x86_gcc.cpp b/audio/soundtouch/files/patch-cpu_detect_x86_gcc.cpp
deleted file mode 100644
index fe1aba6b2b5b..000000000000
--- a/audio/soundtouch/files/patch-cpu_detect_x86_gcc.cpp
+++ /dev/null
@@ -1,95 +0,0 @@
---- ./source/SoundTouch/cpu_detect_x86_gcc.cpp.orig 2009-01-25 18:32:53.000000000 +0200
-+++ ./source/SoundTouch/cpu_detect_x86_gcc.cpp 2011-05-13 23:03:42.000000000 +0300
-@@ -79,6 +79,11 @@
-
- #else
- uint res = 0;
-+#ifdef __x86_64__
-+ int64_t edx, eax, ecx;
-+#else
-+ int edx, eax, ecx;
-+#endif
-
- if (_dwDisabledISA == 0xffffffff) return 0;
-
-@@ -86,42 +91,55 @@
- "\n\txor %%esi, %%esi" // clear %%esi = result register
- // check if 'cpuid' instructions is available by toggling eflags bit 21
-
-+#ifdef __x86_64__
-+
- "\n\tpushf" // save eflags to stack
-- "\n\tpop %%eax" // load eax from stack (with eflags)
-- "\n\tmovl %%eax, %%ecx" // save the original eflags values to ecx
-- "\n\txor $0x00200000, %%eax" // toggle bit 21
-- "\n\tpush %%eax" // store toggled eflags to stack
-+ "\n\tpop %2" // load eax from stack (with eflags)
-+ "\n\tmov %2, %3" // save the original eflags values to ecx
-+ "\n\txor $0x00200000, %2" // toggle bit 21
-+ "\n\tpush %2" // store toggled eflags to stack
- "\n\tpopf" // load eflags from stack
- "\n\tpushf" // save updated eflags to stack
-- "\n\tpop %%eax" // load from stack
-- "\n\txor %%edx, %%edx" // clear edx for defaulting no mmx
-- "\n\tcmp %%ecx, %%eax" // compare to original eflags values
-+ "\n\tpop %2" // load from stack
-+#else
-+
-+ "\n\tpushf" // save eflags to stack
-+ "\n\tpopl %2" // load eax from stack (with eflags)
-+ "\n\tmovl %2, %3" // save the original eflags values to ecx
-+ "\n\txor $0x00200000, %2" // toggle bit 21
-+ "\n\tpush %2" // store toggled eflags to stack
-+ "\n\tpopf" // load eflags from stack
-+ "\n\tpushf" // save updated eflags to stack
-+ "\n\tpopl %2" // load from stack
-+#endif
-+ "\n\txor %1, %1" // clear edx for defaulting no mmx
-+ "\n\tcmp %3, %2" // compare to original eflags values
- "\n\tjz end" // jumps to 'end' if cpuid not present
-
- // cpuid instruction available, test for presence of mmx instructions
-
-- "\n\tmovl $1, %%eax"
-+ "\n\tmov $1, %2"
- "\n\tcpuid"
--// movl $0x00800000, %edx // force enable MMX
-- "\n\ttest $0x00800000, %%edx"
-+// movl $0x00800000, %1 // force enable MMX
-+ "\n\ttest $0x00800000, %1"
- "\n\tjz end" // branch if MMX not available
-
- "\n\tor $0x01, %%esi" // otherwise add MMX support bit
-
-- "\n\ttest $0x02000000, %%edx"
-+ "\n\ttest $0x02000000, %1"
- "\n\tjz test3DNow" // branch if SSE not available
-
- "\n\tor $0x08, %%esi" // otherwise add SSE support bit
-
- "\n\ttest3DNow:"
- // test for precense of AMD extensions
-- "\n\tmov $0x80000000, %%eax"
-+ "\n\tmov $0x80000000, %2"
- "\n\tcpuid"
- "\n\tcmp $0x80000000, %%eax"
- "\n\tjbe end" // branch if no AMD extensions detected
-
- // test for precense of 3DNow! extension
-- "\n\tmov $0x80000001, %%eax"
-+ "\n\tmov $0x80000001, %2"
- "\n\tcpuid"
- "\n\ttest $0x80000000, %%edx"
- "\n\tjz end" // branch if 3DNow! not detected
-@@ -132,9 +150,9 @@
-
- "\n\tmov %%esi, %0"
-
-- : "=r" (res)
-+ : "=r" (res), "=d" (edx), "=a" (eax), "=c" (ecx)
- : /* no inputs */
-- : "%edx", "%eax", "%ecx", "%esi" );
-+ : "%esi");
-
- return res & ~_dwDisabledISA;
- #endif
diff --git a/audio/soundtouch/pkg-plist b/audio/soundtouch/pkg-plist
index 605b3ecc8f81..d2228cef6890 100644
--- a/audio/soundtouch/pkg-plist
+++ b/audio/soundtouch/pkg-plist
@@ -11,4 +11,4 @@ lib/libSoundTouch.la
lib/libSoundTouch.so.0
lib/libSoundTouch.so
share/aclocal/soundtouch.m4
-libdata/pkgconfig/soundtouch-1.4.pc
+libdata/pkgconfig/soundtouch.pc