aboutsummaryrefslogtreecommitdiff
path: root/audio/soundtracker
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
commit7b4c77811e89d7fc1131ca6e63df3e719bc86b1d (patch)
tree9695733a1620c4c290c86f161a4f1b73160ed39a /audio/soundtracker
parentc76cf46929051f9dd322487d888c82f104026e6d (diff)
downloadports-7b4c77811e89d7fc1131ca6e63df3e719bc86b1d.tar.gz
ports-7b4c77811e89d7fc1131ca6e63df3e719bc86b1d.zip
Notes
Diffstat (limited to 'audio/soundtracker')
-rw-r--r--audio/soundtracker/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index c12fbb353e23..a69ce5774f00 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -12,32 +12,28 @@ MASTER_SITES= ftp://ftp.soundtracker.org/pub/soundtracker/v0.5/
MAINTAINER= kzentner@u.washington.edu
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-.if defined(USE_GNOME)
-LIB_DEPENDS+= gnome.4:${PORTSDIR}/x11/gnomelibs
-.endif
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-GNU_CONFIGURE= YES
-
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
-
USE_X_PREFIX= yes
-
-.if defined(USE_GNOME)
-CONFIGURE_ARGS+= --enable-gnome
-PLIST_SUB+= GNOME:=""
-PLIST= ${PKGDIR}/PLIST.gnome
+USE_GTK= yes
+USE_ESOUND= yes
+WANT_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+=--enable-gnome
.else
-CONFIGURE_ARGS+= --disable-gnome
-PLIST_SUB+= GNOME:="@comment "
+CONFIGURE_ARGS+=--disable-gnome
.endif
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-post-install:
- @strip ${PREFIX}/bin/soundtracker
+pre-patch:
+ @${PERL} -pi -e 's^-l(pthread|c_r)^-pthread^g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>