aboutsummaryrefslogtreecommitdiff
path: root/audio/speex
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-05-08 03:59:05 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-05-08 03:59:05 +0000
commit2b3295fca6fe0fb4f741c4c4eec929af410ec283 (patch)
tree9737071e6f392097d3d95b7b958e74f19726b7c5 /audio/speex
parentfca5599500b31845d4fb6c3f0e504435ce1f282f (diff)
downloadports-2b3295fca6fe0fb4f741c4c4eec929af410ec283.tar.gz
ports-2b3295fca6fe0fb4f741c4c4eec929af410ec283.zip
- Update to 1.0.5
- Use libtool15 now instead of libtool13 - Speex bumped lib version but there is no need so I put it back at .3
Notes
Notes: svn path=/head/; revision=134826
Diffstat (limited to 'audio/speex')
-rw-r--r--audio/speex/Makefile16
-rw-r--r--audio/speex/distinfo4
-rw-r--r--audio/speex/files/patch-configure10
3 files changed, 10 insertions, 20 deletions
diff --git a/audio/speex/Makefile b/audio/speex/Makefile
index 098dba1bca08..84949cb73ae3 100644
--- a/audio/speex/Makefile
+++ b/audio/speex/Makefile
@@ -7,11 +7,10 @@
#
PORTNAME= speex
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.5
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= http://www.speex.org/download/
+MASTER_SITES= http://downloads.xiph.org/releases/speex/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= ahze@FreeBSD.org
@@ -22,11 +21,10 @@ LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
CONFLICTS= speex-devel-*
USE_GNOME= gnomehack
-USE_GETOPT_LONG= yes
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL_VER=15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
@@ -42,6 +40,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|@SPEEX_VERSION@|${PORTVERSION}|' \
${WRKSRC}/speex.pc.in
@${REINPLACE_CMD} -e 's| in -lgnugetopt||g ; \
- s|LIBS="-lgnugetopt|LIBS="|g' ${WRKSRC}/configure
+ s|LIBS="-lgnugetopt|LIBS="|g; \
+ s|SPEEX_LT_CURRENT=4|SPEEX_LT_CURRENT=3|' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/audio/speex/distinfo b/audio/speex/distinfo
index 38eb24350374..135ccbad979e 100644
--- a/audio/speex/distinfo
+++ b/audio/speex/distinfo
@@ -1,2 +1,2 @@
-MD5 (speex-1.0.4.tar.gz) = 15a0686b7e1f81d352a648044b350fcc
-SIZE (speex-1.0.4.tar.gz) = 546214
+MD5 (speex-1.0.5.tar.gz) = 01d6a2de0a88a861304bf517615dea79
+SIZE (speex-1.0.5.tar.gz) = 546872
diff --git a/audio/speex/files/patch-configure b/audio/speex/files/patch-configure
deleted file mode 100644
index 868364574624..000000000000
--- a/audio/speex/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Jul 29 11:40:32 2002
-+++ configure Wed Jul 31 03:49:39 2002
-@@ -5287,6 +5287,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'