aboutsummaryrefslogtreecommitdiff
path: root/audio/speex
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-01-09 14:37:52 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-01-09 14:37:52 +0000
commit9281940ef388cbf9e0f56132ff20679b5b907ae5 (patch)
tree38ffd16903da142444f13367d8695fa8fc80ddd2 /audio/speex
parent26b0043fe8a613678bd54831272645b362245b6a (diff)
downloadports-9281940ef388cbf9e0f56132ff20679b5b907ae5.tar.gz
ports-9281940ef388cbf9e0f56132ff20679b5b907ae5.zip
Notes
Diffstat (limited to 'audio/speex')
-rw-r--r--audio/speex/Makefile34
-rw-r--r--audio/speex/distinfo4
-rw-r--r--audio/speex/files/patch-speex.pc.in8
-rw-r--r--audio/speex/pkg-descr11
-rw-r--r--audio/speex/pkg-plist13
5 files changed, 12 insertions, 58 deletions
diff --git a/audio/speex/Makefile b/audio/speex/Makefile
index 603a27e9b5dd..4bedc60ce04e 100644
--- a/audio/speex/Makefile
+++ b/audio/speex/Makefile
@@ -2,40 +2,20 @@
# $FreeBSD$
PORTNAME= speex
-DISTVERSION= 1.2rc1
-PORTREVISION= 7
+DISTVERSION= 1.2rc2
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://downloads.us.xiph.org/releases/speex/
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= Open-source patent-free voice codec
+COMMENT= Audio compression format designed for speech
-LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
+ libspeexdsp.so:${PORTSDIR}/audio/speexdsp
-USES= libtool:keepla pathfix
-USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ogg-dir=${LOCALBASE}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+USES= libtool pathfix
+USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
-.if defined(MACHINE_CPU) && ${MACHINE_CPU:Msse}!=""
-CONFIGURE_ARGS+= --enable-sse
-.endif
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|doc win32|win32|g ; \
- s|^mandir =.*$$|mandir = @mandir@|g'
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
- ${WRKSRC}/*/*.h
- @${REINPLACE_CMD} -e 's| in -lgnugetopt||g ; \
- s|LIBS="-lgnugetopt|LIBS="|g' ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/speex/distinfo b/audio/speex/distinfo
index dc4e137c3b64..51edd20bde40 100644
--- a/audio/speex/distinfo
+++ b/audio/speex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (speex-1.2rc1.tar.gz) = 342f30dc57bd4a6dad41398365baaa690429660b10d866b7d508e8f1179cb7a6
-SIZE (speex-1.2rc1.tar.gz) = 1061882
+SHA256 (speex-1.2rc2.tar.gz) = caa27c7247ff15c8521c2ae0ea21987c9e9710a8f2d3448e8b79da9806bce891
+SIZE (speex-1.2rc2.tar.gz) = 1016729
diff --git a/audio/speex/files/patch-speex.pc.in b/audio/speex/files/patch-speex.pc.in
deleted file mode 100644
index 09ce828d48da..000000000000
--- a/audio/speex/files/patch-speex.pc.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./speex.pc.in.orig 2008-05-30 11:34:16.000000000 +0400
-+++ ./speex.pc.in 2008-07-30 00:21:52.000000000 +0400
-@@ -12,4 +12,4 @@
- Conflicts:
- Libs: -L${libdir} -lspeex
- Libs.private: -lm
--Cflags: -I${includedir}
-+Cflags: -I${includedir} -I${includedir}/speex
diff --git a/audio/speex/pkg-descr b/audio/speex/pkg-descr
index 604889a78c91..d052788ddbc7 100644
--- a/audio/speex/pkg-descr
+++ b/audio/speex/pkg-descr
@@ -1,11 +1,4 @@
-The Speex is a patent-free, Open Source/Free Software voice codec.
-Unlike other codecs like MP3 and Ogg Vorbis, Speex is designed to
-compress voice at bitrates in the 2-45 kbps range. Possible
-applications include VoIP, Internet audio streaming, archiving of
-speech data (e.g. voice mail), and audio books. In some sense, it is
-meant to be complementary to the Ogg Vorbis codec.
-
-This ports is for the development version of speex, but the file format
-is compatible with the base (1.0 and 1.1) versions.
+Speex is an Open Source/Free Software patent-free audio compression
+format designed for speech.
WWW: http://www.speex.org/
diff --git a/audio/speex/pkg-plist b/audio/speex/pkg-plist
index a4e44fb621df..ecfdbf41fc1f 100644
--- a/audio/speex/pkg-plist
+++ b/audio/speex/pkg-plist
@@ -2,28 +2,17 @@ bin/speexdec
bin/speexenc
include/speex/speex.h
include/speex/speex_bits.h
-include/speex/speex_buffer.h
include/speex/speex_callbacks.h
include/speex/speex_config_types.h
-include/speex/speex_echo.h
include/speex/speex_header.h
-include/speex/speex_jitter.h
-include/speex/speex_preprocess.h
-include/speex/speex_resampler.h
include/speex/speex_stereo.h
include/speex/speex_types.h
lib/libspeex.a
-lib/libspeex.la
lib/libspeex.so
lib/libspeex.so.1
lib/libspeex.so.1.5.0
-lib/libspeexdsp.a
-lib/libspeexdsp.la
-lib/libspeexdsp.so
-lib/libspeexdsp.so.1
-lib/libspeexdsp.so.1.5.0
libdata/pkgconfig/speex.pc
-libdata/pkgconfig/speexdsp.pc
man/man1/speexdec.1.gz
man/man1/speexenc.1.gz
share/aclocal/speex.m4
+@comment %%PORTDOCS%%%%DOCSDIR%%/manual.pdf