aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynth
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-04 17:45:28 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-04 17:45:28 +0000
commit937c9dc60c5a31400104b83968e3ee2eb3dc47fc (patch)
treee823e6201e818a84988b38f251932a3d52dd8574 /audio/spiralsynth
parent243361c57ab4244347257b1ca1b81c988c5c6464 (diff)
downloadports-937c9dc60c5a31400104b83968e3ee2eb3dc47fc.tar.gz
ports-937c9dc60c5a31400104b83968e3ee2eb3dc47fc.zip
Respect CC, CFLAGS, CXX, CXXFLAGS. Don't hard-code g++ as the
linker either. Chase soundcard.h header. Mark broken at kris' request.
Notes
Notes: svn path=/head/; revision=93091
Diffstat (limited to 'audio/spiralsynth')
-rw-r--r--audio/spiralsynth/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index afc5f52629e9..ea1d1dfac64e 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -26,14 +26,26 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
DOC_FILES= CHANGES COPYING README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500112
+BROKEN= "errors in linking"
+USE_GCC= 2.95
+.endif
+
post-patch:
-.for ii in Makefile.in PluginLink.sh
+.for ii in Makefile.in PluginLink.sh SpiralSound/Output.h
${MV} ${WRKSRC}/${ii} ${WRKSRC}/${ii}.orig
${SED} -e 's|-O3|${PTHREAD_CFLAGS}|g ; \
+ s|CC =|CC? =|g ; \
s|CFLAGS =|CFLAGS +=|g ; \
+ s|CXX =|CXX? =|g ; \
s|CXXFLAGS=|CXXFLAGS+=|g ; \
+ s|LINK = g++|LINK = ${CXX}|g ; \
s|-lm|${PTHREAD_LIBS} -lm|g ; \
- s|/usr/X11R6|${X11BASE}|g' < ${WRKSRC}/${ii}.orig \
+ s|/usr/X11R6|${X11BASE}|g ; \
+ s|machine/soundcard|sys/soundcard|g' \
+ < ${WRKSRC}/${ii}.orig \
> ${WRKSRC}/${ii}
.endfor
# Use as a plugin to SpiralLoops 2.0.0 results in "Can't open audio driver."
@@ -73,4 +85,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>