aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynth
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-10-04 14:58:59 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-10-04 14:58:59 +0000
commit9603a7860cf9c30b9892f8fd5ec7259b55e79350 (patch)
tree12a7d02bb7f16c89f2245e6127873974331de7a5 /audio/spiralsynth
parent337990e0b30d11ddeb13c89beb02390c7dd2f95f (diff)
downloadports-9603a7860cf9c30b9892f8fd5ec7259b55e79350.tar.gz
ports-9603a7860cf9c30b9892f8fd5ec7259b55e79350.zip
Avoid Perl.
PR: 47651 Submitted by: Simon Schubert of ath.cx
Notes
Notes: svn path=/head/; revision=90251
Diffstat (limited to 'audio/spiralsynth')
-rw-r--r--audio/spiralsynth/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 3a8638e6e3c7..235edcd50d01 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -33,16 +33,19 @@ BROKEN= "Does not compile (bad C++ code)"
.endif
post-patch:
- ${PERL} -pi -e 's|-O3|${PTHREAD_CFLAGS}|g ; \
+.for ii in Makefile.in PluginLink.sh
+ ${MV} ${WRKSRC}/${ii} ${WRKSRC}/${ii}.orig
+ ${SED} -e 's|-O3|${PTHREAD_CFLAGS}|g ; \
s|CFLAGS =|CFLAGS +=|g ; \
s|CXXFLAGS=|CXXFLAGS+=|g ; \
s|-lm|${PTHREAD_LIBS} -lm|g ; \
- s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/PluginLink.sh
+ s|/usr/X11R6|${X11BASE}|g' < ${ii}.orig > ${ii}
+.endfor
# Use as a plugin to SpiralLoops 2.0.0 results in "Can't open audio driver."
.if defined(PLUGIN)
- ${PERL} -pi -e 's|^//#define PLUGIN|#define PLUGIN|g' \
- ${WRKSRC}/Synth.C
+ ${MV} ${WRKSRC}/Synth.C ${WRKSRC}/Synth.C.orig
+ ${SED} -e 's|^//#define PLUGIN|#define PLUGIN|g' \
+ < ${WRKSRC}/Synth.C.orig > ${WRKSRC}/Synth.C
post-build:
cd ${WRKSRC}; ${SH} ./PluginLink.sh