aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynth
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-11-15 13:26:36 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-11-15 13:26:36 +0000
commit9c4b64a964b995cf74774308b95d8a29e453368d (patch)
tree1d1e50b8fecd5d673f5a8501c62c614956fd16a3 /audio/spiralsynth
parentb53f78eb1a9131b9c05b482bc9f76d07c9a7dd65 (diff)
downloadports-9c4b64a964b995cf74774308b95d8a29e453368d.tar.gz
ports-9c4b64a964b995cf74774308b95d8a29e453368d.zip
- Unbreak - fix build with latest x11-toolkits/fltk
- Fix a runtime segfault due to an uninitialized pointer Feature safe: yes
Notes
Notes: svn path=/head/; revision=285849
Diffstat (limited to 'audio/spiralsynth')
-rw-r--r--audio/spiralsynth/Makefile2
-rw-r--r--audio/spiralsynth/files/patch-GUI_OutputGUI.C17
-rw-r--r--audio/spiralsynth/files/patch-SpiralSound_Oscillator.C14
3 files changed, 26 insertions, 7 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 445786de7525..24acb8166722 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -17,8 +17,6 @@ COMMENT= MIDI-capable synthesizer for X
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-BROKEN= does not compile
-
GNU_CONFIGURE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
diff --git a/audio/spiralsynth/files/patch-GUI_OutputGUI.C b/audio/spiralsynth/files/patch-GUI_OutputGUI.C
index 18a74a00b1fe..ec7bdb63623e 100644
--- a/audio/spiralsynth/files/patch-GUI_OutputGUI.C
+++ b/audio/spiralsynth/files/patch-GUI_OutputGUI.C
@@ -1,8 +1,15 @@
-$FreeBSD$
-
---- GUI/OutputGUI.C.orig Sun Nov 26 15:52:39 2000
-+++ GUI/OutputGUI.C Mon Feb 9 12:10:10 2004
-@@ -26,8 +26,10 @@ OutputGUI::OutputGUI(Output *o)
+--- GUI/OutputGUI.C.orig 2000-11-26 16:52:39.000000000 +0100
++++ GUI/OutputGUI.C 2011-11-15 14:11:31.000000000 +0100
+@@ -18,7 +18,7 @@
+
+ #include "OutputGUI.h"
+
+-#include <FL/fl_file_chooser.h>
++#include <FL/Fl_File_Chooser.H>
+
+ OutputGUI::OutputGUI(Output *o)
+ {
+@@ -26,8 +26,10 @@
if (!m_out) cerr<<"WARNING: Output not correctly set up"<<endl;
}
diff --git a/audio/spiralsynth/files/patch-SpiralSound_Oscillator.C b/audio/spiralsynth/files/patch-SpiralSound_Oscillator.C
new file mode 100644
index 000000000000..62b5ebef4fab
--- /dev/null
+++ b/audio/spiralsynth/files/patch-SpiralSound_Oscillator.C
@@ -0,0 +1,14 @@
+--- SpiralSound/Oscillator.C.orig 2011-11-15 14:22:27.000000000 +0100
++++ SpiralSound/Oscillator.C 2011-11-15 14:22:21.000000000 +0100
+@@ -30,7 +30,10 @@
+ m_PulseWidth(0.5f),
+ m_PortmentoSpeed(1),
+ m_DesiredFreq(0),
+-m_ModAmount(0.01f)
++m_ModAmount(0.01f),
++m_FreqModBuf(0),
++m_PulseWidthModBuf(0),
++m_SHModBuf(0)
+ {
+ m_CyclePos=new int[SpiralInfo::POLY];
+ m_InOctave=new int[SpiralInfo::POLY];