aboutsummaryrefslogtreecommitdiff
path: root/audio/splay
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-05-16 07:39:29 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-05-16 07:39:29 +0000
commit5ae9afcef5f459dcc0b064b60d0304a9fba55f43 (patch)
tree21d8f3d59caa3b9ceddf23603a7224ee966ec802 /audio/splay
parent1b8fb360665d82645d741cf2bbb78399b4ea5a53 (diff)
downloadports-5ae9afcef5f459dcc0b064b60d0304a9fba55f43.tar.gz
ports-5ae9afcef5f459dcc0b064b60d0304a9fba55f43.zip
Upgrade, 0.2 -> 0.3.
PR: 3321 Submitted by: Choi Jun Ho <junker@moderato.snu.ac.kr>
Notes
Notes: svn path=/head/; revision=6460
Diffstat (limited to 'audio/splay')
-rw-r--r--audio/splay/Makefile20
-rw-r--r--audio/splay/distinfo2
-rw-r--r--audio/splay/files/patch-aa243
-rw-r--r--audio/splay/pkg-comment2
-rw-r--r--audio/splay/pkg-descr24
-rw-r--r--audio/splay/pkg-plist1
6 files changed, 22 insertions, 270 deletions
diff --git a/audio/splay/Makefile b/audio/splay/Makefile
index 6e55cc5310e1..92dd657fe73d 100644
--- a/audio/splay/Makefile
+++ b/audio/splay/Makefile
@@ -1,20 +1,18 @@
# New ports collection makefile for: splay
-# Version required: 0.2
-# Date created: Mar 20 1997
+# Version required: 0.3
+# Date created: 1 Apr 1997
# Whom: junker@jazz.snu.ac.kr
#
-# $Id: Makefile,v 1.1.1.1 1997/03/26 02:10:32 jfitz Exp $
+# $Id$
#
-DISTNAME= splay-0.2
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR = apps/sound
+DISTNAME= splay-0.3
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/players/
-MAINTAINER= junker@jazz.snu.ac.kr
+MAINTAINER= junker@jazz.snu.ac.kr
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/splay ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/randomplay.sh ${PREFIX}/bin
+GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/audio/splay/distinfo b/audio/splay/distinfo
index e24be81fb9ac..99cd5dba6a94 100644
--- a/audio/splay/distinfo
+++ b/audio/splay/distinfo
@@ -1 +1 @@
-MD5 (splay-0.2.tar.gz) = 0fe98624ee1882f5173b8a59b62c7ea3
+MD5 (splay-0.3.tar.gz) = db2a43b005fe729cc739e22453a85091
diff --git a/audio/splay/files/patch-aa b/audio/splay/files/patch-aa
index 9a1244a523fa..253006d4b401 100644
--- a/audio/splay/files/patch-aa
+++ b/audio/splay/files/patch-aa
@@ -1,181 +1,5 @@
-diff -c -r ../splay-0.2-orig/Makefile ./Makefile
-*** ../splay-0.2-orig/Makefile Sat Mar 15 00:00:00 1997
---- ./Makefile Wed Mar 19 19:19:58 1997
-***************
-*** 1,4 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
-
---- 1,4 ----
-! CC = cc
- #CC = pgcc
- AR = ar
-
-***************
-*** 7,14 ****
- WFLAGS = -Wstrict-prototypes -Wall
- OFLAGS = -O2 -m486
- #OFLAGS = -O6 -mpentium
-! TFLAGS = -D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = -lpthread
- CFLAGS = $(OFLAGS) $(WFLAGS) $(IFLAGS) $(DEBUG) $(TFLAGS)
- OBJECTS = splay.o
- LIBRARY = -lm $(TLIBFLAGS) \
---- 7,14 ----
- WFLAGS = -Wstrict-prototypes -Wall
- OFLAGS = -O2 -m486
- #OFLAGS = -O6 -mpentium
-! TFLAGS = #-D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = #-lpthread
- CFLAGS = $(OFLAGS) $(WFLAGS) $(IFLAGS) $(DEBUG) $(TFLAGS)
- OBJECTS = splay.o
- LIBRARY = -lm $(TLIBFLAGS) \
-diff -c -r ../splay-0.2-orig/bbitstream/Makefile ./bbitstream/Makefile
-*** ../splay-0.2-orig/bbitstream/Makefile Sat Mar 15 00:00:00 1997
---- ./bbitstream/Makefile Wed Mar 19 19:17:17 1997
-***************
-*** 1,7 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-
- OBJLIB = bbitstream.a
- OBJECTS = input.o output.o
---- 1,8 ----
-! CC = cc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-+ RANLIB = ranlib
-
- OBJLIB = bbitstream.a
- OBJECTS = input.o output.o
-***************
-*** 21,27 ****
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rcs $(OBJLIB) $(OBJECTS)
-
- .cc.o :
- $(CC) -c $(CFLAGS) -o $*.o $<
---- 22,29 ----
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rc $(OBJLIB) $(OBJECTS)
-! $(RANLIB) $(OBJLIB)
-
- .cc.o :
- $(CC) -c $(CFLAGS) -o $*.o $<
-diff -c -r ../splay-0.2-orig/sound/Makefile ./sound/Makefile
-*** ../splay-0.2-orig/sound/Makefile Sat Mar 15 00:00:00 1997
---- ./sound/Makefile Wed Mar 19 19:18:57 1997
-***************
-*** 1,7 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-
- OBJLIB = mpegsound.a
- OBJECTS = rawplayer.o wavetoraw.o \
---- 1,8 ----
-! CC = cc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-+ RANLIB = ranlib
-
- OBJLIB = mpegsound.a
- OBJECTS = rawplayer.o wavetoraw.o \
-***************
-*** 15,29 ****
- DEBUG = -g
- IFLAGS = -I../bbitstream/
- AFLAGS = -malign-loops=2 -malign-jumps=2 -malign-functions=2
-! TFLAGS = -D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = -lpthread
- OFLAGS = -O3 -fomit-frame-pointer -fno-strength-reduce -m486 $(AFLAG)
- #OFLAGS = -O6 -mpentium
- WFLAGS = -Wstrict-prototypes -Wall
- CFLAGS = $(DEBUG) $(IFLAGS) $(OFLAGS) $(WFLAGS) $(TFLAGS)
- LIBS = $(OBJLIB) -lm $(TLIBFLAGS) ../bbitstream/bbitstream.a
-
-! all: $(OBJLIB) test
-
- clean:
- $(RM) *.a test *.o *~
---- 16,30 ----
- DEBUG = -g
- IFLAGS = -I../bbitstream/
- AFLAGS = -malign-loops=2 -malign-jumps=2 -malign-functions=2
-! TFLAGS = #-D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = #-lpthread
- OFLAGS = -O3 -fomit-frame-pointer -fno-strength-reduce -m486 $(AFLAG)
- #OFLAGS = -O6 -mpentium
- WFLAGS = -Wstrict-prototypes -Wall
- CFLAGS = $(DEBUG) $(IFLAGS) $(OFLAGS) $(WFLAGS) $(TFLAGS)
- LIBS = $(OBJLIB) -lm $(TLIBFLAGS) ../bbitstream/bbitstream.a
-
-! all: $(OBJLIB) #test
-
- clean:
- $(RM) *.a test *.o *~
-***************
-*** 36,42 ****
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rcs $(OBJLIB) $(OBJECTS)
-
- .cc.o:
- $(CC) -c $(CFLAGS) -o $*.o $<
---- 37,44 ----
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rc $(OBJLIB) $(OBJECTS)
-! $(RANLIB) $(OBJLIB)
-
- .cc.o:
- $(CC) -c $(CFLAGS) -o $*.o $<
-***************
-*** 54,57 ****
-
- bitwindow.o : mpegsound.h bitwindow.cc
- huffman.o : mpegsound.h huffman.cc
-! huffmantable.o : mpegsound.h huffmantable.cc
---- 56,59 ----
-
- bitwindow.o : mpegsound.h bitwindow.cc
- huffman.o : mpegsound.h huffman.cc
-! huffmantable.o : mpegsound.h huffmantable.cc
-diff -c -r ../splay-0.2-orig/sound/mpegsound.h ./sound/mpegsound.h
-*** ../splay-0.2-orig/sound/mpegsound.h Sat Mar 15 00:00:00 1997
---- ./sound/mpegsound.h Wed Mar 19 20:02:22 1997
-***************
-*** 11,17 ****
- /* Inlcude default library packages */
- /************************************/
- #include <stdio.h>
-! #include <malloc.h>
- #include <unistd.h>
-
- #ifdef PTHREADEDMPEG
---- 11,17 ----
- /* Inlcude default library packages */
- /************************************/
- #include <stdio.h>
-! #include <stdlib.h>
- #include <unistd.h>
-
- #ifdef PTHREADEDMPEG
-diff -c -r ../splay-0.2-orig/sound/rawplayer.cc ./sound/rawplayer.cc
-*** ../splay-0.2-orig/sound/rawplayer.cc Sat Mar 15 00:00:00 1997
---- ./sound/rawplayer.cc Wed Mar 19 19:16:56 1997
+*** mpegsound/rawplayer.cc Thu Mar 27 22:18:47 1997
+--- mpegsound/rawplayer.cc Tue Apr 1 19:33:46 1997
***************
*** 8,14 ****
@@ -193,66 +17,3 @@ diff -c -r ../splay-0.2-orig/sound/rawplayer.cc ./sound/rawplayer.cc
#include "mpegsound.h"
-diff -c -r ../splay-0.2-orig/sound/test.cc ./sound/test.cc
-*** ../splay-0.2-orig/sound/test.cc Sat Mar 15 00:00:00 1997
---- ./sound/test.cc Wed Mar 19 19:18:03 1997
-***************
-*** 2,8 ****
-
- #include <stdio.h>
- #include <string.h>
-! #include <getopt.h>
- #include <unistd.h>
-
- #include "mpegsound.h"
---- 2,8 ----
-
- #include <stdio.h>
- #include <string.h>
-! //#include <getopt.h>
- #include <unistd.h>
-
- #include "mpegsound.h"
-diff -c -r ../splay-0.2-orig/sound/wavetoraw.cc ./sound/wavetoraw.cc
-*** ../splay-0.2-orig/sound/wavetoraw.cc Sat Mar 15 00:00:00 1997
---- ./sound/wavetoraw.cc Wed Mar 19 20:02:48 1997
-***************
-*** 5,11 ****
- // Wavetoraw.cc
- // Server which strips wave header.
-
-! #include <malloc.h>
-
- #include "mpegsound.h"
-
---- 5,11 ----
- // Wavetoraw.cc
- // Server which strips wave header.
-
-! #include <stdlib.h>
-
- #include "mpegsound.h"
-
-diff -c -r ../splay-0.2-orig/splay.cc ./splay.cc
-*** ../splay-0.2-orig/splay.cc Sat Mar 15 00:00:00 1997
---- ./splay.cc Wed Mar 19 19:20:52 1997
-***************
-*** 42,47 ****
---- 42,48 ----
- return;
- }
-
-+ #ifdef PTHREADEDMPEG
- void playingthread(Mpegfileplayer *player)
- {
- if(player->geterrorcode()>0)error(player->geterrorcode());
-***************
-*** 52,57 ****
---- 53,59 ----
- if(player->geterrorcode()>0)error(player->geterrorcode());
- }
- }
-+ #endif
-
- void playing(Fileplayer *player)
- {
diff --git a/audio/splay/pkg-comment b/audio/splay/pkg-comment
index 9e382a133878..d757aaf70be7 100644
--- a/audio/splay/pkg-comment
+++ b/audio/splay/pkg-comment
@@ -1 +1 @@
-An audio player/decoder that decodes MPEG Layer I,II,II and WAV files.
+An audio player/decoder that decodes MPEG Layer I,II,III and WAV files.
diff --git a/audio/splay/pkg-descr b/audio/splay/pkg-descr
index 8d6cbbe91cef..614ef9bd7150 100644
--- a/audio/splay/pkg-descr
+++ b/audio/splay/pkg-descr
@@ -1,20 +1,14 @@
-The splay program uses the MPEG/Wave Sound library to play sound files in
+splay-0.3
+---------
+
+Splay program uses the MPEG/Wave Sound library to play sound files in
several formats, notably the MPEG audio and Wave format. This early version
-has only limited functionally and a simplistic user interface. For the moment,
-only Intel pc's running Linux are supported.
+has only limited functionally and a simplistic user interface.
This program have NO WARRANTY.
+You can use this program under GPL.
+You can use these libraries under Library GPL.
-Now, threaded playing and 'Force to mono' are implemented.
-And implemented poor shuffle play.
-
-Bug report
- jwj95@eve.kaist.ac.kr
- jwj95@nownuri.net
-
-THANKS FOR this document
- Tommy Thorn
-
+* This version of splay was not compiled with pthread library.
--
-From FreeBSD porter:
- * This version of splay was not compiled with pthread library.
+Port by Choi Jun Ho <junker@jazz.snu.ac.kr>
diff --git a/audio/splay/pkg-plist b/audio/splay/pkg-plist
index f4379cd6a3d4..df1c853561db 100644
--- a/audio/splay/pkg-plist
+++ b/audio/splay/pkg-plist
@@ -1,2 +1 @@
bin/splay
-bin/randomplay.sh