aboutsummaryrefslogtreecommitdiff
path: root/audio/splay
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-04-19 15:40:55 +0000
committerSteve Price <steve@FreeBSD.org>1998-04-19 15:40:55 +0000
commit8b3fb6d2ddac90812148266f44cf703f7808bcb7 (patch)
tree18769fd6915134abb6c341fe1f264755d3a656c5 /audio/splay
parent9455416a5486a9d51e48cb5c380d8448162b98d3 (diff)
downloadports-8b3fb6d2ddac90812148266f44cf703f7808bcb7.tar.gz
ports-8b3fb6d2ddac90812148266f44cf703f7808bcb7.zip
Upgrade to version 0.8.2.
PR: 6122 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=10585
Diffstat (limited to 'audio/splay')
-rw-r--r--audio/splay/Makefile13
-rw-r--r--audio/splay/distinfo2
-rw-r--r--audio/splay/files/patch-aa53
-rw-r--r--audio/splay/files/patch-ab24
-rw-r--r--audio/splay/pkg-comment2
-rw-r--r--audio/splay/pkg-descr6
-rw-r--r--audio/splay/pkg-plist1
7 files changed, 62 insertions, 39 deletions
diff --git a/audio/splay/Makefile b/audio/splay/Makefile
index 503af045bf7f..8a1b96900582 100644
--- a/audio/splay/Makefile
+++ b/audio/splay/Makefile
@@ -1,18 +1,21 @@
# New ports collection makefile for: splay
-# Version required: 0.3
+# Version required: 0.8.2
# Date created: 1 Apr 1997
# Whom: junker@jazz.snu.ac.kr
#
-# $Id: Makefile,v 1.4 1997/08/09 23:37:33 fenner Exp $
+# $Id: Makefile,v 1.5 1998/01/08 18:52:01 fenner Exp $
+#
+# pthread library can be used, but sound quality is buggy
#
-DISTNAME= splay-0.5
+DISTNAME= splay-0.8.2
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/sound/players
+MASTER_SITES= http://cain.kaist.ac.kr/~jwj95/
MAINTAINER= junker@jazz.snu.ac.kr
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --without-xsplay --without-pthread
+MAN1= splay.1
.include <bsd.port.mk>
diff --git a/audio/splay/distinfo b/audio/splay/distinfo
index 2563a9b3a0d0..e3bf7be88e7c 100644
--- a/audio/splay/distinfo
+++ b/audio/splay/distinfo
@@ -1 +1 @@
-MD5 (splay-0.5.tar.gz) = 6c98edfb97961c4f89c6a4b8e9aac405
+MD5 (splay-0.8.2.tar.gz) = 4031830584fddf315881798e074f7207
diff --git a/audio/splay/files/patch-aa b/audio/splay/files/patch-aa
index 253006d4b401..dcc51df4e75e 100644
--- a/audio/splay/files/patch-aa
+++ b/audio/splay/files/patch-aa
@@ -1,19 +1,34 @@
-*** mpegsound/rawplayer.cc Thu Mar 27 22:18:47 1997
---- mpegsound/rawplayer.cc Tue Apr 1 19:33:46 1997
-***************
-*** 8,14 ****
-
- #include <fcntl.h>
- #include <sys/ioctl.h>
-! #include <sys/soundcard.h>
-
- #include "mpegsound.h"
-
---- 8,14 ----
-
- #include <fcntl.h>
- #include <sys/ioctl.h>
-! #include <machine/soundcard.h>
-
- #include "mpegsound.h"
-
+diff -uNr ../../splay-0.8.2/mpegsound/httpinput.cc ./mpegsound/httpinput.cc
+--- ../../splay-0.8.2/mpegsound/httpinput.cc Fri Mar 6 17:43:55 1998
++++ ./mpegsound/httpinput.cc Fri Mar 20 11:00:16 1998
+@@ -13,6 +13,7 @@
+
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <errno.h>
+
+ #include "mpegsound.h"
+
+diff -uNr ../../splay-0.8.2/mpegsound/rawplayer.cc ./mpegsound/rawplayer.cc
+--- ../../splay-0.8.2/mpegsound/rawplayer.cc Fri Mar 6 17:43:55 1998
++++ ./mpegsound/rawplayer.cc Fri Mar 20 11:00:29 1998
+@@ -13,7 +13,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+-#include <sys/soundcard.h>
++#include <machine/soundcard.h>
+
+ #include "mpegsound.h"
+
+diff -uNr ../../splay-0.8.2/src/splay/splay.cc ./src/splay/splay.cc
+--- ../../splay-0.8.2/src/splay/splay.cc Fri Mar 6 17:43:55 1998
++++ ./src/splay/splay.cc Fri Mar 20 11:01:55 1998
+@@ -12,6 +12,7 @@
+
+ #include <string.h>
+ #include <unistd.h>
++#include <stdlib.h>
+
+ #include <mpegsound.h>
+
diff --git a/audio/splay/files/patch-ab b/audio/splay/files/patch-ab
index cce91b282d0f..8ca578c50572 100644
--- a/audio/splay/files/patch-ab
+++ b/audio/splay/files/patch-ab
@@ -1,11 +1,15 @@
---- src/cmd/cmd.cc.orig Sat Aug 9 16:31:03 1997
-+++ src/cmd/cmd.cc Sat Aug 9 16:31:15 1997
-@@ -15,7 +15,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
--#include <sys/soundcard.h>
-+#include <machine/soundcard.h>
-
- #include <mpegsound.h>
+--- Makefile.in.orig Sat Apr 4 17:32:23 1998
++++ Makefile.in Sat Apr 4 17:38:18 1998
+@@ -132,12 +132,6 @@
+ else file=splay.1; fi; \
+ echo " $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst"; \
+ $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst
+- @sect=1; \
+- inst=`echo "xsplay" | sed '$(transform)'`.1; \
+- if test -f $(srcdir)/xsplay.1; then file=$(srcdir)/xsplay.1; \
+- else file=xsplay.1; fi; \
+- echo " $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst"; \
+- $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst
+ uninstall-man:
+ $(NORMAL_UNINSTALL)
diff --git a/audio/splay/pkg-comment b/audio/splay/pkg-comment
index d757aaf70be7..3f3632aadf09 100644
--- a/audio/splay/pkg-comment
+++ b/audio/splay/pkg-comment
@@ -1 +1 @@
-An audio player/decoder that decodes MPEG Layer I,II,III and WAV files.
+An audio player that decodes MPEG Layer I,II,III and WAV files.
diff --git a/audio/splay/pkg-descr b/audio/splay/pkg-descr
index 614ef9bd7150..25bdb9711eb1 100644
--- a/audio/splay/pkg-descr
+++ b/audio/splay/pkg-descr
@@ -1,5 +1,5 @@
-splay-0.3
----------
+splay
+-----
Splay program uses the MPEG/Wave Sound library to play sound files in
several formats, notably the MPEG audio and Wave format. This early version
@@ -11,4 +11,4 @@ You can use these libraries under Library GPL.
* This version of splay was not compiled with pthread library.
--
-Port by Choi Jun Ho <junker@jazz.snu.ac.kr>
+Port by CHOI Junho <junker@jazz.snu.ac.kr>
diff --git a/audio/splay/pkg-plist b/audio/splay/pkg-plist
index df1c853561db..22ccf5d0b424 100644
--- a/audio/splay/pkg-plist
+++ b/audio/splay/pkg-plist
@@ -1 +1,2 @@
bin/splay
+man/man1/splay.1.gz