aboutsummaryrefslogtreecommitdiff
path: root/audio/squash
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-26 18:51:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-26 18:51:43 +0000
commita6cf5720c796c8010b5b07ed22aa1bc7f367b7bd (patch)
treed533375fb8f6b2766b573f6eeb5dc8f715e68424 /audio/squash
parentbf528c4c43ccf36979cdb49b647276819400a9ea (diff)
downloadports-a6cf5720c796c8010b5b07ed22aa1bc7f367b7bd.tar.gz
ports-a6cf5720c796c8010b5b07ed22aa1bc7f367b7bd.zip
- Update to 1.0
PR: ports/63403 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=102226
Diffstat (limited to 'audio/squash')
-rw-r--r--audio/squash/Makefile23
-rw-r--r--audio/squash/distinfo4
-rw-r--r--audio/squash/files/patch-FIXLOCK-src_global_squash.c10
-rw-r--r--audio/squash/files/pkg-message.in4
-rw-r--r--audio/squash/pkg-plist8
5 files changed, 21 insertions, 28 deletions
diff --git a/audio/squash/Makefile b/audio/squash/Makefile
index 446a86c7f2ec..d7dffbf1db7e 100644
--- a/audio/squash/Makefile
+++ b/audio/squash/Makefile
@@ -5,15 +5,10 @@
# $FreeBSD$
PORTNAME= squash
-PORTVERSION= 1.0.p1
-PORTREVISION= 4
+PORTVERSION= 1.0
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= ${PORTNAME} \
- pav/:local
-DISTNAME= squash-1.0pre1
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT,local
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@gmx.de
COMMENT= Learning console-based MP3/OGG player
@@ -26,23 +21,24 @@ LIB_DEPENDS+= FLAC.5:${PORTSDIR}/audio/flac \
ao.3:${PORTSDIR}/audio/libao
RUN_DEPENDS= id3v2:${PORTSDIR}/audio/id3v2
-PKGMESSAGE= ${WRKDIR}/pkg-message
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_RUBY= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|--std=gnu99|${CFLAGS} ${PTHREAD_CFLAGS}|; \
+ @${REINPLACE_CMD} -e "s|--std=gnu99|--std=gnu99 ${CFLAGS} ${PTHREAD_CFLAGS}|; \
s|-Iinclude|-Iinclude -I${LOCALBASE}/include|; \
s|-lpthread|${PTHREAD_LIBS}|; s|-ldl|-L${LOCALBASE}/lib|" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s,/usr/bin/ruby,${RUBY}," \
${WRKSRC}/extra/*.rb
@${REINPLACE_CMD} -e "s,/etc/squash.conf,${PREFIX}/etc/squash.conf," \
${WRKSRC}/src/global.c
- @${SED} "s,%%DD%%,${DOCSDIR}," ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
do-install:
${MKDIR} ${PREFIX}/bin
@@ -51,7 +47,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/extra/${FILE}.rb ${PREFIX}/bin
.endfor
${INSTALL_DATA} ${WRKSRC}/extra/musicdb_lib.rb ${RUBY_SITELIBDIR}
- ${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${PREFIX}/etc/squash.conf.dist
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in README doc/FEATURES doc/LOCKS doc/INSTALL doc/USERS_GUIDE
@@ -59,9 +55,6 @@ do-install:
.endfor
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.if ${OSVERSION} < 501100
IGNORE= "ignored: FreeBSD before 5.1 lacks the wordexp interface"
diff --git a/audio/squash/distinfo b/audio/squash/distinfo
index b09cbde534ef..599b0b686d2a 100644
--- a/audio/squash/distinfo
+++ b/audio/squash/distinfo
@@ -1,2 +1,2 @@
-$FreeBSD$
-MD5 (squash-1.0pre1.tar.bz2) = 017b935067e6f01058af76ad595ccae1
+MD5 (squash-1.0.tar.bz2) = 8db5cb7686a1b80ffc1b49421fd15b6f
+SIZE (squash-1.0.tar.bz2) = 84366
diff --git a/audio/squash/files/patch-FIXLOCK-src_global_squash.c b/audio/squash/files/patch-FIXLOCK-src_global_squash.c
new file mode 100644
index 000000000000..256084356e07
--- /dev/null
+++ b/audio/squash/files/patch-FIXLOCK-src_global_squash.c
@@ -0,0 +1,10 @@
+--- ./src/global_squash.c~ Fri Dec 5 21:23:51 2003
++++ ./src/global_squash.c Thu Feb 26 18:57:02 2004
+@@ -143,7 +143,6 @@
+ playlist_queue_song( song, state_info.raw_songs[state_info.current_song].position );
+ }
+ state_info.current_song++;
+- squash_unlock(state_info.lock);
+ squash_wunlock(database_info.lock);
+ squash_unlock(song_queue.lock);
+ squash_unlock(state_info.lock);
diff --git a/audio/squash/files/pkg-message.in b/audio/squash/files/pkg-message.in
deleted file mode 100644
index 22708b508d47..000000000000
--- a/audio/squash/files/pkg-message.in
+++ /dev/null
@@ -1,4 +0,0 @@
----------------------------------------------------------------------------
-NOTE: You MUST configure squash and run a script before you can use squash.
-Please see %%DD%%/INSTALL for details.
----------------------------------------------------------------------------
diff --git a/audio/squash/pkg-plist b/audio/squash/pkg-plist
index e3cb17054e66..5213e0b73962 100644
--- a/audio/squash/pkg-plist
+++ b/audio/squash/pkg-plist
@@ -5,11 +5,5 @@ bin/import_music.rb
bin/joystick.rb
bin/squash
bin/uncollect_info.rb
-etc/squash.conf
+etc/squash.conf.dist
%%RUBY_SITELIBDIR%%/musicdb_lib.rb
-%%DOCSDIR%%/FEATURES
-%%DOCSDIR%%/INSTALL
-%%DOCSDIR%%/LOCKS
-%%DOCSDIR%%/README
-%%DOCSDIR%%/USERS_GUIDE
-@dirrm %%DOCSDIR%%