aboutsummaryrefslogtreecommitdiff
path: root/audio/squash
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-09-13 00:32:17 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-09-13 00:32:17 +0000
commite487af5f22219541dbd65d15c875e14454d2fc85 (patch)
tree594be45be2cce1b30ac6a8b11dcdf3684871c84d /audio/squash
parent22b7691b1d82b01f9fa4dd5b784b68bc7de228ef (diff)
downloadports-e487af5f22219541dbd65d15c875e14454d2fc85.tar.gz
ports-e487af5f22219541dbd65d15c875e14454d2fc85.zip
Add CC=${CC} through MAKE_ARGS, to override hard-coded gcc by actual
compiler. To fix FreeBSD 10-CURRENT fallout (untested on 10 because flac is broken due to libstdc++ removal; flac needs to be told to use libc++, 9.X Tinderbox has no complaints though). Drop library versions from LIB_DEPENDS. NOPORTDOCS -> PORT_OPTIONS. ${MKDIR} ${RUBY_SITELIBDIR} in installation to support "port test".
Notes
Notes: svn path=/head/; revision=327119
Diffstat (limited to 'audio/squash')
-rw-r--r--audio/squash/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/audio/squash/Makefile b/audio/squash/Makefile
index 25a75f57b849..8ee8453a503d 100644
--- a/audio/squash/Makefile
+++ b/audio/squash/Makefile
@@ -12,17 +12,21 @@ MAINTAINER= mandree@FreeBSD.org
COMMENT= Learning console-based MP3/OGG player
LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac \
- fftw.2:${PORTSDIR}/math/fftw \
- id3-3.8.3:${PORTSDIR}/audio/id3lib \
- mad.2:${PORTSDIR}/audio/mad \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- ao.4:${PORTSDIR}/audio/libao
+ fftw:${PORTSDIR}/math/fftw \
+ id3:${PORTSDIR}/audio/id3lib \
+ mad:${PORTSDIR}/audio/mad \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ ao:${PORTSDIR}/audio/libao
RUN_DEPENDS= id3v2:${PORTSDIR}/audio/id3v2
USE_BZIP2= yes
USES= gmake
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
+MAKE_ARGS= CC=${CC}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
@@ -41,9 +45,10 @@ do-install:
.for FILE in collect_info edit_tag export_music import_music joystick uncollect_info
${INSTALL_SCRIPT} ${WRKSRC}/extra/${FILE}.rb ${PREFIX}/bin
.endfor
+ ${MKDIR} ${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/extra/musicdb_lib.rb ${RUBY_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/extra/squash.conf ${PREFIX}/etc/squash.conf.dist
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in README doc/FEATURES doc/LOCKS doc/INSTALL doc/USERS_GUIDE
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}