aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezeboxserver-sqlplaylist/Makefile
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2008-06-29 22:05:56 +0000
committerTim Bishop <tdb@FreeBSD.org>2008-06-29 22:05:56 +0000
commitd57e8a63a9d235b1b8484a08af5dfa253ae44e70 (patch)
treecbd9442c61e9c85d11a4fca15111cf191c9be8da /audio/squeezeboxserver-sqlplaylist/Makefile
parent680356a122f9f794d5efe1f4642347b7ed0c69df (diff)
downloadports-d57e8a63a9d235b1b8484a08af5dfa253ae44e70.tar.gz
ports-d57e8a63a9d235b1b8484a08af5dfa253ae44e70.zip
Notes
Diffstat (limited to 'audio/squeezeboxserver-sqlplaylist/Makefile')
-rw-r--r--audio/squeezeboxserver-sqlplaylist/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/squeezeboxserver-sqlplaylist/Makefile b/audio/squeezeboxserver-sqlplaylist/Makefile
new file mode 100644
index 000000000000..8511a102a252
--- /dev/null
+++ b/audio/squeezeboxserver-sqlplaylist/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: squeezecenter-sqlplaylist
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlplaylist
+PORTVERSION= 2.0.b04
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-sqlplaylist&filename=/
+PKGNAMEPREFIX= squeezecenter-
+DISTNAME= SQLPlayList-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin to create playlists based on SQL queries
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter \
+ ${LOCALBASE}/${SLIMDIR}/Plugins/DynamicPlayList/install.xml:${PORTSDIR}/audio/squeezecenter-dynamicplaylist
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+ ${CP} -R ${WRKSRC}/SQLPlayList/* ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+
+.include <bsd.port.mk>