aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezeboxserver
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-05-18 22:37:05 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-05-18 22:37:05 +0000
commit7b9b86faa6f2d6354c1766a92a1395987cd07fb0 (patch)
tree1bbac63ec29a8cab8e87306e85d1d58dfbd534a5 /audio/squeezeboxserver
parent25f045d1f2cf5b358cf59c2822af190f64bb0d3d (diff)
downloadports-7b9b86faa6f2d6354c1766a92a1395987cd07fb0.tar.gz
ports-7b9b86faa6f2d6354c1766a92a1395987cd07fb0.zip
Notes
Diffstat (limited to 'audio/squeezeboxserver')
-rw-r--r--audio/squeezeboxserver/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 38ea6e126295..9456157a0cd7 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -1,13 +1,9 @@
-# Ports collection makefile for: squeezeboxserver
-# Date created: Wed Apr 14, 2004
-# Whom: Brooks Davis <brooks@freebsd.org>
-#
+# Created by: Brooks Davis <brooks@freebsd.org>
# $FreeBSD$
-#
PORTNAME= squeezeboxserver
PORTVERSION= 7.5.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
@@ -174,12 +170,16 @@ post-patch:
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|g' \
${WRKSRC}/scanner.pl \
${WRKSRC}/slimserver.pl
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's/skip-locking/skip-external-locking/' \
-e 's/default-character-set/character-set-server/'\
- -e 's/table_cache/table_open_cache/'\
-e 's/default-collation/collation-server/' ${WRKSRC}/MySQL/my.tt
- ${REINPLACE_CMD} \
+# table_open_cache was known as table_cache in MySQL 5.1.2 and earlier
+ @if [ "$(MYSQL_VER)" != "50" ] ; then \
+ ${REINPLACE_CMD} \
+ -e 's/table_cache/table_open_cache/' ${WRKSRC}/MySQL/my.tt ;\
+ fi
+ @${REINPLACE_CMD} \
-e 's/TYPE=InnoDB/ENGINE=InnoDB/' ${WRKSRC}/SQL/mysql/schema_*.sql
do-build: