aboutsummaryrefslogtreecommitdiff
path: root/audio/stone-phaser-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-11-17 07:05:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-11-17 07:05:23 +0000
commit26571a2a3b84b0bf185030a1f32e229c9815c63f (patch)
tree55559927bd43bee0b08aae16a0cbfaef96f57515 /audio/stone-phaser-lv2
parentfbe7610a2979c3b9006b31eabe7e6ad5a40a108b (diff)
downloadports-26571a2a3b84b0bf185030a1f32e229c9815c63f.tar.gz
ports-26571a2a3b84b0bf185030a1f32e229c9815c63f.zip
New port: audio/stone-phaser-lv2: Classic analog phaser effect, made with DPF and Faust
Notes
Notes: svn path=/head/; revision=517806
Diffstat (limited to 'audio/stone-phaser-lv2')
-rw-r--r--audio/stone-phaser-lv2/Makefile33
-rw-r--r--audio/stone-phaser-lv2/distinfo5
-rw-r--r--audio/stone-phaser-lv2/files/mntent.h64
-rw-r--r--audio/stone-phaser-lv2/files/patch-plugins_stone-phaser-stereo_Makefile22
-rw-r--r--audio/stone-phaser-lv2/files/patch-plugins_stone-phaser_Makefile43
-rw-r--r--audio/stone-phaser-lv2/pkg-descr7
-rw-r--r--audio/stone-phaser-lv2/pkg-plist30
7 files changed, 204 insertions, 0 deletions
diff --git a/audio/stone-phaser-lv2/Makefile b/audio/stone-phaser-lv2/Makefile
new file mode 100644
index 000000000000..d0aaeb551411
--- /dev/null
+++ b/audio/stone-phaser-lv2/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= stone-phaser
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.2-5
+DISTVERSIONSUFFIX= -g3e51889
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Classic analog phaser effect, made with DPF and Faust
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ bash:shells/bash
+
+USES= gmake gnome pkgconfig shebangfix xorg
+SHEBANG_GLOB= *.sh
+USE_GITHUB= yes
+GH_ACCOUNT= jpcima
+GH_TUPLE= DISTRHO:DPF:e69074e:dpf/dpf
+USE_GNOME= cairo
+USE_XORG= x11
+
+MAKE_ARGS= BUILD_LADSPA=false
+CFLAGS+= -I${FILESDIR}
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/vst
+
+.include <bsd.port.mk>
diff --git a/audio/stone-phaser-lv2/distinfo b/audio/stone-phaser-lv2/distinfo
new file mode 100644
index 000000000000..057ca78ee72a
--- /dev/null
+++ b/audio/stone-phaser-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1573972096
+SHA256 (jpcima-stone-phaser-v0.1.2-5-g3e51889_GH0.tar.gz) = 87f2eb37ca483b27864e842fffbc2c6dfbfc75797e605b50a085e1bf90c36ba2
+SIZE (jpcima-stone-phaser-v0.1.2-5-g3e51889_GH0.tar.gz) = 2099441
+SHA256 (DISTRHO-DPF-e69074e_GH0.tar.gz) = 2d97f40ce65da28150f86f364347577a917b0ee9920862cdf1979db69e69f06c
+SIZE (DISTRHO-DPF-e69074e_GH0.tar.gz) = 2113728
diff --git a/audio/stone-phaser-lv2/files/mntent.h b/audio/stone-phaser-lv2/files/mntent.h
new file mode 100644
index 000000000000..5cdf9881ccca
--- /dev/null
+++ b/audio/stone-phaser-lv2/files/mntent.h
@@ -0,0 +1,64 @@
+/*
+ * mntent
+ * mntent.h - compatability header for FreeBSD
+ *
+ * Copyright (c) 2001 David Rufino <daverufino@btinternet.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+// $FreeBSD$
+
+#if defined(HAVE_MNTENT_H)
+#include <mntent.h>
+#else
+#ifndef _MNTENT_H
+#define _MNTENT_H
+#include <stdio.h>
+
+#define MOUNTED "dummy"
+
+#define MNTTYPE_NFS "nfs"
+
+struct mntent {
+ char *mnt_fsname;
+ char *mnt_dir;
+ char *mnt_type;
+ char *mnt_opts;
+ int mnt_freq;
+ int mnt_passno;
+};
+
+#define setmntent(x,y) ((FILE *)0x1)
+#ifdef __cplusplus
+extern "C" {
+#endif
+struct mntent *getmntent __P ((FILE *fp));
+char *hasmntopt __P ((const struct mntent *mnt, const char *option));
+#ifdef __cplusplus
+}; // extern "C"
+#endif
+#define endmntent(x) ((int)1)
+
+#endif /* _MNTENT_H */
+#endif /* HAVE_MNTENT_H */
diff --git a/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser-stereo_Makefile b/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser-stereo_Makefile
new file mode 100644
index 000000000000..42edb494a02a
--- /dev/null
+++ b/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser-stereo_Makefile
@@ -0,0 +1,22 @@
+--- plugins/stone-phaser-stereo/Makefile.orig 2019-11-12 05:51:36 UTC
++++ plugins/stone-phaser-stereo/Makefile
+@@ -158,8 +158,7 @@ ifeq ($(BUILD_VST2),true)
+ @install -Dm755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(DESTDIR)$(VST_DIR)/$(NAME)-vst$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_LV2),true)
+- @install -dm755 $(DESTDIR)$(LV2_DIR) && \
+- cp -rfd $(TARGET_DIR)/$(NAME).lv2 $(DESTDIR)$(LV2_DIR)
++ @cp -rf $(TARGET_DIR)/$(NAME).lv2 $(DESTDIR)$(LV2_DIR)
+ endif
+ ifeq ($(BUILD_JACK),true)
+ ifeq ($(HAVE_JACK),true)
+@@ -184,8 +183,7 @@ ifeq ($(BUILD_VST2),true)
+ @install -Dm755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(USER_VST_DIR)/$(NAME)-vst$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_LV2),true)
+- @install -dm755 $(USER_LV2_DIR) && \
+- cp -rfd $(TARGET_DIR)/$(NAME).lv2 $(USER_LV2_DIR)
++ @cp -rf $(TARGET_DIR)/$(NAME).lv2 $(USER_LV2_DIR)
+ endif
+ ifeq ($(BUILD_JACK),true)
+ ifeq ($(HAVE_JACK),true)
diff --git a/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser_Makefile b/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser_Makefile
new file mode 100644
index 000000000000..92e659c48c65
--- /dev/null
+++ b/audio/stone-phaser-lv2/files/patch-plugins_stone-phaser_Makefile
@@ -0,0 +1,43 @@
+--- plugins/stone-phaser/Makefile.orig 2019-11-12 05:51:36 UTC
++++ plugins/stone-phaser/Makefile
+@@ -152,14 +152,13 @@ endif
+ endif
+ endif
+ ifeq ($(BUILD_LADSPA),true)
+- @install -Dm755 $(TARGET_DIR)/$(NAME)-ladspa$(LIB_EXT) $(DESTDIR)$(LADSPA_DIR)/$(NAME)-ladspa$(LIB_EXT)
++ @install -m755 $(TARGET_DIR)/$(NAME)-ladspa$(LIB_EXT) $(DESTDIR)$(LADSPA_DIR)/$(NAME)-ladspa$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_VST2),true)
+- @install -Dm755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(DESTDIR)$(VST_DIR)/$(NAME)-vst$(LIB_EXT)
++ @install -m755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(DESTDIR)$(VST_DIR)/$(NAME)-vst$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_LV2),true)
+- @install -dm755 $(DESTDIR)$(LV2_DIR) && \
+- cp -rfd $(TARGET_DIR)/$(NAME).lv2 $(DESTDIR)$(LV2_DIR)
++ @cp -rf $(TARGET_DIR)/$(NAME).lv2 $(DESTDIR)$(LV2_DIR)
+ endif
+ ifeq ($(BUILD_JACK),true)
+ ifeq ($(HAVE_JACK),true)
+@@ -172,7 +171,7 @@ ifeq ($(BUILD_DSSI),true)
+ ifneq ($(MACOS_OR_WINDOWS),true)
+ ifeq ($(BUILD_UI),true)
+ ifeq ($(HAVE_LIBLO),true)
+- @install -Dm755 $(TARGET_DIR)/$(NAME)-dssi$(LIB_EXT) $(USER_DSSI_DIR)/$(NAME)-dssi$(LIB_EXT)
++ @install -m755 $(TARGET_DIR)/$(NAME)-dssi$(LIB_EXT) $(USER_DSSI_DIR)/$(NAME)-dssi$(LIB_EXT)
+ endif
+ endif
+ endif
+@@ -181,11 +180,10 @@ ifeq ($(BUILD_LADSPA),true)
+ @install -Dm755 $(TARGET_DIR)/$(NAME)-ladspa$(LIB_EXT) $(USER_LADSPA_DIR)/$(NAME)-ladspa$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_VST2),true)
+- @install -Dm755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(USER_VST_DIR)/$(NAME)-vst$(LIB_EXT)
++ @install -m755 $(TARGET_DIR)/$(NAME)-vst$(LIB_EXT) $(USER_VST_DIR)/$(NAME)-vst$(LIB_EXT)
+ endif
+ ifeq ($(BUILD_LV2),true)
+- @install -dm755 $(USER_LV2_DIR) && \
+- cp -rfd $(TARGET_DIR)/$(NAME).lv2 $(USER_LV2_DIR)
++ @cp -rf $(TARGET_DIR)/$(NAME).lv2 $(USER_LV2_DIR)
+ endif
+ ifeq ($(BUILD_JACK),true)
+ ifeq ($(HAVE_JACK),true)
diff --git a/audio/stone-phaser-lv2/pkg-descr b/audio/stone-phaser-lv2/pkg-descr
new file mode 100644
index 000000000000..f7fac1bcd48b
--- /dev/null
+++ b/audio/stone-phaser-lv2/pkg-descr
@@ -0,0 +1,7 @@
+A classic analog phaser effect
+
+This is an analog phaser with similarity to the Small Stone. It has a color
+switch, which makes the phasing stronger when on, and adds some feedback
+controls. A stereo variant of the phaser is included.
+
+WWW: https://github.com/jpcima/stone-phaser
diff --git a/audio/stone-phaser-lv2/pkg-plist b/audio/stone-phaser-lv2/pkg-plist
new file mode 100644
index 000000000000..8117ff5b0697
--- /dev/null
+++ b/audio/stone-phaser-lv2/pkg-plist
@@ -0,0 +1,30 @@
+lib/lv2/manifest.ttl
+lib/lv2/modgui.ttl
+lib/lv2/modgui/icon-stone-phaser.html
+lib/lv2/modgui/knobs/stone/stone.png
+lib/lv2/modgui/pedals/footswitch.png
+lib/lv2/modgui/pedals/stone/gray.png
+lib/lv2/modgui/screenshot-stone-phaser.png
+lib/lv2/modgui/stylesheet-stone-phaser.css
+lib/lv2/modgui/switches/stone/stone.png
+lib/lv2/modgui/thumbnail-stone-phaser.png
+lib/lv2/stone-phaser-stereo.lv2/manifest.ttl
+lib/lv2/stone-phaser-stereo.lv2/modgui.ttl
+lib/lv2/stone-phaser-stereo.lv2/modgui/icon-stone-phaser.html
+lib/lv2/stone-phaser-stereo.lv2/modgui/knobs/stone/stone.png
+lib/lv2/stone-phaser-stereo.lv2/modgui/pedals/footswitch.png
+lib/lv2/stone-phaser-stereo.lv2/modgui/pedals/stone/gray.png
+lib/lv2/stone-phaser-stereo.lv2/modgui/screenshot-stone-phaser.png
+lib/lv2/stone-phaser-stereo.lv2/modgui/stylesheet-stone-phaser.css
+lib/lv2/stone-phaser-stereo.lv2/modgui/switches/stone/stone.png
+lib/lv2/stone-phaser-stereo.lv2/modgui/thumbnail-stone-phaser.png
+lib/lv2/stone-phaser-stereo.lv2/stone-phaser-stereo_dsp.so
+lib/lv2/stone-phaser-stereo.lv2/stone-phaser-stereo_dsp.ttl
+lib/lv2/stone-phaser-stereo.lv2/stone-phaser-stereo_ui.so
+lib/lv2/stone-phaser-stereo.lv2/stone-phaser-stereo_ui.ttl
+lib/lv2/stone-phaser_dsp.so
+lib/lv2/stone-phaser_dsp.ttl
+lib/lv2/stone-phaser_ui.so
+lib/lv2/stone-phaser_ui.ttl
+lib/vst/stone-phaser-stereo-vst.so
+lib/vst/stone-phaser-vst.so