aboutsummaryrefslogtreecommitdiff
path: root/audio/stone-phaser-lv2
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-12-11 13:13:14 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-12-11 13:13:14 +0000
commitd57e3ecdf752c7f8ba03b7bba21a20f801bef70c (patch)
tree16e6bb50990cc226861784e263d2a0511de3f535 /audio/stone-phaser-lv2
parent2c0aff5f35647e018872c31c2aa82f522150d3e2 (diff)
downloadports-d57e3ecdf752c7f8ba03b7bba21a20f801bef70c.tar.gz
ports-d57e3ecdf752c7f8ba03b7bba21a20f801bef70c.zip
Fix build on GCC-based systems:
cc1plus: error: unrecognized command line option "-msse" cc1plus: error: unrecognized command line option "-msse2" cc1plus: error: unrecognized command line option "-std=gnu++0x" The previous patchfile is now split into two, depending on whether ARCH is x86 or not. Since REINPLACE is now deprecated for this purpose, I could not figure out any other way to do it. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=519800
Diffstat (limited to 'audio/stone-phaser-lv2')
-rw-r--r--audio/stone-phaser-lv2/Makefile12
-rw-r--r--audio/stone-phaser-lv2/files/extra-patch-dpf_Makefile.base.mk11
-rw-r--r--audio/stone-phaser-lv2/files/extra-patch-nosse-dpf_Makefile.base.mk11
3 files changed, 32 insertions, 2 deletions
diff --git a/audio/stone-phaser-lv2/Makefile b/audio/stone-phaser-lv2/Makefile
index d0aaeb551411..5c4d3800ab62 100644
--- a/audio/stone-phaser-lv2/Makefile
+++ b/audio/stone-phaser-lv2/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= lv2>0:audio/lv2 \
bash:shells/bash
-USES= gmake gnome pkgconfig shebangfix xorg
+USES= compiler:c++0x gmake gnome pkgconfig shebangfix xorg
SHEBANG_GLOB= *.sh
USE_GITHUB= yes
GH_ACCOUNT= jpcima
@@ -30,4 +30,12 @@ CFLAGS+= -I${FILESDIR}
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/vst
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "i386"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-dpf_Makefile.base.mk
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-nosse-dpf_Makefile.base.mk
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/stone-phaser-lv2/files/extra-patch-dpf_Makefile.base.mk b/audio/stone-phaser-lv2/files/extra-patch-dpf_Makefile.base.mk
new file mode 100644
index 000000000000..787537cecad0
--- /dev/null
+++ b/audio/stone-phaser-lv2/files/extra-patch-dpf_Makefile.base.mk
@@ -0,0 +1,11 @@
+--- dpf/Makefile.base.mk.orig 2019-09-28 00:18:08 UTC
++++ dpf/Makefile.base.mk
+@@ -106,7 +106,7 @@ endif
+ # Set build and link flags
+
+ BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
+-BASE_OPTS = -O3 -ffast-math -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
++BASE_OPTS = -O3 -ffast-math -fdata-sections -ffunction-sections
+
+ ifeq ($(MACOS),true)
+ # MacOS linker flags
diff --git a/audio/stone-phaser-lv2/files/extra-patch-nosse-dpf_Makefile.base.mk b/audio/stone-phaser-lv2/files/extra-patch-nosse-dpf_Makefile.base.mk
new file mode 100644
index 000000000000..e5800458d2be
--- /dev/null
+++ b/audio/stone-phaser-lv2/files/extra-patch-nosse-dpf_Makefile.base.mk
@@ -0,0 +1,11 @@
+--- dpf/Makefile.base.mk.orig 2019-12-11 09:25:25 UTC
++++ dpf/Makefile.base.mk
+@@ -106,7 +106,7 @@ endif
+ # Set build and link flags
+
+ BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
+-BASE_OPTS = -O3 -ffast-math -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
++BASE_OPTS = -O3 -ffast-math -fdata-sections -ffunction-sections
+
+ ifeq ($(MACOS),true)
+ # MacOS linker flags