aboutsummaryrefslogtreecommitdiff
path: root/audio/strawberry
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-06-14 20:18:32 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-06-14 20:18:32 +0000
commit65f5e533c05959efc02fa17d1cb223a3327e90ac (patch)
tree45c6725aeedc7b6a64dda7c9ac82f76eca0cacd5 /audio/strawberry
parent711279bdb98cf522f699a78debed8b0c973d61a4 (diff)
downloadports-65f5e533c05959efc02fa17d1cb223a3327e90ac.tar.gz
ports-65f5e533c05959efc02fa17d1cb223a3327e90ac.zip
audio/strawberry: Update to 0.6.12
Update audio/strawberry to 0.6.12 Remove local patches that are incorporated upstream PR: 247241 Submitted by: Daniel Menelkir (maintainer)
Notes
Notes: svn path=/head/; revision=538828
Diffstat (limited to 'audio/strawberry')
-rw-r--r--audio/strawberry/Makefile6
-rw-r--r--audio/strawberry/distinfo6
-rw-r--r--audio/strawberry/files/patch-src_collection_collectionmodel.cpp84
-rw-r--r--audio/strawberry/files/patch-src_organise_organiseformat.cpp33
-rw-r--r--audio/strawberry/files/patch-tests_CMakeLists.txt10
-rw-r--r--audio/strawberry/files/patch-tests_src_collectionmodel__test.cpp29
-rw-r--r--audio/strawberry/files/patch-tests_src_organiseformat__test.cpp24
-rw-r--r--audio/strawberry/files/patch-tests_src_playlist__test.cpp31
8 files changed, 6 insertions, 217 deletions
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index 70d60452756e..8ed825de4dfc 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= strawberry
-DISTVERSION= 0.6.11
-PORTREVISION= 1
+DISTVERSION= 0.6.12
CATEGORIES= audio
MASTER_SITES= https://github.com/strawberrymusicplayer/${PORTNAME}/releases/download/${DISTVERSION}/ \
https://files.jkvinge.net/packages/strawberry/
@@ -46,8 +45,9 @@ TEST_TARGET= strawberry_test
OPTIONS_DEFINE= APPLEDEV AUDIOCD IPOD MOODBAR MTPDEV MUSICBRAINZ \
SUBSONIC TIDAL VLC
+
APPLEDEV_IMPLIES= IPOD
-OPTIONS_DEFAULT= PULSEAUDIO
+OPTIONS_DEFAULT= PULSEAUDIO MOODBAR
OPTIONS_MULTI= SOUND
OPTIONS_MULTI_SOUND= ALSA PULSEAUDIO
diff --git a/audio/strawberry/distinfo b/audio/strawberry/distinfo
index be0a4a1ff877..df642996926e 100644
--- a/audio/strawberry/distinfo
+++ b/audio/strawberry/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589641083
-SHA256 (strawberry-0.6.11.tar.xz) = 84b71b33b5f80b7e86682e49f15289c2c00ab89d47e3722f762dda0d6965a201
-SIZE (strawberry-0.6.11.tar.xz) = 9295808
+TIMESTAMP = 1592075662
+SHA256 (strawberry-0.6.12.tar.xz) = c53207613508da507f0a9cb4b13e23532fe06b9aaf3200d44b5e4b84170aeb79
+SIZE (strawberry-0.6.12.tar.xz) = 9311104
diff --git a/audio/strawberry/files/patch-src_collection_collectionmodel.cpp b/audio/strawberry/files/patch-src_collection_collectionmodel.cpp
deleted file mode 100644
index dbbd4750a6da..000000000000
--- a/audio/strawberry/files/patch-src_collection_collectionmodel.cpp
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/collection/collectionmodel.cpp.orig 2020-05-16 18:39:26 UTC
-+++ src/collection/collectionmodel.cpp
-@@ -119,12 +119,14 @@ CollectionModel::CollectionModel(CollectionBackend *ba
- }
-
- QIcon nocover = IconLoader::Load("cdcase");
-- no_cover_icon_ = nocover.pixmap(nocover.availableSizes().last()).scaled(kPrettyCoverSize, kPrettyCoverSize, Qt::KeepAspectRatio, Qt::SmoothTransformation);
-- //no_cover_icon_ = QPixmap(":/pictures/noalbumart.png").scaled(kPrettyCoverSize, kPrettyCoverSize, Qt::KeepAspectRatio, Qt::SmoothTransformation);
-+ if (!nocover.isNull()) {
-+ no_cover_icon_ = nocover.pixmap(nocover.availableSizes().last()).scaled(kPrettyCoverSize, kPrettyCoverSize, Qt::KeepAspectRatio, Qt::SmoothTransformation);
-+ }
-
-- if (sIconCache == nullptr) {
-+ if (app_ && !sIconCache) {
- sIconCache = new QNetworkDiskCache(this);
- sIconCache->setCacheDirectory(QStandardPaths::writableLocation(QStandardPaths::CacheLocation) + "/" + kPixmapDiskCacheDir);
-+ connect(app_, SIGNAL(ClearPixmapDiskCache()), SLOT(ClearDiskCache()));
- }
-
- connect(backend_, SIGNAL(SongsDiscovered(SongList)), SLOT(SongsDiscovered(SongList)));
-@@ -139,8 +141,6 @@ CollectionModel::CollectionModel(CollectionBackend *ba
- backend_->UpdateTotalArtistCountAsync();
- backend_->UpdateTotalAlbumCountAsync();
-
-- connect(app_, SIGNAL(ClearPixmapDiskCache()), SLOT(ClearDiskCache()));
--
- ReloadSettings();
-
- }
-@@ -189,7 +189,9 @@ void CollectionModel::ReloadSettings() {
-
- QPixmapCache::setCacheLimit(MaximumCacheSize(&s, CollectionSettingsPage::kSettingsCacheSize, CollectionSettingsPage::kSettingsCacheSizeUnit, CollectionSettingsPage::kSettingsCacheSizeDefault) / 1024);
-
-- sIconCache->setMaximumCacheSize(MaximumCacheSize(&s, CollectionSettingsPage::kSettingsDiskCacheSize, CollectionSettingsPage::kSettingsDiskCacheSizeUnit, CollectionSettingsPage::kSettingsDiskCacheSizeDefault));
-+ if (sIconCache) {
-+ sIconCache->setMaximumCacheSize(MaximumCacheSize(&s, CollectionSettingsPage::kSettingsDiskCacheSize, CollectionSettingsPage::kSettingsDiskCacheSizeUnit, CollectionSettingsPage::kSettingsDiskCacheSizeDefault));
-+ }
-
- s.endGroup();
-
-@@ -510,7 +512,7 @@ void CollectionModel::SongsDeleted(const SongList &son
- // Remove from pixmap cache
- const QString cache_key = AlbumIconPixmapCacheKey(ItemToIndex(node));
- QPixmapCache::remove(cache_key);
-- if (use_disk_cache_) sIconCache->remove(QUrl(cache_key));
-+ if (use_disk_cache_ && sIconCache) sIconCache->remove(QUrl(cache_key));
- if (pending_cache_keys_.contains(cache_key)) {
- pending_cache_keys_.remove(cache_key);
- }
-@@ -585,7 +587,7 @@ QVariant CollectionModel::AlbumIcon(const QModelIndex
- }
-
- // Try to load it from the disk cache
-- if (use_disk_cache_) {
-+ if (use_disk_cache_ && sIconCache) {
- std::unique_ptr<QIODevice> cache(sIconCache->data(QUrl(cache_key)));
- if (cache) {
- QImage cached_image;
-@@ -637,7 +639,7 @@ void CollectionModel::AlbumCoverLoaded(const quint64 i
- }
-
- // If we have a valid cover not already in the disk cache
-- if (use_disk_cache_) {
-+ if (use_disk_cache_ && sIconCache) {
- std::unique_ptr<QIODevice> cached_img(sIconCache->data(QUrl(cache_key)));
- if (!cached_img && !result.image_scaled.isNull()) {
- QNetworkCacheMetaData item_metadata;
-@@ -1556,6 +1558,7 @@ int CollectionModel::MaximumCacheSize(QSettings *s, co
- } while (unit > 0);
-
- return size;
-+
- }
-
- void CollectionModel::GetChildSongs(CollectionItem *item, QList<QUrl> *urls, SongList *songs, QSet<int> *song_ids) const {
-@@ -1686,7 +1689,7 @@ void CollectionModel::TotalAlbumCountUpdatedSlot(const
- }
-
- void CollectionModel::ClearDiskCache() {
-- sIconCache->clear();
-+ if (sIconCache) sIconCache->clear();
- }
-
- QDataStream &operator<<(QDataStream &s, const CollectionModel::Grouping &g) {
diff --git a/audio/strawberry/files/patch-src_organise_organiseformat.cpp b/audio/strawberry/files/patch-src_organise_organiseformat.cpp
deleted file mode 100644
index 95da02e88999..000000000000
--- a/audio/strawberry/files/patch-src_organise_organiseformat.cpp
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/organise/organiseformat.cpp.orig 2020-04-27 23:42:16 UTC
-+++ src/organise/organiseformat.cpp
-@@ -35,6 +35,7 @@
- #include <QPalette>
- #include <QValidator>
- #include <QTextEdit>
-+#include <QTextDocument>
- #include <QTextFormat>
-
- #include "core/arraysize.h"
-@@ -44,8 +45,6 @@
-
- #include "organiseformat.h"
-
--class QTextDocument;
--
- const char *OrganiseFormat::kTagPattern = "\\%([a-zA-Z]*)";
- const char *OrganiseFormat::kBlockPattern = "\\{([^{}]+)\\}";
- const QStringList OrganiseFormat::kKnownTags = QStringList() << "title"
-@@ -145,7 +144,12 @@ QString OrganiseFormat::GetFilenameForSong(const Song
-
- QFileInfo info(filename);
- QString extension = info.suffix();
-- QString filepath = info.path() + "/" + info.completeBaseName();
-+ QString filepath;
-+ if (!info.path().isEmpty() && info.path() != ".") {
-+ filepath.append(info.path());
-+ filepath.append("/");
-+ }
-+ filepath.append(info.completeBaseName());
-
- // Fix any parts of the path that start with dots.
- QStringList parts_old = filepath.split("/");
diff --git a/audio/strawberry/files/patch-tests_CMakeLists.txt b/audio/strawberry/files/patch-tests_CMakeLists.txt
deleted file mode 100644
index dce966737196..000000000000
--- a/audio/strawberry/files/patch-tests_CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- tests/CMakeLists.txt.orig 2020-04-27 23:42:17 UTC
-+++ tests/CMakeLists.txt
-@@ -87,7 +87,6 @@ if(Qt5Test_FOUND AND GTEST_FOUND AND GMOCK_LIBRARY)
- add_test_file(src/song_test.cpp false)
- add_test_file(src/collectionbackend_test.cpp false)
- add_test_file(src/collectionmodel_test.cpp true)
-- add_test_file(src/playlist_test.cpp true)
- add_test_file(src/songplaylistitem_test.cpp false)
- add_test_file(src/organiseformat_test.cpp false)
-
diff --git a/audio/strawberry/files/patch-tests_src_collectionmodel__test.cpp b/audio/strawberry/files/patch-tests_src_collectionmodel__test.cpp
deleted file mode 100644
index 782ac6b35ba6..000000000000
--- a/audio/strawberry/files/patch-tests_src_collectionmodel__test.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- tests/src/collectionmodel_test.cpp.orig 2020-04-27 23:42:17 UTC
-+++ tests/src/collectionmodel_test.cpp
-@@ -75,6 +75,8 @@ class CollectionModelTest : public ::testing::Test {
- Song AddSong(const QString& title, const QString& artist, const QString& album, int length) {
- Song song;
- song.Init(title, artist, album, length);
-+ song.set_mtime(0);
-+ song.set_ctime(0);
- return AddSong(song);
- }
-
-@@ -111,6 +113,8 @@ TEST_F(CollectionModelTest, CompilationAlbums) {
- Song song;
- song.Init("Title", "Artist", "Album", 123);
- song.set_compilation(true);
-+ song.set_mtime(0);
-+ song.set_ctime(0);
-
- AddSong(song);
- model_->Init(false);
-@@ -200,6 +204,8 @@ TEST_F(CollectionModelTest, VariousArtistSongs) {
- QString n = QString::number(i+1);
- Song song;
- song.Init("Title " + n, "Artist " + n, "Album", 0);
-+ song.set_mtime(0);
-+ song.set_ctime(0);
- songs << song;
- }
-
diff --git a/audio/strawberry/files/patch-tests_src_organiseformat__test.cpp b/audio/strawberry/files/patch-tests_src_organiseformat__test.cpp
deleted file mode 100644
index 1036718afa96..000000000000
--- a/audio/strawberry/files/patch-tests_src_organiseformat__test.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- tests/src/organiseformat_test.cpp.orig 2019-06-29 18:18:34 UTC
-+++ tests/src/organiseformat_test.cpp
-@@ -59,6 +59,7 @@ TEST_F(OrganiseFormatTest, BasicReplace) {
- format_.set_format("%album %albumartist %artist %bitrate %comment %composer %performer %grouping %disc %genre %length %samplerate %bitdepth %title %track %year");
-
- ASSERT_TRUE(format_.IsValid());
-+
- EXPECT_EQ("album_albumartist_artist_123_comment_composer_performer_grouping_789_genre_987_654_32_title_321_2010", format_.GetFilenameForSong(song_));
-
- }
-@@ -135,11 +136,12 @@ TEST_F(OrganiseFormatTest, ReplaceNonAscii) {
-
- format_.set_remove_non_ascii(false);
- EXPECT_EQ(QString::fromUtf8("Röyksopp"), format_.GetFilenameForSong(song_));
-+
- format_.set_remove_non_ascii(true);
- EXPECT_EQ("Royksopp", format_.GetFilenameForSong(song_));
-
- song_.set_artist(QString::fromUtf8("Владимир Высоцкий"));
-- EXPECT_EQ("_________________", format_.GetFilenameForSong(song_));
-+ EXPECT_EQ("????????_????????", format_.GetFilenameForSong(song_));
-
- }
-
diff --git a/audio/strawberry/files/patch-tests_src_playlist__test.cpp b/audio/strawberry/files/patch-tests_src_playlist__test.cpp
deleted file mode 100644
index 030aba973870..000000000000
--- a/audio/strawberry/files/patch-tests_src_playlist__test.cpp
+++ /dev/null
@@ -1,31 +0,0 @@
---- tests/src/playlist_test.cpp.orig 2020-04-27 23:42:17 UTC
-+++ tests/src/playlist_test.cpp
-@@ -53,15 +53,15 @@ class PlaylistTest : public ::testing::Test {
- Song metadata;
- metadata.Init(title, artist, album, length);
-
-- //MockPlaylistItem* ret = new MockPlaylistItem;
-+ MockPlaylistItem *ret = new MockPlaylistItem;
- //EXPECT_CALL(*ret, Metadata()).WillRepeatedly(Return(metadata));
-
-- //return ret;
-+ return ret;
- return nullptr;
- }
-
-- std::shared_ptr<PlaylistItem> MakeMockItemP(const QString& title, const QString& artist = QString(), const QString& album = QString(), int length = 123) const {
-- return std::shared_ptr<PlaylistItem>(MakeMockItem(title, artist, album, length));
-+ PlaylistItemPtr MakeMockItemP(const QString& title, const QString& artist = QString(), const QString& album = QString(), int length = 123) const {
-+ return PlaylistItemPtr(MakeMockItem(title, artist, album, length));
- }
-
- Playlist playlist_;
-@@ -76,7 +76,7 @@ TEST_F(PlaylistTest, Basic) {
- TEST_F(PlaylistTest, InsertItems) {
-
- MockPlaylistItem* item = MakeMockItem("Title", "Artist", "Album", 123);
-- std::shared_ptr<PlaylistItem> item_ptr(item);
-+ PlaylistItemPtr item_ptr(item);
-
- // Insert the item
- EXPECT_EQ(0, playlist_.rowCount(QModelIndex()));