aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtranscoder
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-31 02:38:17 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-31 02:38:17 +0000
commit61b8565a92e5efb8ddc2c85ff6c6fcc01e1d4055 (patch)
tree8292a9a70b74e8d038ae5c24276e3cd999192ba6 /audio/streamtranscoder
parentfed5fbab28349504814631166a3cd37362609ab1 (diff)
downloadports-61b8565a92e5efb8ddc2c85ff6c6fcc01e1d4055.tar.gz
ports-61b8565a92e5efb8ddc2c85ff6c6fcc01e1d4055.zip
Add streamtranscoder.
streamTranscoder takes the output from SHOUTcast/Icecast/Peercast/KasterBlaster servers or a soundcard input and transcodes them to another SHOUTcast, Icecast, or Peercast server in MP3 or Ogg Vorbis format. It can transcode the input audio by resampling or re-encoding, as well as changing the format from MP3 to Ogg Vorbis (or vice versa). WWW: http://www.oddsock.org/tools/streamTranscoder/ PR: ports/85459 Submitted by: Mark Kane <mark@mkproductions.org>
Notes
Notes: svn path=/head/; revision=141517
Diffstat (limited to 'audio/streamtranscoder')
-rw-r--r--audio/streamtranscoder/Makefile40
-rw-r--r--audio/streamtranscoder/distinfo2
-rw-r--r--audio/streamtranscoder/pkg-descr11
3 files changed, 53 insertions, 0 deletions
diff --git a/audio/streamtranscoder/Makefile b/audio/streamtranscoder/Makefile
new file mode 100644
index 000000000000..3a8e421532ae
--- /dev/null
+++ b/audio/streamtranscoder/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: streamtranscoder
+# Date created: 29 August 2005
+# Whom: Mark Kane <mark@mkproductions.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= streamtranscoder
+PORTVERSION= 1.2.8
+CATEGORIES= audio
+MASTER_SITES= http://www.oddsock.org/tools/streamTranscoder/
+
+MAINTAINER= mark@mkproductions.org
+COMMENT= Transcode and stream audio to a SHOUTcast/Icecast/Peercast server
+
+LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ mad:${PORTSDIR}/audio/libmad \
+ curl:${PORTSDIR}/ftp/curl \
+ mp3lame:${PORTSDIR}/audio/lame
+
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/streamTranscoder
+PORTDOCS= AUTHORS README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|g; \
+ s|-pthread|${PTHREAD_LIBS}|g; s|-O20|$$CFLAGS|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/streamtranscoder/distinfo b/audio/streamtranscoder/distinfo
new file mode 100644
index 000000000000..da5bdb095319
--- /dev/null
+++ b/audio/streamtranscoder/distinfo
@@ -0,0 +1,2 @@
+MD5 (streamtranscoder-1.2.8.tar.gz) = 9a046ff6aadc62df3598af11dac400b8
+SIZE (streamtranscoder-1.2.8.tar.gz) = 355078
diff --git a/audio/streamtranscoder/pkg-descr b/audio/streamtranscoder/pkg-descr
new file mode 100644
index 000000000000..317e338a69a1
--- /dev/null
+++ b/audio/streamtranscoder/pkg-descr
@@ -0,0 +1,11 @@
+streamTranscoder takes the output from
+SHOUTcast/Icecast/Peercast/KasterBlaster servers or a soundcard input and
+transcodes them to another SHOUTcast, Icecast, or Peercast server in MP3 or
+Ogg Vorbis format. It can transcode the input audio by resampling or
+re-encoding, as well as changing the format from MP3 to Ogg Vorbis (or vice
+versa).
+
+WWW: http://www.oddsock.org/tools/streamTranscoder/
+
+- Mark
+mark@mkproductions.org