aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 02:25:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 02:25:39 +0000
commitadd996bba32444ec46d60744b7c273f6fd31982d (patch)
tree291659698e818dda9f808975302ba38054cea1de /audio/streamtuner/Makefile
parent900dfa479e53e75bba1697fbdc85ebc141e7b793 (diff)
Notes
Diffstat (limited to 'audio/streamtuner/Makefile')
-rw-r--r--audio/streamtuner/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index 366aa112f828..7420a4ad225e 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= streamtuner
-PORTVERSION= 0.99
-PORTREVISION= 1
+PORTVERSION= 0.99.99
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,8 +22,10 @@ USE_X_PREFIX= yes
USE_GNOME= gtk20 gnomehack gnomeprefix
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETOPT_LONG= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= SHOUTCAST "SHOUTcast plugin" on \
LIVE365 "Live365 plugin" on \
@@ -74,10 +75,11 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON="@comment "
.else
PLIST_SUB+= PYTHON=""
-USE_PYTHON= 2.2+
+USE_PYTHON= 2.3+
# we need to manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygtk2
.endif
.include <bsd.port.post.mk>