aboutsummaryrefslogtreecommitdiff
path: root/audio/sweep
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /audio/sweep
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'audio/sweep')
-rw-r--r--audio/sweep/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index 504e2eccb71a..a196f9f79d4e 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gtk12
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \