aboutsummaryrefslogtreecommitdiff
path: root/audio/sweep
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 08:56:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 08:56:01 +0000
commit7f2f76366e13348b97179c2221844c7dff28d595 (patch)
tree3527cb421c19f7696ede53de44778118a2d2b890 /audio/sweep
parent173e1b87805885b7e4d1922de705739828179168 (diff)
downloadports-7f2f76366e13348b97179c2221844c7dff28d595.tar.gz
ports-7f2f76366e13348b97179c2221844c7dff28d595.zip
- Trim Makefile header per new guidelines
- Drop leading indefinite article from COMMENT - Remove shlib ABI versions from LIB_DEPENDS - Minor whitespace fixes while I am here
Notes
Notes: svn path=/head/; revision=312960
Diffstat (limited to 'audio/sweep')
-rw-r--r--audio/sweep/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index b9828221d846..a3b27f075ee9 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sweep
-# Date created: 25 September 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sweep
PORTVERSION= 0.9.3
@@ -13,19 +9,20 @@ CATEGORIES= audio gnome
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A sound editor for the GNOME/GTK 2.0 desktop
+COMMENT= Sound editor for the GNOME/GTK+2 desktop
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
- samplerate.1:${PORTSDIR}/audio/libsamplerate \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS= mad:${PORTSDIR}/audio/libmad \
+ samplerate:${PORTSDIR}/audio/libsamplerate \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ speex:${PORTSDIR}/audio/speex
USE_BZIP2= yes
USE_GNOME= gnomehack gtk20
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
@@ -35,10 +32,10 @@ CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-ogg-libraries=${LOCALBASE}/lib \
--with-ogg-includes=${LOCALBASE}/include/ogg
-MAN1= sweep.1
+MAN1= ${PORTNAME}.1
post-patch:
@${REINPLACE_CMD} -e 's|^ac_enable_alsa=yes|ac_enable_alsa=no|g ; \
- s|$${datadir}|$${datarootdir}|g' ${WRKSRC}/configure
+ s|$${datadir}|$${datarootdir}|g' ${WRKSRC}/configure
.include <bsd.port.mk>