aboutsummaryrefslogtreecommitdiff
path: root/audio/swh-lv2/Makefile
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-19 17:48:03 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-19 17:48:03 +0000
commitb2bab33a808397f910e7b8e01b692f7ce14f7963 (patch)
treeb589130a178594f309c7a69f87cf657633a7a715 /audio/swh-lv2/Makefile
parentebccb3f308d8ff4f22b2f4a2403b93a57eb31766 (diff)
downloadports-b2bab33a808397f910e7b8e01b692f7ce14f7963.tar.gz
ports-b2bab33a808397f910e7b8e01b692f7ce14f7963.zip
Steve Harris' LV2 version of Plugin Collection.
WWW: http://plugin.org.uk PR: 221384 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12081
Notes
Notes: svn path=/head/; revision=448345
Diffstat (limited to 'audio/swh-lv2/Makefile')
-rw-r--r--audio/swh-lv2/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/swh-lv2/Makefile b/audio/swh-lv2/Makefile
new file mode 100644
index 000000000000..ab19c0c932d3
--- /dev/null
+++ b/audio/swh-lv2/Makefile
@@ -0,0 +1,29 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= swh
+DISTVERSION= 1.0.16-4
+DISTVERSIONSUFFIX= -g1aa77e5
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= SWH Plugins in LV2 format
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ ${LOCALBASE}/include/fftw3.h:math/fftw3 \
+ xsltproc:textproc/libxslt
+LIB_DEPENDS= libfftw3f.so:math/fftw3-float
+
+USES= gmake pkgconfig localbase
+USE_GITHUB= yes
+GH_ACCOUNT= swh
+GH_PROJECT= lv2
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/*.lv2/*.so
+
+.include <bsd.port.mk>