aboutsummaryrefslogtreecommitdiff
path: root/audio/swhplugins/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-02-28 11:01:00 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-02-28 11:01:00 +0000
commit196c16bdde247f0776cb2e58e147a7f888dc7a97 (patch)
treece8864e16b3c105de9207eb0a6b32fbb1ebd3b9c /audio/swhplugins/Makefile
parentbfb72fe5433ac4e00645d5ac49bf782fc3d703e1 (diff)
downloadports-196c16bdde247f0776cb2e58e147a7f888dc7a97.tar.gz
ports-196c16bdde247f0776cb2e58e147a7f888dc7a97.zip
Notes
Diffstat (limited to 'audio/swhplugins/Makefile')
-rw-r--r--audio/swhplugins/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index c46dfbe5f176..b3fc8afbbcab 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= swhplugins
-PORTVERSION= 0.4.2
-PORTREVISION= 2
+PORTVERSION= 0.4.3
CATEGORIES= audio
MASTER_SITES= http://plugin.org.uk/releases/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -19,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
# includes assember code
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
USE_GETTEXT= yes
USE_REINPLACE= yes
@@ -27,8 +26,9 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-fPIC -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
INSTALLS_SHLIB= yes
post-patch:
@@ -38,5 +38,6 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|#include <bits/nan.h>||g' \
${WRKSRC}/gverb/gverb-test.c
+ @${REINPLACE_CMD} -e 's|-lrt||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>